Renderer in Rhino 6 Mac

Rhino crashes when trying to render a drawing. It can be the smallest to the biggest rest.

Sorry, the last word is resolution.

Sorry, my question was about Rhino crashing when I am rendering a model. I was able to render a complicated model without a problem, even if it took quite a while, but these last few days Rhino crashed several times after clicking the render command and also using different resolutions.


Envoyé de mon iPhone

Hi - I moved your latest post to this thread as the other thread where it appeared was about copy-paste issues.

We will need some more information about this problem with rendering.
You write that you used to be able to render without problems. What has changed?
Does the crash happen with any model, like a simple box in a factory-default template file?
Are you sending in crash reports?
Please run the Rhino SystemInfo command and post the result here.


I will try different objects. The only thing that has changed is that the Rhino version is no longer the beta.



Envoyé de mon iPhone

So the problem has been solved?

Hi - which problem?

New question. When I use the rendered mode of objects in the workplace they are black, what can I do so that they are white like they are sunlit?

Wim - I have the same problem while attempting to render a very simple model within the Rhino 6 evaluation installed last night. Crash report and System info follows:

Rhino 6 for MAC trial crash when render

Anonymous UUID: F8791461-74C1-B665-9B38-DA0C65ABB2BB

Sun Nov 10 23:39:19 2019

*** Panic Report ***

panic(cpu 4 caller 0xffffff80142dd16d): Kernel trap at 0xffffff7f952bb716, type 14=page fault, registers:

CR0: 0x0000000080010033, CR2: 0x0000000000000030, CR3: 0x000000046b9dd0a4, CR4: 0x00000000001626e0

RAX: 0xffffff81e0044010, RBX: 0x0000000000000000, RCX: 0x0000000000000008, RDX: 0x0000000000000006

RSP: 0xffffff9246393780, RBP: 0xffffff92463937f0, RSI: 0x0000000000000000, RDI: 0xffffff81b39c91f0

R8: 0x0000000000000000, R9: 0xffffff8014a9fa30, R10: 0xffffff8014a9fa50, R11: 0xffffff921548aff0

R12: 0xffffff9246393898, R13: 0xffffff81e0044010, R14: 0x0000000000000008, R15: 0xffffff81e0035000

RFL: 0x0000000000010293, RIP: 0xffffff7f952bb716, CS: 0x0000000000000008, SS: 0x0000000000000010

Fault CR2: 0x0000000000000030, Error code: 0x0000000000000000, Fault CPU: 0x4, PL: 0, VF: 0

Backtrace (CPU 4), Frame : Return Address

0xffffff9246393250 : 0xffffff80141af82d

0xffffff92463932a0 : 0xffffff80142eb795

0xffffff92463932e0 : 0xffffff80142dcf4a

0xffffff9246393350 : 0xffffff801415cae0

0xffffff9246393370 : 0xffffff80141af247

0xffffff9246393490 : 0xffffff80141af093

0xffffff9246393500 : 0xffffff80142dd16d

0xffffff9246393670 : 0xffffff801415cae0

0xffffff9246393690 : 0xffffff7f952bb716

0xffffff92463937f0 : 0xffffff7f952baa28

0xffffff9246393870 : 0xffffff7f952bbf6c

0xffffff9246393900 : 0xffffff7f952bc7f2

0xffffff9246393960 : 0xffffff7f951f95e1

0xffffff92463939a0 : 0xffffff7f952bc4d0

0xffffff92463939f0 : 0xffffff7f951efdb8

0xffffff9246393a80 : 0xffffff8014888a2c

0xffffff9246393ae0 : 0xffffff8014886c50

0xffffff9246393b30 : 0xffffff801488ff92

0xffffff9246393c70 : 0xffffff80142970c6

0xffffff9246393d80 : 0xffffff80141b506c

0xffffff9246393dd0 : 0xffffff801418fa91

0xffffff9246393e50 : 0xffffff80141a42fe

0xffffff9246393ef0 : 0xffffff80142c3e87

0xffffff9246393fa0 : 0xffffff801415d2c6

Kernel Extensions in backtrace:[2B970BDA-3F88-31F1-9A04-D52B72F2D784]@0xffffff7f951eb000->0xffffff7f9528ffff











BSD process name corresponding to current thread: Rhinoceros

Mac OS version:


Kernel version:

Darwin Kernel Version 18.5.0: Mon Mar 11 20:40:32 PDT 2019; root:xnu-4903.251.3~3/RELEASE_X86_64

Kernel UUID: 4170BF94-38B6-364F-A1B0-2F7C2C30F9A9

Kernel slide: 0x0000000013e00000

Kernel text base: 0xffffff8014000000

__HIB text base: 0xffffff8013f00000

System model name: MacBookPro11,3 (Mac-2BD1B31983FE1663)

System uptime in nanoseconds: 275524658719

last loaded kext at 26680160025: 1.10 (addr 0xffffff7f958e8000, size 69632)

loaded kexts: 1.10 96 1.9.5d0 1.70 20.036.15 3.0 110.25.2 2.7.0d0 1.0.0 3.13 282.54 282.54 3.30.14 3.30.14 3.6.5 12.0.0 1 1.0.1 6.0.11f4 1 12.0.8 7.0.0 1 4.1.0 12.0.0 3.30.14 3.1 12.0.8 1 3.30.14 212 6.8.0 1.0.0 4.0.0 3.1.2 170.12.11 1.5.6 6.0.11f4 408.250.3 456.250.6 456.250.6 255 255 255 3.0.1 2.1.3 407.200.4 1.0.0d1 40 1.0.0 1.0 945.250.134 329.200.2 1.0 1400.1.1 1.8 161.0.0 6.1 2.0 2.1 6.1 1.7 190 8 6.0.11f4 2440.7 2440.2 1.0 282.54 528 12.0.0 740.1 740.2 1.1.0 1 12.0.0 1.0 3.30.14 282.54 282.54 1.0.14d1 404.8 255.4.2 3.30.14 3.30.14 1.0.0 1.0.0 6.0.0d8 1.0.0 4.2.0 5.6.2 1.1.0 530.51 1.0.18d1 530.60 208 6.0.11f4 6.0.11f4 6.0.11f4 6.0.11f4 4.0.4 263 315.6 1.2 206.5 1.2.0 5.0.0 5.0.0 1.2 1.2 11 1 900.4.2 3 301.250.5 288 5.6.2 5.6.2 2.1.4 4.7.6 6.8.4 1200.12.2 1.0.1b8 1.0.4 3.0.60 1.2 1.2 1.0 900.4.2 1.2 2.1 2.1 1.1 2.0.0 3 300.0 1.0.0d1 493.0.0 28.30 1.0 2 456.250.6 1.0.5 145.200.2 408.250.3 408.250.3 2.1 1 1.0 1 1.2 1.0 1.0 1.0.1 1 740.2 3.4 47 6.1 3.1.9 2.9 1.4 1 1 1.0


Model: MacBookPro11,3, BootROM, 4 processors, Intel Core i7, 2.3 GHz, 16 GB, SMC 2.19f12

Graphics: kHW_IntelIrisProItem, Intel Iris Pro, spdisplays_builtin

Graphics: kHW_NVidiaGeForceGTX750MItem, NVIDIA GeForce GT 750M, spdisplays_pcie_device, 2 GB

Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343147533641465238412D50422020

Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343147533641465238412D50422020

AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x134), Broadcom BCM43xx 1.0 ( AirPortDriverBrcmNIC-1305.8)

Bluetooth: Version 6.0.11f4, 3 services, 27 devices, 1 incoming serial ports

Network Service: Wi-Fi, AirPort, en0

Serial ATA Device: APPLE SSD SM0512F, 500.28 GB

USB Device: USB 3.0 Bus

USB Device: G-DRIVE mobile

USB Device: Apple Internal Keyboard / Trackpad

USB Device: BRCM20702 Hub

USB Device: Bluetooth USB Host Controller

USB Device: Keyboard Hub

USB Device: USB Receiver

USB Device: Apple Keyboard

Thunderbolt Bus: MacBook Pro, Apple Inc., 17.1

System info:
Rhino 6 SR19 2019-10-25 (Public Build, 6.19.19298.01152, Git hash:master @ 01a413724f36af3118af8e0ad5305b6671ef66be)
License type: Evaluation, build 2019-10-25
License details: Stand-Alone
Expires on: 2020-02-08

Apple Intel 64-bit macOS Version 10.14.4 (Build 18E226) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro11,3
Machine name: Peter’s MacBook Pro
Language: en-US (MacOS default)

NVIDIA GeForce GT 750M OpenGL Engine (OpenGL ver:4.1 NVIDIA-12.0.23 355.

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB
Graphics: NVIDIA GeForce GT 750M
Displays: Color LCD (221dpi 2x), U28E590 (214dpi 2x)

Graphics processors
Intel Iris Pro (1536 MB)
NVIDIA GeForce GT 750M (2 GB)
Color LCD (1440 x 900)
U28E590 (2560 x 1440 @ 60 Hz)

USB devices
WesternDigital GTech: G-DRIVE mobile
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
Logitech: USB Receiver
Apple Inc.: Apple Keyboard

Bluetooth devices
Apple: Apple Magic Mouse

Third party kernel extensions

Third party plugins

Rhino plugins
/Applications/ “PanelingTools” 6.19.19298.1002
/Applications/ “Grasshopper” 6.19.19298.1152
/Applications/ “IronPython” 6.19.19298.1152
/Applications/ “Commands” 6.19.19298.1152
/Applications/ “Snapshots” 6.19.19298.1002
/Applications/ “RDK_EtoUI” 6.19.19298.1152
/Applications/ “Displacement” 6.19.19298.1002
/Applications/ “Renderer Development Kit” 6.19.19298.1002
/Applications/ “Rhino Render” 6.19.19298.1002
/Applications/ “RhinoCycles” 6.19.19298.1152

Hi Peter - does this crash every time you are rendering or only for a specific model? Are you sending in the crash reports when the dialog appears?
Do you have an external display attached to your laptop?

Hi @gnemob - That crash report doesn’t have enough information in it for us to fix anything; the ones that get sent to us automatically might - though they’re not a ton better. Did you send in the crash report to us via the dialog that appeared?

I did.

okay thanks, when it was crashing, it skipped the designed crash dialog box.
i’ve sent report and system info to tech support.

the next day the sample model rendered without a hitch. hmmm.

and yes i’m connected to another external monitor…

A post was split to a new topic: Assigning textures

Hello again Brian,
While saving a retraced drawing to a file I had a second window open and when trying to turn the model in that second window the rhino window turned completely red. When I stopped the screen went back to normal but the model was frozen. What is that?

J. Neill

Hi Joe, sorry I missed this - what version of Rhino for Mac are you running?

Hi Brian,
It is 6 and it is updated to the latest version.There was no problem using the normal renderer, only the raytracer.

Hello again Brian,
I am getting more and more mystified by this Rhino version. I haven’t used this machine for 2 days and when I started rendering a drawing the raytracer is now functioning considerable slower than previously. The last time I used it the raytracer was rendering a little more than 1 pass per second. Today it is 5/6 times slower. What gives?


Hi Joe-

We are investigating a display related bug that might be impacting you.

If you simply open the file in question - and do nothing else at all except switch the viewport to Raytraced mode - does it raytrace at the “normal” speed?

Hello Brian,
It turns out that the drawing in question is very big, 205Mo so that explains the speed. However, the real problem is saving said drawing in “save viewport to file”. I have tried another drawing and when saved the title is there but no image. I did do a test with a simple cube with a texture applied and it worked fine. This is a problem that has developed progressively. I did not have this problem a month or so ago.

As far as the GPU is concerned mine is a Radeon Pro 580X.

Is there a special technique for applying a photo to a surface that allows it to be projected correctly? I have tried it through the materials panel and the image is distorted.


Envoyé de mon iPhone