Rendering time comparison (example file included)


(Marinus) #1

Hi guys, I’m having trouble rendering. Even simple things take very long.

So, I was working on a file and when I rendered at: 1600x1200 pixels @ 300 dpi and it told me it would take an hour to render… I decided to share the file here and see what times you are getting. If you have the time and energy to open the file and simply render it at the same settings, that would be great. It’s not about the final rendering, it’s just to get an idea of what times rendering of this file will take.

I am using a very fast Macbook Pro with a dedicated GPU but I am not noticing anything of it. Rendering a simple scene feels like doing it with a 16Mb Voodoo II from 1996.

The file can be found here:
mitersawbox_v2.3dm (2.3 MB)


#2

when i open that file and click render, it takes 5 seconds to complete.

    Rhinoceros version:  5.0 WIP (5A772w)
    OS X version:  Version 10.10.2 (Build 14C109)

    Hardware model:  iMac14,2
    Processor:  Intel Core i7-4771 CPU @ 3.50GHz
    Memory:  24 GB

    Graphics:  NVIDIA GeForce GTX 780M 4096 MB

are you sure the file you uploaded is using the same settings as the file which is taking your computer an hour to complete?


(Marinus) #3

Hi, thanks for checking, yes I am 100% sure this is the file I’m rendering.

Maybe I should do a 100% wipe of any Rhino system files and do a fresh install. Does anyone have advice on how to do that? If I can’t get it to work, maybe there is a defect in my laptop…

*Did a reboot, hardware check, system status check etc.
Didn’t make a difference, no problems are reported. I’m not happy.


#4

instead of wiping rhino, you can reset it to default values… in the event of having a corrupt rhino .plist, this will fix it.

• Quit rhino
• open a terminal window (Applications/ Utilities/ Terminal.app)
• type or copy/paste the following then press return:

defaults delete com.mcneel.rhinoceros

launch rhino and it will be as if it’s the first time you installed… all preferences will be reset to default and any custom settings (display modes etc.) will be gone.

if you want to back up the .plist you have now prior to resetting (you’ll also be able to restore the current .plist if need be)… follow the more detailed instructions here:

http://wiki.mcneel.com/rhino/mac/resetprefs




EDIT- fwiw, i just tried the file on a 2core 2010 15" MBP and it still renders relatively fast… around 5 seconds

Rhinoceros version:  5.0 WIP (5A772w)
OS X version:  Version 10.10.2 (Build 14C1514)

Hardware model:  MacBookPro6,2
Processor:  Intel Core i7 CPU       M 620  @ 2.67GHz
Memory:  4 GB

Graphics:  NVIDIA GeForce GT 330M 512 MB
Screen size:  1680 x 1050

(Marinus) #5

Hey, thanks for your help. I reset everything, Rhino looks like the first start, however… Rendering is slow as ever…

About half an hour for the file I linked earlier in this topic.

The Mac OS hardware check told me the hardware is okay. Only thing I can think of is to do a completely new and fresh install of my OS to see if that solves the problem.


#6

[quote=“ohmarinus, post:5, topic:18814, full:true”]Only thing I can think of is to do a completely new and fresh install of my OS to see if that solves the problem.
[/quote]

hmm… that sounds a bit extreme and you might want to wait to see if anybody else has some ideas regarding this.

but i guess if you’re going to reinstall OS X, make sure to do a clean install… otherwise, i think many of the existing files are still going to be hanging around on your computer.


(Marinus) #7

When I render a different object with reflections and such, I get the render almost instantly. For example when I’m using the ‘gold’ texture on a bracelet I’ve designed.

I’m not sure if my computer is the problem.

In the file supplied, when I unlink the texture, the image renders fine within seconds. I was using the texture ‘beech’ to render. This causes the render to take around an hour. No texture = seconds. I think there is a problem with the renderer when you use textures?


#8

Maybe the textures isn’t a straight RGB. We had the same problem with vray some years ago.


#9

possibly… i haven’t done too much with the updated renderer yet so i don’t really know what type of problems may exist there.

fwiw, your file is using the beech texture when i render it… and it’s still fast for me.
?


#10

Your model, while elegant in the joinery detail is quite simple and should render quickly. I opened the file and rendered in Flamingo on my windows machine. It did 72 passes in one minute. I changed the mesh settings to a level higher than I would normally but considering the simplicity of you model thought would pose a challenge. It rendered instantaneously on screen and I got 65 passes in one minute in Flamingo.

So, what is the problem with your scenario. Have you set your render meshes too high? Do you hear you laptop fan cranking up to cover the cpu load? If you don’t, then there is a problem there. Most renderings are cpu intensive; more so than gpu intensive.

Best of luck, Rob


(Pascal Golay) #11

Is the texture image stored locally, or on a network?

-Pascal


(Marinus) #12

Hi Pascal, they are stored locally on a high speed SSD which has enough free space…

I am using the Beech material. No idea why it does this.

One pointer might be that when I render and it starts taking long, the log window said something like ‘calculating light tables’.

However, rendering without materials is almost instantly. Sadly this means I can’t even render a simple object with materials.


(Marinus) #13

Hi Rob, indeed, the fans speed up, I’ve checked the system core to see which programs use RAM, CPU and GPU, when Rhino is rendering it is using the CPU fully. Nothing wrong there. I guess there is an incompatability with Rhino when I’m rendering objects that use materials with textures.


Rendering again very slow?
(Brian James) #14

What OSX version are you using? Also, what is the Mac hardware exactly. Sorry, if I’m missing this info here but I’m wondering if you are using OSX 10.9.5 specifically. Can you also check that the skylight is off when the rendering is calculated. This render property may not be transferring with the file you posted… it still renders in a couple minutes with the skylight on and the texture displayed here in 10.10.2 but I want to make certain what your setting is for the skylight. Without the skylight it’s 5 seconds like others reported.

Let me know all the info on your OSX version and hardware please.

@marlin @andy


(Marlin Prowell) #15

I have looked at this and determined that this is a problem inside OS X 10.9.5. It likely also exists in OS X 10.8.5, but I did not check this. I ran the following tests on a mid-2013 MacBook Air using build 5A783w. Identical hardware and identical copy of Rhino software.

On 10.9.5, rendering the model in the first post takes 6 minutes 53 seconds.
On 10.10.2, rendering the model in the first post takes 6 seconds.

This explains the difference between your results and the results everyone else saw when rendering your model.

I traced into the rendering code, and the delay is entirely inside Apple routines (on 10.9.5) for manipulating bitmaps.

I tried to find some easy workarounds but was not successful.

At this point, I would suggest upgrading to OS X Yosemite to get much faster renders. We will look at this some more in the future, but the simple fix right now is for you to upgrade to Yosemite.


(Marinus) #16

Hi, I will try and make a nice printout of my specs for the forum. I’ve seen others do it, but don’t know how to myself.
Ah, found it:

Software information

Software versions
Rhinoceros version: 5.0 WIP (5A783w)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.9.5 (Build 13F34)

Plug-ins
None

Third party kernel extensions
at.obdev.nke.LittleSnitch (4216)
com.nvidia.CUDA (1.1.0)

Hardware information

Computer hardware
Hardware model: MacBookPro11,3
Processor: Intel Core i7-4850HQ CPU @ 2.30GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 750M 2048 MB
Memory: 2048 MB
Screen size: 1680 x 1050
Displays: Color LCD (258dpi 2x)

USB devices
Apple: Internal Memory Card Reader
A4TECH: USB Device
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: Apple Internal Keyboard / Trackpad

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.26.28 310.40.55b01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


#17

I’m also having problems with very long render times and long times to apply or change materilas. I’ve posted about this a number of times already, however I’m still researching the issue and prefer not to go into the details until I’m closer to isolating the problem.
One thing I have found though is that applying or changing a texture on a large file can take forever - often not being complete after eight or ten hours and requiring a restart.
However if I remove the object from the file and paste it into a new file I can apply or change the material instantly and then past back into the original model.
T


(Marinus) #18

Finally, after a LOT of work. Running Yosemite now and I can confirm that the rendering time has gone down from estimated hours to a mere 15 seconds :smile:

Yosemite is terrible, I miss Mavericks, but I have to render, so I guess I have no choice.

On to solve other problems now. Very happy with the ability to render now!


#19

I aborted a rendering after one and half days and only 25% done. I rebuilt the model loading the surfaces into a new file one at a time. Now happily rendering in less than half an hour at 10x.
Lighting may be part or all of the problem, not sure.
Also running Yosemite. I wish Apple had stopped OS development at Snow Leopard. Looks like too many engineers with nothing useful to do.
Saving materials and getting multiple duplicates with wrong name seems to be problematic but not really affecting my work flow at this time.
Overall very happy with the potential of the new render engine.


(Marinus) #20

Very interesting, do you think it could be possible for me to re-create the rendering problem you’re having? Would sharing a file work?

Now that I re-installed my machine to Yosemite, I’m quite curious to see if I get the same results as you. With the new system, the rendering of my own files is going very smoothly luckily. I was afraid that I was running into a hardware failure, something very frightening when you’re a student and don’t have any backup finance :wink: