Rhino 6 for Mac crashes with Raytraced mode

Hi,

I recently installed Rhino6 on my iMac and I’m running into the issue that Rhino will Crash systematically as soon as I switch the viewing mode to Raytraced.

Thank you for your support !

Lauren

Hi,

I have been experiencing the same problem.
Any support would be much appreciated.

thank you!

Kanto

hi guys, on older hardware make sure you have open cl deactivated and only keep cpu checked under preferences/cycles. otherwise you get a beach ball spinning forever. i have a geforce gt 750 m and it would knock it out either, that also happens on radeon by the way, at least those in the macbook pros from around 2015. the lastest ones or really powerful ones may work.

@encephalon

Hi, thank you for your advice. I tried it but the crash problem still remains…
FYI My macbook pro is from 2013.

K

well mine is a late 2013. how does it crash? with a beach ball spinning forever?

the program shuts down immediately, followed by a crash report.

ok, that sounds actually different. and that happens on an empty viewport with a standard template? if not maybe post the file where that happens, and also post your system info.

i get total crashes only when i am in raytraced mode and using ViewCaptureToFile. it then shuts down. but raytraced itself works once i figured out that i should not activate the graphic card.

i guess @nathanletwory could have a look.

Unfortunately I have not been able to reproduce the crash by just running ViewCaptureToFile.

@encephalon I generally use only the dashed version of the commands, since I don’t want to wait for the previews. Are you using the dialog-version of the command? If so, are you tweaking settings in the dialog still when the crash happens? Or does the crash happen only once you have started the capture from the dialog?

i am a bit confused, i thought this was already acknowledged or at least you had said that you could produce it on a release build.

the dashed version seems interesting, but how do i set it to raytraced while the viewport is in rendered for example. the problem is setting the viewport to raytraced then then using viewcapturetofile crashes it reliably. so there is currently no way to capture a raytraced to file.

anyway the problem here is a different, its about the raytraced mode for those 2 guys above which already seems to crash rhino.

The way I could reproduce a crash was through cancelling the capture once one was started.

The same as for the dialog version. You first set the viewport to Raytraced, then do the capture.

Indeed.

@laurenmcgrady, @saubaone. Can you please post with the text generated by the _SystemInfo Rhino command? Just copy&paste the text from the dialog that pops up.

@encephalon @nathanletwory
The crash happens even with just a simple box with an assigned material (standard one from default library)…
below is my system info.

Rhino 6 SR20 2019-11-19 (Public Build, 6.20.19323.01022, Git hash:master @ f60ce76e397bba419469ae5277fc1578641caa3a)
License type: 商用版, build 2019-11-19
License details: Cloud Zoo. In use by: Kanto Amaze ()

Apple Intel 64-bit macOS Version 10.13.6 (Build 17G9016) (Physical RAM: 8Gb)
Mac Model Identifier: MacBookPro10,1
Machine name: Kanto’s MacBook Pro
Language: en

NVIDIA GeForce GT 650M OpenGL Engine (OpenGL ver:4.1 NVIDIA-10.32.0 355.11.10.10.40.102)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB
Graphics: NVIDIA GeForce GT 650M
Displays: Color LCD (295dpi 2x)

Graphics processors
Intel HD Graphics 4000 (1536 MB)
NVIDIA GeForce GT 650M (1024 MB)
Color LCD (1920 x 1200)

USB devices
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Apple: Apple Magic Mouse

Third party kernel extensions
None

Third party plugins
/Library/Frameworks/iTunesLibrary.framework/iTunesLibrary

Rhino plugins
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.20.19323.1022
/Applications/Rhinoceros.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.20.19323.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.20.19323.1022
/Applications/Rhinoceros.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.20.19323.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.20.19323.1022
/Applications/Rhinoceros.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.20.19323.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.20.19323.1022
/Applications/Rhinoceros.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.20.19323.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.20.19323.1022
/Applications/Rhinoceros.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.20.19323.1002

which crashes rhino. any other options to capture raytraced images to a file?

just tried it again with the lated build is is unchanged and here a crashreport.

crash.txt (152.5 KB)

Can you please ensure that under Preferences > Cycles the render device is set to CPU before trying again to switch to Raytraced? Does that work without crashing?

Your crash has several PDF calls as part of the capture. Not sure how that happens…

Hi,
I’m having the exactly same problem since I updated Rhino two days ago.

No matter what render device I select now, it will crash as soon as I change the render mode to Raytracing.

Thanks

I leave the crash report here:

crashReport.txt (142.0 KB)

Thanks @hvpereira. I see that, like @saubaone, you are on MacOS 10.13 . Perhaps it is possible to upgrade to at least 10.14 for you?

I don’t know what else could be the problem. For me Raytraced works just fine, and without being able to reproduce there is not much I can do :confused:

Don’t know if it’s any help… but I also have a late 2013 MBP and raytrace view capture to file didn’t crash anything.

the Raytrace itself seems to be a lot quicker then it used to be when I last tested it [back in the days when the progress bar was a too small]

  • Nathan please, it is really important to add .PSD to the save options. with at least 16bits. [I guess you probably have it on the to do list already…? so just a reminder]

thanks a lot
Akash

As @encephalon advised, I have been trying with CPU as the render device…
I’m a little hesitant in using Mojabe or Catalina as I was once told my MBP could be too old to cope with those updates by an apple genius.
this is my latest crash report.
crash.txt (133.6 KB)

could you tell me which OS version you are operating on? thank you…

Hi
I’m on 15.1 Catalina
On the update page, they have a list of which model can update to which OS.

Akash

1 Like