Print width not working correctly in Rhino 8

Hello,

I have to print to PDF a Layout.
Layers in the model have assigned PRINT WIDTH set to 0.3 and 0.5
When in preview, these look alright, but once I open the PDF the thickness were not applied. PDF shows as default thickness.
Curiously, if I have the titleblock in Layout area and is on one of the layers mentioned above, these lines HAVE the thickness applied.

Note: I tried opening with Rhino 7 and there is no issue with this. I have been working in Rhino since 2011 so I know how it worked up to R7…

Can someone help me understand if there is a different approach in R8 or this is a bug which needs fixed?

Thank you,

image


can you please run the systeminfo command and post the result, and your file if possible?


file with issues.3dm (662.7 KB)

here you go.

Hi Tiberiu -

The SystemInfo data that Kyle was requesting is what you get when you run that command in Rhino.

From your 3dm file, I see that you are running 8.5. I would recommend changing your update frequency to service release Candidates and let that download a newer version.

Here, in 8.7, this appears to work as expected. When I print to PDF and open that file in, e.g., Inkscape, the line is set to 0,5 mm:

Page 1 - 8.7.pdf (62.1 KB)
-wim

Hello,

It does not work.
When saving or printing to PDF, as VECTOR, from LAYOUT (not from 3D space), it just keeps the same line thickness as the Default. Are there any specific settings that I need to apply when saving/printing to PDF other than the default ones?

I have updated Rhino to latest.

image

I still get the same result… What is highlighted supposed to have same thickness as the drawing border (yes they are on separate layers, but the line thickness is the same - drawing is in viewport whilst the border is in layout)

T.

Hi all - I’m having an issue that might be related to Tiberiu’s. Since upgrading to Rhino 8 I’m finding some layers that are set to Hairline are printing much thicker in PDF outputs. Hairline layers work fine when set to that thickness globally, but when I override a layer’s setting in the Detail Print Width column for a given detail view, the thickness shows as “0” in the layers list rather than “hairline”, and the objects print thicker than hairline.

I’ve updated to 8.6 but same issue. It used to work fine in Version 7.

Any help would be gratefully received!
Andy

1 Like

Hi all - I’m still having trouble with this. The latest service release (8.7.24101.10002, 2024-04-10) seems to have fixed the issue with displaying Hairline as “0” in the layers list described above.

But I’m still struggling to get things to print to PDF correctly. I’ve attached a couple of examples to this post:

  • Drainage plan v7 - correct line widths.pdf shows how the whole drawing used to look in V7 - the interior walls are over-ridden to Hairline so as to background them
  • Drainage plan v8 - some hairline too thick.pdf shows how the drawing looks now in V8 - the stuff set to Hairline for that view now prints thicker.
  • Test default set to 0.13.pdf shows some example boxes set to different things
  • Test default set to hairline.pdf similarly shows example boxes

The latter two files show how layers I’ve set to Hairline for that detail view appear to be printing at their global setting (0.13 in this case).

Can anyone help with this? It might be I’ve misunderstood how this all works!! But it does seem to be behaving differently since V7, and I can’t think of a way to resolve it - I don’t want to change the global settings as they work for most drawings, and I’ve got lots of drawings sheets referring to the same model.

As an aside, the issue doesn’t appear to be with objects that are part of a linked block - I get the same behaviour whether the object is part of a linked block or just drawn straight into that file’s model space.

Grateful for any advice!!
Drainage plan v7 - correct line widths.pdf (768.1 KB)
Drainage plan v8 - some hairline too thick.pdf (1.1 MB)