Grasshopper pie menu gone in RhinoWIP?

Hi all,

In the latest RhinoWIP for Mac (2018-10-16, 6.11.18289.120269), I cannot open the pie menu in Grasshopper: hitting the spacebar behaves exactly like double clicking on the canvas (“Enter a search keyword”), which is not useful at all, in my opinion.

If it was an intentional change, could you consider reverting to the “old way”? (If not, please tell me, how to call the pie menu forth…)
If it wasn’t intentional, please log it as a bug!

By “pie menu” I mean this:

Thank you!

It is a change that happened quite awhile ago. You get it from middle mouse button or ctrl+spacebar.

Hi Michael,

Neither ctrl+space, nor the middle mouse button works for me.
I don’t know when it happened, I haven’t had the time to try the WIP until now.

I’m not really sure, why these changes are necessary, the best idea would be to leave such customization for the users, e.g. ctrl+space is also occupied for me (the Things quick menu uses it system wide, similarly to cmd+space, which is the shortcut for spotlight, etc.), and although I use an extension to emulate a middle mouse button on my magic mouse, a lot of users I know don’t. A very good example for the above mentioned widely available custumization is the user interface for Cinema 4D, where all the clicks (RMB/MMB/LMB/etc.), modification keys, shortcuts, etc. are up to the user.

All the best!

You can change it in the xml file.

Well, when I open Grasshopper in the WIP, the following happens:

Note, that the application name hasn’t changed from RhinoWIP to Grasshopper (as I presume it should based on my Rhino 5 experiences). Clicking on any of the special folders (components, settings, etc.) has no effect at all, it won’t direct me to the corresponding folder.

In Rhino 5 the Grasshopper settings file (as David explains in the linked forum thread) is located here:


In that file there is no line such as

<item name="Canvas:SpaceIsRadial" type_name="gh_bool" type_code="1">false</item>

so I cannot change it to “True”. Even if I added the line, it has no apparent effect on the behaviour.
(I was searching for “Canvas:SpaceIsRadial”, which returned 0 results.)

So to summarize, the Menus under “File” need a fix as well (Special Folders: none of the Menu items work), so does “Preferences”: the window shows up blank:

I suppose Mac Gh is just behind, sorry I am not familiar with the Mac version so much. That is all the info I have :smiley:

Yup, unfortunately it is still behind…

Thanks for the help though!

You should be able to navigate to Preferences again in the latest RhinoWIP.

RH-49024 “Grasshopper: File > Special Folders unresponsive” is a known issue that we need to fix stat.

1 Like

The xml file you want to edit is here (hex digits in parentheses may be different on your system):
~/Library/Application Support/McNeel/Rhinoceros/6.0/Plug-ins/Grasshopper (b45a29b1-4343-4035-989e-044e8580d9cf)/grasshopper_kernel.xml

Change this line:
<item name="Canvas:SpaceIsRadial" type_name="gh_bool" type_code="1">false</item>

To this:
<item name="Canvas:SpaceIsRadial" type_name="gh_bool" type_code="1">true</item>

Worked for me - I get the “pie menu” when I press the space bar.

If you don’t want to make this change, you can still access the “pie menu” by pressing “fn-command-space”


You should be able to get to the Special Folders again in the latest RhinoWIP.

1 Like

A post was split to a new topic: Grasshopper window disappears when it becomes inactive