Disable enter repeat command on right mouse button

Is there a way to do this? I can’t find anything relating to it anywhere…
I use a Wacom tablet, as well as a mouse, but I generally only use the mouse for the scroll wheel, and a macro on the middle button.
The problem is that when I want to rotate the view, which requires the right (pen) button, it’s too easy to fire the enter command, which of course repeats the last command.
It’s driving me nuts!

Thanks
rabbit

1 Like

There’s no way to fully disable RMB as "enter"
In Options - Mouse, there is a RMB Delayed context menu.
If you set the delay to 1 millisecond, then even a quick right mouse click will bring up the Context menu instead of triggering an enter.

My guess is that won’t help your issue that that’s all there is as far as I know.

Hmmm… how many enter keys do we need? There’s ‘Enter’ as enter - there’s RM as enter, and there’s the space bar as enter.

My choice would be to allow the user to change of the space bar to another function, my choice would be the ESC key, cancelling the current command and deselecting everything.

Well, of course the next question is why?
Why are we forced to accept (a: enter repeating the last command, and (b: having enter hard coded to sundry buttons/keys other than the natural one handed down thru the mists of time from the great querty keyboard gods on high?
Why?

cheers
rabbit

Agreed that apart from Enter, space and RMB should be customizable…

@rabbit: As for repeating commands with Enter/RMB - in General Options there is a list of commands that should never repeat: “Defines a list of commands that will not repeat when you press Enter.
Note: Only command names can be flagged as do-not-repeat. If a command is in a macro, it will repeat even if it is on this list…”

Not sure what will happen if you try to paste tons of (all?) rhino commands there, but may be worth a try.

Thanks Jarek - I already have a stack of commands in there…surely it is not a “solution” to paste every rhino command in there??

The solution is to recode so enter is not hardwired into anything except the enter key(s)…and to allow the user to disable enter=repeat if they don’t want it…

cheers
rabbit

Thread from the dead… just to say this…
BOOOOOOOOOOOOO
Why on earth is RMB the same as pan… We need an option to kill the repeat command on right click.

Is there anything in rhinocommon that will do this?

What happens is this, I curve boolean lots and lots and lots of items… go to pan, and then it accepts it when I am only half way done.

When I was hired here, that was the VERY first thing I noticed with rhino, and I have been shaking my head ever since.

Not sure why I only have this problem on this computer but yes, why all of a sudden is RMB repeating the last command? It is supposed to just pan? That is one of the big reasons I like rhino!! Hate middle mouse pan on autocad.

If the mouse isn’t moving the RMB click is an Enter.
RMB click and hold, drag, release, is Pan/Rotate

Then maybe I am being too quick with my mouse. But I hate the RMB repeat the last command with a vengeance. Surely it can be made an option? Please?

In fact, I just went back to work, panned, and suddenly I am back here in the forum!!! This is bonkers!!

@Tim_Perry
There is one thing you could try:
In Options > Mouse, there is a setting for the right-mouse button “Delayed context menu”. The default is 250ms or 1/4 of a second. If you shortened that up to 1ms, the a right-mouse click would either Pan (if the cursor is moving), or open the context menu, and likely never just repeat the last command.

This might replace one frustration with another but it’s worth a try and it works now.

I have this set to 300 at present - it seems to work ok most of the time as far as disabling enter goes on my ancient laptop…
…but this whole thing is ridiculous! Why is there this almost religious insistence on hard coding “enter” all over the place, instead of simply allowing the user to CHOOSE whether they want this behaviour or not?
Please can this be addressed within V6 before it is released.???

Thanks
rabbit

1 Like

Thanks John, I’ll give that a go.

No, still driving me nuts. Whatever setting or delay I use, it still fires up the last command 2 or 3 times out of 5. I can’t see ANY benefit for this option, but I understand there will be others who find it useful. BUT PLEASE PLEASE PLEASE PLEASE find a way of disabling it completely. OFF. Disconnected. Not working under any circumstances unless I turn it on specifically.

Please.

Thank you in advance.

Please.

There you go. I finish typing, back out to Rhino, move the mouse and I am instantly back here on the forum…

Jeez this is frustrating beyond measure!!! I’ve been a Rhino user since it was on a freebie demo disc on the front of Computer Arts magazine, and this is far and away the most irritating feature I have ever experienced!!

Please fix it. PLEASE!!!

Tim

See my post in Serengeti: disable right mouse button repeat workaround…

cheers
rabbit

( this post )

I tried to use another mouse and it helped for me. Apparently a small hesitation/fail of your mouse RMB can cause all these frustrations…