Mouse right click speed

Hi all! I noticed that in rhino 5 every time I do a minimal rotation using the right button I always activate the last command as well.
This is very annoying and it never happened to me before, has anybody experienced the same issue?
Is there a way to deactivate the “repeat last command” associated with the right click of the mouse? I just want it to orbit around…


Hi aronfini,

You can’t prevent the right mouse from equaling Enter but I can think of two options that may help. Swap out the mouse, it could be a sticky right mouse button or aging connection there or try a 3D connexion device for scene rotation. This would allow you to only use the RMB when running Enter.

Hi Alessandro,

I once had that same problem due to a mouse that was defective. The micro switch under the button was worn down and glitching.
So I’d try another mouse to see if that is causing it.


I also find this unbelievably irritating.
Number one aggravation for using Rhino.
Been using for a few months now every day, and this constantly annoys me.

Hi Bill,

I’m sorry this is making your work more difficult in Rhino. I’m thinking about what possible settings could be added to Rhino to account for different user click duration. The obvious option though would be to disable RMB from equaling Enter but this would have to be a non default option due to most users not having this problem and also relying on RMB = Enter. I’ll bring it up with development to see if a disable option is considerable. Feature request filed as RH-20644. This report is not publicly visible at this time.

In the meantime, can you try another mouse just as a test?

1 Like

Wow ! That was a really quick reply. Thank you for justifying my little rant with an answer.
Obviously from my perspective any way of altering this right hand mouse button behaviour would be a godsend.
I use the space bar to repeat my last command, and spend a lot of time ‘looking round’ my models, as much of what I do is adjusting proportions of a product and so constantly inspecting from all angles seems to help with this.
Hence, I regularly accidentally repeat my last command unintentionally with the RH mouse button.

Hi Bill,

One of our developers offered this work around which might help too. Change the timing for the right click context menu in Options to be 0. This will cause RMB to always launch the Windows context menu in line with normal Windows behavior and thus never allow RMB to equal Enter.

1 Like

That’s amazing !!! Thank you. I will try this and report back, but really appreciate yours and the developers efforts

That’s fantastic ! Works perfectly. Thank you, really appreciated. Screenshot helpful too.

This sort of works - but if you are rotating in Perspective View, and you leave the Right Mouse Button on for a long time as you rotate, you get this pop up menu appearing. This is almost as bad as the repeat Enter problem. Whats a good workaround ? Also, it doesn’t happen every time, but I cant figure out why.

PS - I disabled the Delayed Context Menu Option, and now the Rhino Properties box appears in place of the Shortcut menu ??