Disable right mouse button repeat workaround

Despite posts from myself and others asking for the ability to remove “enter” from the right mouse button, there is just stony silence from McNeel. I use a wacom tablet, and it is just far too easy to fire “enter” when all you want to do is rotate the view. Its also too easy to do this with a regular mouse also.
Anyway, I wont go into it again because I’ll just get all upset, but in the meantime here is what i have done to get around it, in both V6 and V5:

disable right mouse button V6:

options, advanced - scroll down to entries for right mouse button.

Set:

rightMouseDownRemap to 1
rightMouseMoveRemap to 1
rightMouseUpRemap to 1

This disables the right mouse button (except for selecting via a crossing window & maybe something else I haven’t come across yet). I have no idea what this actually is supposed to do since I can find no help on it, but for the moment it seems to work to disable the button.

Now, in options, mouse, set the middle mouse button to manipulate view rotate.

This gets the middle mouse button to rotate the view, as the right mouse button previously did.

Finally, in the Wacom properties, set the secondary pen button to middle click. This allows that button (previously assigned to the right button) to rotate the view as before, but without firing off enter all the time.
It unfortunately also sets it to middle button for every other program…but I use rhino more than anything else, so I just have to live with it.

In V5:

There isn’t an advanced set of options, but something similar can be done by just setting the middle mouse button to rotate the view, then altering the wacom properties as above.

The other way to probably do this is to open the mouse and physically disable the right button permanently, and then use this mouse for rhino only. This has obvious problems if you are going to multitask with other programs on the computer but I was so annoyed that I was going to do that very thing if the above hadn’t worked.

The whole situation is ridiculous - why should i have to go to such lengths to try to configure my computer and my copy of the software to work how I want…??

I’ll ask one more time again: Please give the user the option to disable “enter” on the right mouse button.

cheers
rabbit

1 Like

Thanks Rabbit, I will look into this. I did have some success damping down the effects by slowing down the click speed on my mouse, using the Windows mouse control settings, but it still happens, and of course now using my mouse feels like trying to write while wearing boxing gloves!! I will fiddle around with the click speed settings to balance this a bit less but you are dead right, the option should simply be switchable. I see know utility in the option anyway, other than to irritate users like you and me! At which, it is extraordinarily effective!

Anyway, thanks again, I’ll report back when I have had a play…

Hi Tony - I added your comments to the bug/request item.

thanks,

-Pascal

I agree it would be nice to disable RMB=enter, but many users have just been so accustomed to this functionality for so long we haven’t made a fuss. Nearly 20 years in Rhino, and then in Autocad before that. True, we could disable it in Acad, but we didn’t because it’s a timesaver.

Oddly just tonight I started having a major issue with it while trying to pan around. Took me 10 minutes before I figured out my wireless mouse batteries were dying and was causing a lag between click and drag.

EDIT: OK mouse was not the problem. This is now messing me up big time. I have no idea what has changed with my setup after years of no major issue with this. Now can’t do my curvebooleans like I need to. RMB is activating enter prematurely while panning.
I’m continuing to troubleshoot…

Hi, thanks for this! It solves the issue on windows, however, can I disable the command on mac as well? I’m working on two different machines and it drives me nuts on both.
Thank you!
Kama

I’d also like to see a way to disable this in macOS. I’ve been bitten by this often while rotating the view and picking edges.

Thanks!

Placing 0 (cero) to the "Context Menu Delay " has solve this for me, now i can have the context menu and use the middle button for pan etc

Thanks rabbit! This has been bothering me for a while now. I am working on a plugin that requires that I select some vertices on a mesh. I would be continuously kicked out of its execution because I wanted to rotate my view around to select more points. At first I thought I was coding something wrong on my end, but it turns out this has been an ongoing issue.

When it came to V6 (on Windows 10), I was able to disable the “enter” functionality using your idea by Setting:

rightMouseMoveRemap to 1
rightMouseUpRemap to 1

However, I left rightMouseDownRemap alone. This leaves the rotate/pan functionality with the right mouse button, without having the frustration of accidentally “entering” with the RMB.

Let me know if this helps at all.

Robert

There should be an option to disable it, but if RMB = Enter is removed from Rhino, I swear I’m gonna murder somebody. :smiling_imp:

yeah - thanks robert.

so this seems to be the way to do it with V6 - (I’m on windows 7 so I think any version of windows that will run V6 is ok.)

rightMouseMoveRemap - 1
rightmouseUpRemap - 1

rightMouseDownRemap - leave at default

which cleanly seems to disable “enter” being called by the right mouse button.

Who knows if this is really correct or there is a better way? - All I can say is it seems to work without any side effects so far…


As for V5, there is no other way to get around this I have found except that offered in my original post.

cheers
rabbit