Windows cloud zoo licensing- how to fix when it misbehaves

In rare occasions with Rhino v6 (and even rarer in v7) you may encounter a cloud zoo (rhino account) licensing loop that says something like “rhino needs a license, please enter your email” which you will do, and see “license found! log in with (your name)” which you do, and that takes you your rhino account, which asks you to login and allow access, then says "login successful " go back to rhino-

when leads you back to rhino which says “rhino needs a license”

and then you use grown up words and throw your keyboard across the room…

good news! There are two fixes for this. One easy, and one slightly more advanced easy…

Easy method-
when rhino pops up the dialog asking for your email, look in the lower left and click options.

-click remove license
-rhino will close.
-re-lauch rhino and that same dialog should pop up.
-enter your email and click next
-rhino should find your license
-login to your account and click allow.
-go back to Rhino and wait a few seconds, rhino should launch this time.

If that fails, the more advanced method is:

  • close rhino and go to this folder in a file browser

%appdata%\McNeel\Rhinoceros\6.0\License Manager\Licenses

-clear the contents of the folder but KEEP the folder.
-empty your trash.
-restart rhino, and enter your email and login as prompted.

rhino should start as expected.

-this link points you to a v6 folder, this is correct even if you have v7, or the wip v8.
-please let us know if these fixes do not fix your licensing loop, as we need to help you because something weird is now happening.
-as always, if you can’t sort a rhino problem quickly with a forum or google search, please hit us up at or call 206-545-6877

happy modeling!


I occasionally get messages from my clients about a different problem - like the one I just got a few hours ago:

(Translated from French)
It happens sometimes when have many Rhino files open and I try to open a new one: I get the message “Retrieving license from the manager”, but it doesn’t find the license. At this moment it is impossible to open another instance of Rhino, I try to close the dialog, it asks me for my email address and password to connect, I try entering that but it does not work.

The only remedy I have found is to close all my open Rhino files and then it works again… There are even times - like today - when I have to completely restart my computer…

Don’t know if it’s related, but this is not the first time I have heard of this happening.

I’ve heard of a few reports of that too, and could never duplicate it myself. I’m pretty sure it is a completely different issue.

I am as well, but as it also falls under the heading of ‘fixing licensing that is misbehaving’, I thought it was appropriate to post it here.

1 Like


Need help, please.

I have both my RH7 and RH8 in the “Zoo”

Can I run RH7 and RH8 on the same 'puter at the same time?

If I try I get caught in an endless loop

And so on…

Back to my question can I use both on the same 'puter, at the same time

Thanks in advance

Regards Lawrence

This is a known bug, there are quite a few posts on it from the last few days. They are working in fixing it. In principle yes, you can use both V7 and V8 on the same computer if you have a license of V7 and either the V8 paid upgrade or evaluation license.

Guess I will just wait for the fix

Remove your v7 from your zoo. Remove your v8 from the zoo. Add your v8 back in and your v7 should be added automatically. If not, add it back in. Restart and try both again. This is due to v7 or v6 not being correctly linked to our validation servers and that causes the v8 problem. The fix is to remove both licenses and add v8 back 1st, then v7 unless it goes in automatically.

Is that only in the case where the V8 is an upgrade over the V7?

Can happen from v6 too…

OK, but not with two full licenses…?

Unfortunately this does not solve the endless “Do you want to keep using…” cycle when multiple editions of Rhino are opened simultaneously on the same machine.

Try this- launch v8. Then launch v7. When it asks if you wan to use v7, answer no.

V7 will close. The reopen it… it should come up. Any luck?

I tried all this methods, even logged in successfully on rhino website, but when I came back to rhino, it just always says “fetching license from the cloudzoo”, and nothing happened.


More info on this problem here-

Please add to that thread for more info on this problem.

No, that doesn’t work. You have to close the first instance, not the second. So, to recast your example: Launch v8, Launch v7. When it asks if you want to continue using v8, answer no. v8 will close. Let v7 finish opening, then reopen v8. It will come up.

You can swap v7 and v8 in the above.

Note also that this workaround does not need the deletion and reinstallation of licences - that appears to be a red herring for this particular problem.

1 Like

Thanks, that worked

1 Like