Problem Cloud zoo


Just bought my Rhino 7 licence (upgrade from Rhino 6). Works fine on my laptop but when i try to use the licence via my account on my desktop it’s doesn’t find a valid licence…what’s going on?

I’ve checked multiple times to make sure the licence is in the cloud zoo etc…everything works fine for Rhino 6 on both PCs.

Any Ideas?

Thanks, Seb.

Can you login to you rhino account and confirm that the license has been added to cloud zoo?

If it is there, probably a firewall issue?

Yep, it has been added to the cloud zoo. Not sure about the firewall issue. When I boot Rhino 7, it asks me to login, which I do, everything goes fine until I confirm my account on my browser and then Rhino pops up saying “Rhino 7 needs a licence to work, Rhino will now close”. And that’s it.

Have you tried restarting your computer? IIRC, it can happen that the browser that goes looking for your license in your account ‘goes deaf’ and can’t find it, a computer restart usually fixes it. Don’t know if that is the case for you, but maybe worth a try.

Still doesn’t work, thanks anyway ! :+1:

Problem solved! I got help from a Rhino technicien here’s the answer ( simpler than I thought :sweat_smile:):

Thanks for contacting us.

These steps should fix your issue. Please try it on the affected computer:

  • Open Rhino. You should then see a pop-up message, please click “No”:

Then you should come to the “Welcome to Rhino” window.

  • Check the “I have read and agree…” box:
  • Click on “Options” (bottom left).
  • Click Remove License:

This should trigger the logout process, which deletes the cached credentials.

Open Rhino again and try to login with your Rhino Account

1 Like