Why Selection Filter keeps popping up even when already docked?

Version 8 SR6
(8.6.24101.5001, 2024-04-10)

It suddenly started, but whenever I use filtering (using the selection filter that’s docked), a new selection filter window pops up. Also, it happens whenever I toggle Disable.

How do I make the selection filter behave?

Hello - I do not see this here - but I am not sure I have things arranged as you do - can you go to Window menu > Window Layouts > Save window layout and save what you have and then from ‘Manage window layouts’ Export that layout and post it here?


It only started recently for me, and I haven’t changed the layout. Now I realize the latest update was about 10 days ago. I wonder if the latest update messed up this one.

Here’s the window layout file.

Window Layout.rhw (489.0 KB)

Thanks - I do not see that here so far - can you please try restoring the default window layout, then load and restore the one you posted above - does that behave any better?


Restore default and reload the saved layout didn’t help.
I tried this in a brand new file, but no help.

Any thoughts? It’s really frustrating having to close the popup every time I use the selection filter now.

I can’t help, I can only chime in and say that I had this issue too, but it went away. I have reset and re-done my UI in V8 many times though, so I unfortunately can’t remember what ultimately fixed it for me (but I’m still on V7 for now).

Thank you for confirming this is not just one isolated case. I’ve done resetting a few times, but it didn’t help. Rebooting the computer a few times didn’t help, either. I wonder how many times I need to reset Rhino to get rid of this pesky bug.

I wonder if it has anything to do with where you are trying to dock the toolbar. In V7 I always had it docked to the bottom of the screen, but in V8 I now have it docked below the left tools… I seem to remember I had some issue with it along the bottom.

That’s an interesting point. I haven’t tried docking it anywhere else on top, but the problem only recently started. I wonder if the latest updated caused it.

I sent Window Layout.rhw to @pascal, and he said it worked fine.
@pascal, would it make any difference if you could please try with the template I use as well?

Template 8.3dm (102.9 KB)
Window Layout.rhw (489.0 KB)

Now selection filter is flat out not working sometimes-- not all the time. I don’t know what triggers. There must be some sort of bugs with the latest update since it didn’t happen before.

If you are right-clicking it might be that this bug isn’t fixed yet:

Guess what happened to me just now? :upside_down_face:

I imported a STP file, right-clicked on the blocks filter, drag selected across the entire view, and then exploded…

Hey, turns out it’s even repeatable:


EDIT: Oh, and now I can’t right-click to get back to the previous filter selection… the “new” V8 UI sure is just fantastic! :clown_face:

EDIT 2: Ah, the above was this behavior which is still in there, apparently. Great. Still staying on V7 then.

Can anyone @mcneelsoftware acknowledge this bug and see if this can be fixed, please?

I’ve created a ticket to investigate the unwanted pop up issue. The filters should only pop forward if the panel was previously closed and filters are active. So something’s definitely not right here. RH-82558

@eobet in terms of Right click to re-enable, I was unable to repeat that. Do you have a method to repeat?

I can confirm and repeat this on my setup. I am using mac with the latest build. Version 8 (8.9.24163.15302, 2024-06-11)

This happens when I disable all and re enable selections. I get the window every time. I’ve noticed this before, just never reported it and been dealing with it. It is pretty annoying.

Thank you for reporting. Since I use Selection Filters all the time, it’s been quite annoying to me as well.

me too
[reported this long time ago on another thread].
I deal with this by minimizing that container and sticking it in a corner

It’s just there for me (on two different computers) any time I try V8. But I don’t try V8 that often.

I’ve been chasing this a bit and here’s what I’ve found. It’s a bug feature lol.

The issue at hand is that if the Selection Filter panel is not visible when the filter goes active, its forced visible. That part is correct and by design. However…

Compounding issue: Rhino 8 lets you open multiples of the same panel across multiple containers. In all of the examples I can see that the selection filter is being opened twice. Which means that the selection filter panel exists in multiple containers. When the additional container is not visible, its forced visible. The annoying bug is it doesn’t need to be this aggressive if another container that’s also visible has the selection filters UI in it and its open. I will get that fixed.

Simple solution until I can issue a patch. Tear off the Selection Filter from the container that pops up by dragging on its Tab and close it. Once its detached from the container and closed it shouldn’t reopen.

Once there is only 1 Selection Filter panel tab across all containers, it will no longer pop up any hidden ones.

Let me know if this is what’s happening for you as well.