Viewcapturetofile and rhino render

viewcapturetofile
viewport

#1

In the past I have often used viewcapturetofile to add lines to a render as a separate layer in photoshop. This works well and I often up the resolution of the viewcapturetofile output to improve the quality of the lines (jaggies).

In the past this works perfectly without any messing around. The viewcapturetofile lines would exactly align with the render which makes the work in photoshop effortless and easy to get good results.

I have just tried this using 5.2 and for some reason the viewport extents is different for viewcapturetofile and rhino render. This is really frustrating and makes what was otherwise a great workflow into a ball ache.

Can this be fixed?


(Pascal Golay) #2

Hi Robin - do your viewcapture from a viewport that has the same aspect
ratio as the rendered image and it should work - NewFloatingViewport is a
good way to make a viewport that you can size to taste from the Peoperties
panel.

-Pascal

Pascal Golay
pascal@mcneel.com
www.rhino3d.com
206 545 9260


#3

Hi @pascal

Yes, they have the same aspect ratios. The render is 1500x1200 and the viewcapturetofile is 3000x2400.

I’m not sure how the floating viewport would help but I will give it a go.

Robin


(Pascal Golay) #4

Hi Robin - I mean the viewport itself should have the correct aspect ratio, not just the capture. NewFloatingViewport is a convenience, it is not necessary for the thing to work.

Oh, hold on, I see we’re on a mac here… I bounce around the forum, I didn’t notice… could be different, I’ll check but I don’t think NewFloating etc is on the mac yet, hold on a second.
Yup, you have it- try that, and set the size of the vieport to the capture and render aspect ratio using
-VieportProperties > Size
(note the dash in front of the command, not an underscore in this case)

-Pascal


#5

Hi @pascal

Thanks, I’ll give that a go.

I have done some more experiments. If the -viewcapturetofile is set to the same pixel dimensions as the render then the extents match the render of the same viewport. That is good and what would be expected.

The issue seems to be when increasing the pixel dimensions of the -viewcapturetofile command. On Windows and until recently on the Mac, this would result in a higher resolution version of the same image (ie same extents etc). Now, it seems to increase the field of view of the image, much like choosing a wider angle lens. I can see that this could be helpful in some circumstances, but not for what I use it for.

Would it be possible to have a check box to toggle this behaviour between the old and the new?

Robin


#6

-VieportProperties > Size doesn’t seem to work for me


(Pascal Golay) #7

Yep, I see that… thanks.
http://mcneel.myjetbrains.com/youtrack/issue/MR-2820

-Pascal


Rhino 5 for Mac WIP Build 5E41w
#8

@pascal thanks, any further thoughts on the viewcapture problem?


(Pascal Golay) #9

Hi Robin - can you confrim that it lines up correctly if the viewport has the same aspect ratio as the view capture and the rendering? I realize this might be hard to set explicitly in macRhino right now, so maybe work backwards from the viewport that you have… for now.

-Pascal


#10

Hi @pascal

Apologies for the delay.

I’ve now had a chance to test this and as you have suggested, using the viewport size as a starting point rather than specifying a render resolution seems to solve the problem.

It would be really nice for this workflow to work again when specifying a resolution in the render settings but this work around will suffice for the time being. It would be great to have a setting in -viewcapture to match resolution to viewport. Would be great if it just populated the width and height settings rather than just a check box because you could then chose to modify the settings manually if required.

thanks
Robin


(Dan Belcher) #11

This particular bug should be fixed in the latest RhinoWIP (5E41w). Please give it a try.