Capture rendered viewport to file question

I am just starting out with rendering using the Render tool built into the Mac version of Rhino. Overall I am impressed and am able to produce the results I need but am curious about the files I get when I use Capture viewport to file. The appearance on my screen looks fine and so do screenshots using CMD/Shift/4 but the captured viewport to file files I get from Rhino are not what I expect. I’ve created a set of sample files to illustrate the problem. What I am doing wrong?


2 spheres.3dm (784.6 KB)

hmm. that’s strange.

i can’t duplicate your problem… or- when i try
ViewCaptureToFile, -ViewCaptureToFile, or ScreenCaptureToFile…
they all work as expected.

it may be something specific to your system ?
if so, it might be helpful to post Rhinoceros Info regarding your computer.

go Rhinoceros-> About Rhinoceros -> More Info (button)
then click ‘copy to clipboard’…
and paste those contents here in the thread.

Software information

Software versions
Rhinoceros version: 5.1 (5B161)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.10.5 (Build 14F1021)

Plug-ins
None

Third party kernel extensions
expressvpn.tun (1.0)
foo.tap (1.0)

Hardware information

Computer hardware
Hardware model: MacBookPro11,3
Processor: Intel Core i7-4870HQ CPU @ 2.50GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 750M 2048 MB
Memory: 2048 MB
Screen size: 1680 x 1050
Displays: Color LCD (258dpi 2x)

USB devices
Apple: Internal Memory Card Reader
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: Apple Internal Keyboard / Trackpad
2.4G wireless USB Device: 2.4G wireless USB Device

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.4.2 310.41.35f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

uhh… well
i have that same computer… (like- the exact same one… 11,3 with 2.5 i7 and 750M )
:slightly_smiling:

…and your file behaves as expected on my system…
i notice i’m on 10.11.2 and you’re on yosemite but i doubt that’s leading to the problem.

so… sorry i can’t be of more assistance… i don’t have a clue as to what’s causing this to happen for you.

Thanks for trying! I’ll post an answer if I can figure it out.