View capture to file: black image

Hi @jfernand15,

How large is your final capture? What display mode are you capturing?

Thanks,
-David

thanks @DavidEranen,

Rendered with shadows, anything about 1.5 times res goes blackout, that is 2779x1135 pixels

thanks!

1 Like

@jfernand15,

That’s interesting because it’s not a very large capture - and you have a good GPU.

It seems like you left out some information from the top of the System Information text, like Rhino and Windows version. Also, do you think it would be possible to send me the file that is causing problems and the steps to reproduce the problem.

You can send the file here: david.eranen@mcneel.com

Thanks,
-David

I have the same issue with a quadro P5000 everything over 1600x1200 resolution is black, really annoying because i wanted to do fast renderings for a custoimer of mine. when u think the problem will be resolved?
captureing in render display mode.
thanks

Hi @silviopauli,

Please paste the text from Help -> System information.... Do you think it’s possible for you to send the file that fails? If all files fail, could you provide all the options you give to the capture command? A screenshot of the dialog is usually helpful.

Thanks,
-David

Hello,
I had similar issue. Initially I was exporting in resolution 3000x3000. It was working. I guess I changed resolution to 5000x5000. Immediately View capture didnt work. Even reduce back to 3000, still I am not able to get it work now.

Hi - please run the Rhino SystemInfo command and post the result here.
thanks,
wim

Hi there, I was trying to capture a viewport as jpg.
But I just get a black image in any display mode.And I have this same issue, I have latest drivers.

Rhino 6 SR21 2019-12-17 (Rhino 6, 6.21.19351.09141, Git hash:master @ 4d373f64ffb55e3a8d607d9618590728d86fb1e9)
License type: Evaluation, build 2019-12-17
License details: Stand-Alone
Expires on: 2020-02-01

Windows 10.0 SR0.0 or greater (Physical RAM: 3.8Gb)
Machine name: NIRAN

Non-hybrid graphics.
Primary display and OpenGL: Intel® HD Graphics (Intel) Memory: 2GB, Driver date: 11-26-2012 (M-D-Y). OpenGL Ver: 1.1.0

Secondary graphics devices.
AMD Radeon HD 7400M Series (AMD) Memory: 1GB, Driver date: 11-4-2015 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 11-4-2015
Driver Version: 15.201.1151.1008
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\NİRAN\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.4.13.574\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

thanks.

Hi - Windows is not finding your GPUs. Please install the drivers for both once more. If this doesn’t change the situation, completely uninstall and then reinstall the drivers once more.
-wim

Same issue here, please help! Thanks

Rhino 6 SR21 2019-12-17 (Rhino 6, 6.21.19351.09141, Git hash:master @ 4d373f64ffb55e3a8d607d9618590728d86fb1e9)
License type: Commercial, build 2019-12-17
License details: Cloud Zoo. In use by: cecilia (wHY)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: WHY-NY-23

Non-hybrid graphics.
Primary display and OpenGL: AMD Radeon ™ Pro WX 7100 Graphics (AMD) Memory: 8GB, Driver date: 1-31-2020 (M-D-Y). OpenGL Ver: 1.1.0

Secondary graphics devices.
Intel® UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: NA
Driver Version: NA
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Users\cecilia\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Lumion LiveSync for Rhino (839d6175-32d1-4ffe-a0a4-b7fb43cf0ff5)\2019.11.5.949\Lumion\Rhino 6.0\LumionPlugin.rhp “Lumion LiveSync for Rhino”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.21.19351.9141
C:\Program Files\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino.Plugin” 0.0.20013.952
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Cecilia - same issue here, yes. And same solution:

You can find a recipe to completely uninstall and reinstall drivers here:


Make sure to include step 4 of the uninstalling process!

Also, you are running Rhino 6.21. Please update to the current 6.24 version.
-wim

Hi thanks for your reply.
I am working remotely, are there any solution specifically pertaining to SplashTop remote sessions? Because it works while on the machine directly and it can identify the drivers, are there some workaround to let Rhino see the graphics card while remoting with SplashTop?

Thanks!

Hi Cecilia -

Not that I know of.
Have you considered running Rhino locally on your machine?
There are several comments about the use of VPN and possible issues in this thread:


-wim

Hi there,

I’m having the same issue, but was easily able to ViewCaptureToFile just two weeks ago… Let me know if you can help, thanks!

Rhino 6 SR23 2020-2-24 (Rhino 6, 6.23.20055.13111, Git hash:master @ 8106edaa648ba209a8fc587f0f7fcccbaac09169)
License type: Evaluation, build 2020-02-24
License details: Stand-Alone
Expires on: 2020-06-07

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-8A84UFL

Non-hybrid graphics.
Primary display and OpenGL: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y). OpenGL Ver: 1.1.0

Secondary graphics devices.
NVIDIA Quadro P1000 (NVidia) Memory: 4GB, Driver date: 6-24-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 6-24-2019
Driver Version: 26.21.14.3123
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi - somehow your Intel 630 has been set at the primary OpenGL device instead of your P1000.
But the problem goes deeper:

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported

This says that it’s the Windows OS that is doing all the work, not your GPU.
Please open the Rhino Notifications panel and follow the links to update the drivers for both GPUs.
-wim

Hey! When I do ViewCaptureToFile only a few lines or only the background turnes black. Not the whole image. What could be wrong?

Welcome @feli.ladig
Need more info/example

hello, i have the same problem with Rhino 6, it prints as a black png and the named view is also black. Here i copied my System Information, what may be the problem? Can i do something or save my file as a png in another way? Thank youuu.

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Commercial, build 2019-02-27
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 3.8Gb)
Machine name: DESKTOP-DUG7ING

Non-hybrid graphics.
Primary display and OpenGL: Intel® HD Graphics (Intel) Memory: 2GB, Driver date: 11-26-2012 (M-D-Y). OpenGL Ver: 1.1.0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 11-26-2012
Driver Version: 8.15.10.2900
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1760960 KB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello, jumping in to this thread as I see a lot of relevant comments.
I am running Rhino on a computer without a GPU. I am able to see the model rendering in the editor windows, but when i try to capture viewport its all black.
Is it possible to capture viewports to file without a GPU?

My systeminfo (no GPU so no GPU drivers to update):

Windows 10.0 SR0.0 or greater (Physical RAM: 7.9Gb)
Machine name: E87V6L75

Non-hybrid graphics.

Secondary graphics devices.
Microsoft Basic Display Adapter (Unknown) Memory: 0MB, Driver date: 6-21-2006 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: Off
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: NA
Driver Version: NA
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB

Hello -

It seems unlikely, I have never tried it.

-Pascal