V6 - "Writing failed for unknown reason"


#1

So, I’m getting this:

NoSave

Doesn’t seem to matter where I’m saving either. I have full read / write access. It is a 1.85 GB file. I do see a temp file in the directory I’m trying to save, which is only 6,247 KB

Any ideas? It is making me sad.
Sam


(Pascal Golay) #3

Hi Sam - thanks, I am checking on this.
@SamPage - Does this fail on smaller files? Does SaveAs or Export work?

-Pascal


#4

I also can’t copy out of the file. In the not saving file, it shows as '_CopyToClipboard with no error, but when trying to past to a new file I get “Unable to paste, no Rhino objects or text on the clipboard.”

It will save with save geometry only, but that is less than ideal.


#5

!It is now saving again! Yay. It has been sitting by itself since I last tired to save (about an hour ago), tried the export, which worked (I don’t think it was when it wouldn’t save), so tired to save again and it was successful.

Phew,
Sam


(Pascal Golay) #6

That’s good!.. but still, it would be good to figure out what went wrong. Was the computer otherwise busy? Rendering or something?

-Pascal


#7

I wasn’t doing anything special, no rendering or anything. I was also unaware of any background process clogging things up. It almost felt like a license issue, where you can’t save or export, but that doesn’t explain the partial *.tmp file. This was on my home machine, which is using the newer licensing scheme (I think my work machine is using the old stand alone license, but I was sure I closed out Rhino before leaving to tend to a sick kid). I should have tried to change my license key on the home machine to see if that made a difference, but I did not.

At the time, the only thing Ctrl + C was doing was copying an image to the clipboard, I couldn’t paste geo into a new file. I was able to print, and I could save as if saving geometry only, but none of the other save options resulted in a successful save, so no save as, save as v5, clearing Save textures and / or Save plugin data. I’m pretty sure I also tried Save small, but that one I can’t guarantee.

Sam


#8

Just happened to me here for the first time!
(6.4.18124.12321, 4/05/2018)

Happened to a colleague yesterday and after a while she was able to save.
I’m gonna let the file sit in the bg and hope for the best…


#9

Saving to a different drive has worked for me in the past. I do hope they get this (and printing crashes) sorted soon.


#10

Yeah that worked for my colleague (once but not subsequent times). But that’s not working for me…

Just tried saving again after more than an hour, still no joy.


(Andrew le Bihan) #11

Andrew

I will attempt to build a plug-in that fixes it today. Please leave that instance of Rhino running if you can.

Andy


#12

Thanks Andy, Will do. About to finish up for the day so will leave it running overnight.
FYI, autosaves fail too once the problem presents itself.


(Andrew le Bihan) #13

Andrew (and anyone else having this problem):

Attached is a plug-in that will solve this problem:

  1. Download the FixDimStyles.rhp file
  2. Drag the FixDimStyles.rhp file onto Rhino.
  3. Type FixDimStyles
  4. Save

FixDimStyles.rhp (97 KB)


Failed to save Rhino 6 file
Failed to Save Rhino File
(John Brock) #14

#15

What exactly does this do? How will it change dim styles, will those changes be noticeable, will it break dim history, will it cause dim fly offs / compression? Sorry if that sounds a bit like looking a gift horse in the mouth, but dimensioning a drawing can take quite a while, and may span scores of pages, so it is a bit like if someone gave you a plug-in and said “run this, it will solve you problem with surfaces.”

Thanks,
Sam


(John Brock) #16

As I understand it, some as yet undetermined sequence of events is resulting in some garbage characters ending up stored in a linetype table. I’m not sure exactly how this is associated to a named Dimstyle, but whatever.

This tool that Andy put together, “weeds out” this corruption without causing additional trauma, so the file can be Saved.

Dale Lear is closing in on a fix for what seems to be the cause of the problem in the first place.


(Andrew le Bihan) #17

Sam

It replaces the Prefix, Suffix, Alternate Prefix and Alternate Suffix strings with their defaults.

So yes - it will potentially change some dimension styles.

Do not use this unless you have the saving problem. And once you have saved it, close Rhino and restart it.

  • Andy

#18

Thanks for this but unfortunately it didn’t work for me…

UPDATE: I exported my layouts and model space items and was about to quit when I thought I’d try to save one more time and voila, saved!

Thanks Andy!


(Andrew le Bihan) #19

I’m sorry to hear that it didn’t work Andrew, but delighted you solved the problem!

  • Andy

#20

Just wanted to chime in, just had a file in RC6 that wouldn’t save, and your plug-in remedied the problem.

Thanks again for this,
Sam


(Nathan 'jesterKing' Letwory) #21

@SamPage can you paste the complete first line of output from _SystemInfo, please?