Can't save file

I need to save a file but I can’t - “Writing failed for an unknown reason”

I know, there are several other posts about this already but none of them provide a solution. It happened when I wanted to save before like half an hour back. I just saved to another location and continued. Now I need to save again but it always gives me the error message regardless where I try to save it and whatever filename I try.

Please help!

Des SaveAs with a different name work? If not, what about showing everything hidden, unlocking everything and turning on all layers, then SelAll and Export…?

not even that works.
but wherever I export or save to, rhino will always report that it tried to save it in the original location, although I browsed somewhere else.

Just tried to save it via command line:
-_SaveAs "C:\UserData\Desktop\test\backup.3dm"
this time rhino confirms it tried to save to the destination I wrote but still doesn’t help, same message “Writing failed for an unknown reason”

I tried deleting all sorts of hidden temp files rhino created at the locations as well as the autosave files - doesn’t help.

this is pretty annoying, especially since this bug has been around since wip and users complained about it over and over again.

is there anything else I could try, please, I don’t want to loose the work!

Create a new blank Rhino file, then copy/paste all from the original to the new file? Make sure everything is un-hidden and unlocked, layers visible etc. before copying.

the new opened rhino looks completely messed up. the toolbars are all over the place. C&P doesn’t work anymore - maybe because I started quitting services via taskmanager cause of my desperation.

What services did you quit? I’m wondering if Copy/Paste doesn’t work that Rhino thinks it hasn’t got a license? What does it say in Options>Licenses, does it say it has a valid key?

I quit all sorts of services, don’t know.
My license is valid of course.
Had to quit rhino since I lost over an hour about this already. lost the work, restarted windows and now do it again.

really great! this is seriously devastating and disappointing.

Yes, I agree, it’s hard to imagine that V6 was released with this bug.

There are no autosaves of your file either?

autosaves? only one that is .tmp at the end after the 3dm. opened it without the tmp but rhino gives me errors saying it can’t read all sorts of things. then nothing in the file.

but this is on me i think, since I deleted a few autosave files manually cause I thought it might help curing the save-problem.

The V6 autosave files now end up automatically in the trash, you might look there - also if you have deleted them yourself, they might still be in there.

no, all gone, while trying to work around the save-problem I deleted files multiple times and emptied the trahs as well. that was my bad. the austosave files had saved me on a few occasions before already. my bad.

thanks for tying to help.

Hello - Ugh - this sounds very bad, to say the least. To bad about deleting all the files though. If you should run into this situation again, one thing I would try, if you did not, is to run the Autosave command directly - type at the command line. If that succeeds, keep Rhino open and in Windows Explorer navigate to your autosave folder (you can also get there from Options > File page), find the relevant autosave file (it will have your file name plus some gobbledygook) and rename it, and move it - that will have the contents of the file at least, even if it is not where you want it.

If it does not work… that would be bad of course but make a note of the error message and anything on the command line.


I am having this issue at the moment. Tried everything suggested here.
Cant save.
Cant save as.
Cant export.
Cant autosave.
Cant copy.
Any other ideas?


I Was able to save after disabling F-Secure Antivirus. Tried enabling it and saving again and cant save file any longer. I Did not have this issue earlier with F-Secure.