V6 Text Disappearing in Views

rhino6
unhandled

#1

Hello,
I have been having issues with Text objects disappearing from my viewports. The objects are still there but will only appear if selected. I have tried to re-create steps for producing this however it seems to occur sporadically after doing some modeling operations with text present in the scene OR when placing new text after doing some modeling.

It also appears that the issue affects only certain view types (wireframe and shaded, for example). I have also had a few instances where the “Text” command fails to prompt for text placement altogether.

I have seen a few older posts that might related (for example the dimension issue here) but the issue appears to be persisting with the latest version of Rhino 6 (at the time of this post, SR5 6.5.18155.13161, 6/4/2018)

Here is a screenshot. I have also attached the file. TextTest.3dm (223.7 KB)


(John Brock) #2

Please run the V6 SystemInfo command and post the results.
I’m guessing you might need driver updates for your display adapters.


#3

Hi John, My driver date is from 6-1-2018

Rhino 6 SR5 2018-6-4 (Rhino 6, 6.5.18155.13161, Git hash:master @ 0e00e118078ee9a651d609817f672fb0ed8e83bf)
Licence type: Commercial, build 2018-06-04
License details: Cloud Zoo. In use by: archinate ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: IMPERATOR

GeForce GTX 1060/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 398.11)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-1-2018
Driver Version: 24.21.13.9811
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Users\nate\AppData\Roaming\Proving Ground\Conveyor\ProvingGround.ConveyorRhino\ProvingGround.ConveyorRhino.rhp “Conveyor Rhino Setup”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Users\nate\AppData\Roaming\Proving Ground\HDR Data Wrangler 2.0 - Rhino 6\HDR.DataWranglerV6.rhp “HDR Data Wrangler”
C:\Users\nate\AppData\Roaming\Proving Ground\Semantic\Rhino6\SemanticV6.rhp “Semantic for Rhino 6”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(John Brock) #4

Does your system also have an embedded Intel display?
Is the driver for it current too?
We’re seeing a lot of bizarre problems when the driver for the embedded Intel display is old.


(Steve Baer) #8

Hey Nathan,
I can repeat the bug on my computer. Haven’t figured out what is causing this yet, but t most likely has nothing to do with your graphics driver.


#11

Hi @stevebaer,
Have you been able to look at this any further? The issues with disappearing text is still persisting on my machines (and others here). We recently ran a workshop at another firm and some others were also experiencing this problem in fresh models.

-Nate


(Steve Baer) #12

Sorry about not getting back to you sooner on this. Somehow the Room layer in that model has a display color that is magenta, but has its alpha set to completely transparent. If I click on the Room layer in Rhino and adjust the color to magenta again, the text shows back up.

Did the layers in this model get generated through code? Many times when I see completely transparent colors I treat them as completely opaque and I can do so in this case. I’m mostly curious as to how that layer got its color.


#13

@stevebaer
Ah yes, the layer was created with code. I’ll check on the alpha variable there. I should note that the same code works in Rhino 5.0 without this issue.

Also, it appears that the objects appear fine in “Ghosted” view in V6 but disappear in other views.

Thanks,
-Nate


(Steve Baer) #14

Makes sense, we completely ignored the alpha value in V5 :slight_smile:

I’ll update the 6.7 release candidate code to handle the special case of completely transparent so you don’t have to worry about changing your code. This won’t be in today’s 6.7 release candidate since I haven’t typed up a fix yet.


#15

Good news… I ran some tests on the code-generated Layer and ensured the alpha channel was being set correctly for Layer color. It also appears that this was the cause of the issue I was having with the mesh select/deselect here: V6 Bug - Mesh Edge Selection Visibility/Color Problems


V6 Bug - Mesh Edge Selection Visibility/Color Problems
(Steve Baer) #16

That is great. I’m still trying to figure out what the appropriate thing is to do when I encounter a color that is entirely transparent.


(Steve Baer) #17

Do you have an opinion on what we should do in this case (completely transparent)? There is a ise case for just filling the z buffer with transparent geometry, so I’m not sure if I should treat this case specially