Text not showing


#1

In a new file I used the Text command to create some text. The text doesn’t show on screen in any display mode. The first thing I checked was Display Mode Options… Show Text is check-box selected (as are all the Visibility options, I don’t recall ever messing with those settings). First screenshot shows… nothing. If you look above the command line you’ll see “1 text added to selection” and the Properties panel shows an object of type “Text”.

Then, with the text still selected (but not visible), I use the Explode command and there’s my text (as curves of course).


Anybody got any ideas why my text isn’t showing? I’ve used lots of text in lots of different Rhino files over the years, never had this happen. I’m running the latest version of Rhino: Version 5 SR8 64-bit (5.8.40128.10495, 1/28/2014). Haven’t changed anything on this computer lately… I’m baffled. I did install the latest version of Quicktime this morning, but I can’t imagine how that could be related…


#2

Hi,

as I’ve some similar problem with area dimension where my text seems not being displayed I figured out, that it is not visible though the fact the font size is set to “1”. Scrolling into the view and the text gets displayed. Perhaps you have the same issue on it?

Bye, MillingGuy


#3

Does it show up if you “select all” from the menu? I ask because the explode command leaves the text selected, which means it is displayed in the “selected” color.

My thought is that your normal (unselected) text color is the same as your background color.


#4

Nope. The text is selected in both screenshots.


#5

Nope. I tried different text sizes and fonts and formatting. Toggled “layout scaling” on and off, etc. The only thing that will make it visible is exploding.
The text also shows up in print preview. (If I pretend I want to print it and go Ctrl+P, I can see the text in the preview window).


#6

More testing. Another brand new document. One text object and one dimension object. Both are selected in this screenshot. The dimension arrows are visible but not the dimension text. The text object is invisible.

After exploding:

Text object shows it’s curves (“howdy”), dimension text is… nowhere. Here’s a screenshot of the properties for the unexploded dimension:

I’m stumped. I thought maybe something had screwed up font rendering on my computer so I opened up a few other programs to see how they’re doing with the same fonts. I tried InDesign and WordPad, no trouble at all. Opened up the system control panel for fonts, no trouble there, every font displaying fine.


#7

Well I found the dimension text…

After exploding the original dimension it showed just the arrows and dimension line. Apparently the text (16.21) was there, just invisible. I was able to select it and explode it to show the curves.


#8

Ed, maybe you need a rhino restart, and/or a pc reboot, see what happens.
I’ve never run into this particular problem, but I have run into enough little mystery bugs over the years, some of them fixed with restart/reboot.
Upload a file where this is not working, see if we can reproduce this.


#9

I restarted the computer between yesterday and today. It’s not that. :frowning:

My dots still work fine. In this screenshot there’s a text object just below the dot (-y) that’s not showing.

Attached is a Rhino 5 file of the screenshot above.
dot and text.3dm (47.2 KB)

To make that file, I restarted and opened rhino, placed a dot and then text (“Text” command), both with “WTF” as content.


(Wim Dekeyser) #10

Everything comes in fine here. Both import in my template and opening your file.

You have checked your display modes but do you have a mode that is factory default? If not, you could try resetting e.g. the wireframe mode to the defaults.

Only other thing I can think of are the GPU drivers. Perhaps update those to the latest version? Or the Quicktime installation messed with some of the settings?


#11

i know this doesn’t help fix your situation but just verifying the text and dot are in that file:

i have zero clue as to why you can’t see it though.


(Pascal Golay) #12

Hi Ed- Does the text show in any display mode? What if you Zoom Extents?

-Pascal


#13

Thanks Wim and Jeff for checking the file.
Wim: one of the first things I tried was to Restore Defaults on the Wireframe display mode. No difference. :confused: I updated the display driver this morning, no difference.
I kind of suspect some other piece of software is messing with font display somehow… I wish I had a better idea when this problem started. I’ve been working on one project a lot for the past several months that only uses dots (which still work fine), so I can’t really pinpoint what else might have broken the font display and when. In the past couple of months I’ve installed Revit 2014, Maxwell Render V3, OpenOffice 4, Quicktime… probably a few of those annoying Java updates :stuck_out_tongue:

I notice in my font folder that OpenOffice 4 added a half-dozen new fonts, Revit 2014 added a couple too. I might try uninstalling OpenOffice 4 first and see if that has any effect.

Pascal: nope. Text does not show in any display mode. I even tried Artistic for the first time ever!
Screenshot below shows a rectangle that I drew around the text, but not the text, both are selected, then Zoom Extents.

Interestingly, if I zoom out a bit… a line shows up where the text should be showing. The line appears to be right through the center of the text. (Again, the rectangle is just a rectangle I drew around the text).

I think this has to be something specific to my machine (software issue with something else I’ve installed) otherwise everyone else would have the same problem! :smiley:

I’ll try eliminating some other programs and see what happens and report back.

Thanks everybody.


(Pascal Golay) #14

Ed, in Options > View > OpenGL page, is the top check box checked ? ('Use accelerated hardware modes) If not please try checking that box .

-Pascal


#15

Yep. It’s checked.

btw: I uninstalled Quicktime, OpenOffice 4, and Revit 2014. Restarted computer, opened Rhino, no difference. Those are all programs that I’d installed in the last month or so, I thought they might have altered Windows 7 font-handling behavior since they each added fonts (except Quicktime, which I think is just generally guilty of altering things w/out warning). I either thought wrong or uninstalling them didn’t actually restore whatever changes they made to the registry. (or neither. has nothing to do with it).

I might try reinstalling Rhino… or cleaning the registry first probably…


#16

Update: messing around with various display settings today, in View -> Display Modes -> Wireframe -> Other Settings: Display Pipeline Assignment - switching from OpenGL to Windows my text reappears!
Strange… and not a great solution (I miss the anti-aliasing of OpenGL in wireframe mode), but I’ll take it for now over further installing/re-installing of softwares.
Text is still invisible in other display modes, which I’m guessing are reliant on OpenGL.