Text is not visible

unhandled
#1

Hello, There are 115 texts in the attached file and I couldn’t see them, could somebody please have a look and advise someways to make these texts visible…

Thank you

#2

text.3dm (7.5 MB)

it seems when I zoom , the text disappears.

(Wim Dekeyser) #3

Hi - the link to your file doesn’t work.
Could you please run the Rhino SystemInfo command and post the result here?
Thanks!

#4

Thanks Wim,

system info as follows

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Commercial, build 2019-02-27
License details: Cloud Zoo. In use by: Jokking ()

Windows 10.0 SR0.0 or greater (Physical RAM: 7.8Gb)
Machine name: DESKTOP-TOJ6Q44

Non-hybrid graphics.
Primary display and OpenGL: Intel® HD Graphics 4000 (Intel) Memory: 2GB, Driver date: 5-19-2016 (M-D-Y). OpenGL Ver: 1.1.0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 3-20-2014
Driver Version: 9.17.10.3517
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2108 MB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
text.3dm (7.5 MB)

(Wim Dekeyser) #5

Hi - there is something wrong with the driver set-up on your system.
In Rhino, please open the Notifications panel. You should see a warning for the Intel GPU. Follow the links and download the newest driver for your HD Graphics 4000 card.
Please let us know if that solved the problem!

#6

Wow, Thank you for your guidance. Above step solved the problem.

(Wim Dekeyser) #7

That is good to hear.
Could you please run SystemInfo once more and post the result? We are trying to keep track of which drivers work for which cards.
Thanks!

#8

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Commercial, build 2019-02-27
License details: Cloud Zoo. In use by: Jokking ()

Windows 10.0 SR0.0 or greater (Physical RAM: 7.8Gb)
Machine name: DESKTOP-TOJ6Q44

Non-hybrid graphics.
Primary display and OpenGL: Intel® HD Graphics 4000 (Intel) Memory: 2GB, Driver date: 12-21-2015 (M-D-Y). OpenGL Ver: 4.0.0 - Build 10.18.10.4358

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.0
Shading Language: 4.00 - Build 10.18.10.4358
Driver Date: 3-20-2014
Driver Version: 9.17.10.3517
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2108 MB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

#9

Thanks Wim :pray:

(Wim Dekeyser) #10

No problem!
And thank you for posting the updated information!

(Graemec) #12

Hello. Not sure whether I should post here or start a new thread, but I am having exactly the same problem as JOK.

When I insert text or dimensions in Rhino 6 the letters and numbers are invisible. Any background colour shows and the dimension arrows are visible. I also get a Rhino 6 notification “Intel Video Driver Upgrade Recommended.”

I have run the Intel Driver and Support Assistant and it says my drivers are uptodate. Specifically: Date 5-19-2016, Version 9-17-10.4459.

But when I run the Rhino 6 SystemInfo it says …Intel® HD Graphics (Intel) Memory: 2GB, Driver date: 5-19-2016 (M-D-Y). OpenGL Ver: 1.1.0

Same date, Different version. I am confused. Can anyone help, please.

A printout of my Rhino 6 SystemInfo is below.

Rhino 6 SR14 2019-4-28 (Rhino 6, 6.14.19118.15561, Git hash:master @ 8f0a84997c310a7ec1a42cf2704da8daa33e3e21)
License type: Educational, build 2019-04-28
License details: Cloud Zoo. In use by: gtcook ()

Windows 10.0 SR0.0 or greater (Physical RAM: 20Gb)
Machine name: GRAEME-HP

Non-hybrid graphics.
Primary display and OpenGL: Intel® HD Graphics (Intel) Memory: 2GB, Driver date: 5-19-2016 (M-D-Y). OpenGL Ver: 1.1.0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 5-19-2016
Driver Version: 9.17.10.4459
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2172 MB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

(Wim Dekeyser) #13

Hi - the one reports the driver version and the other reports the OpenGL version that this supports.

At any rate…

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported

This shows that the Intel driver is not actually doing anything and that Windows is doing all the screen painting. This means there is something wrong with the installation of the GPU driver, no matter what the Intel Assistant tells you. Your exact model of the HD Graphics is not stated in the report - you’ll have to find out about that and manually search for the latest drivers for that GPU.

Also, I would recommend doing a so-called “clean install” for the new driver - the process is described by Jeff in this post:


Make sure to include step 4 of the uninstalling process!
HTH,
wim

(Jeff Lasor) #14

Download, unzip and run the attached diagnostic program “DeviceID.exe” (probably easiest to save everything to your desktop and work from there)… Once it’s running, don’t click on any of the options, just take a screenshot and post it. Then CHECK the “Driver summary only” checkbox near the top, and take another screenshot and post it.

Thanks,
-Jeff

DeviceID.zip (795.0 KB)

(Graemec) #15

Thanks Wim and Jeff

The driver was an integrated Intel HD Graphics 2000 Driver and it seems that Intel ceased support for that driver on 24 June 2016, and that it is not compatible with Windows 10. It apparently works with at least Win XP through Win 8, but not Win 10.

My computer is an HP Z1 (Gen 1) workstation with an unused MXM graphics expansion slot - MXM are rather expensive cards with limited availability! I am a graduate student in 3D Design, so $$$'s are tight.

I have just found another shortfall in Rhino 6 on my computer. If I access Render > Panels > Library all the infill material options are blank. I cannot apply timber effects, stone effects, glass effects, etc. This function worked fine with Rhino 5.

I am not a nerd; my computer knowledge is very limited - hopefully it is a black box that does what I ask it to… so we must keep things simple.

My available options may be:

  1. Revert to Windows 7 when using Rhino 6 - (this might confuse me in practice) ?

  2. Install another driver, if one exists?

  3. Something else ?

Thanks

Graeme