Unable to use 'create solid' or 'Boolean Union'

I am new to Rhino so this might be a fairly obvious fix…

I created a pattern in grasshopper and created a series of rails that I am trying to join into a solid for 3D printing purposes. However, I keep getting errors when I try to join the individual rails. I have tried to boolean union, create solid, and I tried to create a mesh and run a mesh boolean union.
The image below shows what happens when I attempt the mesh boolean union.

Any help is appreciated! Thanks


Boolean Issues.3dm (14.2 MB)

Why union them for printing? You can print closed watertight pieces that overlap and let the printer fuse them together.

That way if you have to edit them you can do so easily without having to tear the model apart and untrim stuff…

That said, this file is a bit of a hot mess… you have colinear and very closely overlapping stuff all over. This will cause normal issues and that will kill booleans.

You’d need to do a ton of manual trimming to get this anywhere close to something you could boolean.

do your self a favor, mesh each part, make sure they are all closed and watertight then export the whole pile as obe file to the printer and let the print slicer sort it out for you.

You’ll save HOURS of messing with this and get the exact same result had you booleaned it.

see this video

2 Likes