Thea Render v1.5 for Rhino first issues

Hello there…

I am testing the new Thea Render plugin for Rhino.
Despite of we all can use it right inside Rhino Viewport is a must. But i found a very annoying issue on that. (anyone with same problems, please help for solutions or explanation)

1º - Thea Render works like charm inside Thea Darkroom (that open window when press that specific toolbar button).
2º - Thea Render inside Rhino Viewport, after 1 minute of rotating/moving/zooming objects always crash rhino. (the crashdump file don`t show any text inside!!)
3º - When any polysurface object have some rhino texture inserted from a jpg image, Thea Render wont show that texture. That object will be rendered as black color (really annoying).
4º - In Thea Darkroom everytime we try to adjust some rhino glass texture it wont refresh and the solution is close Darkroom and open again.
5º - Insert Textures from Thea Render Material inside rhino it is very complicate to change it properties (impossible to change texture scale, rotate, fit). The solution seams to be in Thea Material Lab and for that you have to redraw a copy from a texture.

The solution for all issues that i mentioned is to install Thea Render Studio and always export your work to there. Of course it would be nice to have Thea Render 100% function inside Rhino, but i give them a discount right because it`s an fresh and immature version for Rhino.

Overall: Thea Render presents very accuracy images in less periods of time. I have been testing some other render engines, like V-Ray, Artlantis, Maya, and Thea Render is the best for what it costs.

Hi Architex,

thanks for the feedback.

That should not happen. Can I have a sample scene and also your computer specs (hardware, operating system)?

Rhino textures are not supported. How do you assign textures to objects? Is it a Rhino material?

It seems that I don’t get an event when UV is changed. I need to check this.

Integrating the whole Thea Studio functionality inside a plug-in is not an easy job. But we are working on making the best one!!


Hi dkapnopoulos1, thanks for your reply.

That should not happen. Can I have a sample scene and also your computer specs (hardware, operating system)?

  • Yes you can have my file, if you want it, but it has 173MB file size. (i could send you throw wetransfer?? what it gone a be?)
  • sample png image:
  • I have a CLEVO P150SM LAPTOP + i7 4710MQ 2,4-3,4Ghz + 16gb RAM + GTX 780M + SSD 256 Samsung Pro + Windows 10 PRO x64 … this machine have handle a complex model that i made in past with 1,5GB size and a lots of clean and closed polysurfaces.

Rhino textures are not supported. How do you assign textures to objects? Is it a Rhino material?

  • I have tested in different ways. Then i realise that Rhino textures are not supported in TheaRender inside Rhino. This should be written in PDF Manual!!! … Otherwise, i try to add some Jpg Texture to some polysurf object and Thea wont recognise it. Then i`ve try some specific Rhino textures, like wood for example, and TheaRender still not recognize it; all objects are show as black in Darkroom.

It seems that I don’t get an event when UV is changed. I need to check this.

  • ???

Integrating the whole Thea Studio functionality inside a plug-in is not an easy job. But we are working on making the best one!!

  • Of course it would be nice to have Thea Render 100% function inside Rhino… it`s an fresh and very new version for Rhino; i perfectly understand. And i give you all a big thanks for the enormous effort for get Thea Render integrated inside softwares like Rhino.
  • I always prefer to use Thea Studio as it is more stable and reliable and more complete.

a big Thanks

Hello again…

I found another issue…
It`s became impossible to export that model (previous image above) from Rhino to Thea Render. I mean, when pressing Export Model Button inside Rhino, it will not save any file and take to much time reading. It not crash, but it not save any file.

Do you know alternatives to proper export from Rhino directly to Thea Render, without loosing detail or any layer?

Again… sorry… :smile:

then i try with sketchup, and i test like this.

Export that model from Rhino to Sketchup (with export to skp file)
Open the exported file inside Sketchup and it will open without any problems.
Then i try to export from Sketchup directly to Thea Render, within Thea Render Toolbar Options.
Again… it will take to much time and as i write this message, it not finish the process yet. (i think it will go crash)

Then i try some other process… I went to an earlier old file, a interior house 3D model made in Rhino, which i export to Thea Render (i dont remmenber if export that in OBJ or whatever, then i open that complete project, render and textures processed inside Thea Render… and when i press Render Interective, Thea Render wont perform like before.

I wonder if this is because now i am working in Windows 10 Pro x64 (DirectX 12), and that model was made in Windows 7 Pro x64 (DirectX 11) ??? Or this could be because, i start that Thea Render project in version 1.4 and now i am using Thea Render v1.5 (isn`t it suppose newest versions became more stable?)

This is awkward because even Thea Render Studio became unstable. The Interface start to intermittent, popping the tool buttons on and off.

3D Model made in Rhino + Renders made in Thea Render v1.4 on Windows 7 Pro x64 (this complete model is about 700MB of Thea file) - My Laptop had a nice behave when working on this big and complex file)

… and then, sketchup wont perform export model, still reading… i have to cancel. Not good so good working like this.
Any help please.

I am keep trying but it is impossible to export any model with more than 10Mb…
This is strange because, with TheaRender RTExporter v1.0.320 for Rhino, it was nice exporting any kind of model in XML (and without loosing any detail or layers order)

Like this:

Why this new version is getting strange?
I think i have to downgrade for Thea Render v1.4 and downgrade Windows 10 to Windows 7

I think i found the solution.
I think the “EXPORT MODEL” button are not well designed… It miss the "GEOMETRY PROCESSING PARAMETERS option that alow us to choose export with LAYERS ID or by OBJECT ID (like in the youtube video, or like THEAROS RTEXPORT)
lets see what happen in the next hours…


I have instaled some new version and i think it correct this bugs.

Thea Render for Rhino v.1.05.3

But still no option on Export Layers or Objects!!!

Hi Architex,

which bugs did the new version solved?

You can have Rhino basic materials with Rhino textures and they will render fine (they are baked). I noticed that Rhino basic material and textures are not updated during interactive rendering but they will be in next release!

Exporting models means that you can export a model like a chair but not the whole scene. Scenes have other components like lights, cameras etc. The model that you tried to export above looks quite big. Thea models are saved in *mod.thea files and are small objects (like a table or a bed) which you can save in you library and import them to different scenes. Exporting the whole house is probably a misunderstanding of this functionality

About the export layers or objects is an options that is not available and I’m afraid it will not be in the future either. Thea for Rhino is a fully integrated plug-in and not an exporter. Having options to control the scene structure will completely break interactive rendering and everything else.

I’d like to have the scene that makes Rhino crash but a stripped down version of it if possible.

I hope my answer helped!!


Hi dimitri kapnopoulos.

Thanks for your answer here and to my e-mail (i assume from that question i made yesterday night in Thea Render Forum as antonio_andre nick name).

About that topic on EXPORT MODEL, sorry it was my mistake.
Yes, you are right. EXPORT MODEL is only for small objects like chairs, tables, sofas, etc, etc. (apparently this wasn`t explain in Manual PDF)

Then i realise what i need is to EXPORT ALL SCENE.
And yes again, this is the only possible method to export all model to Thea Render Studio.

About Darkroom doesn`t refresh itself ! … i will wait for next versions. Hopefully with that option best fixed.

About Rhino crahes inside viewport?, I think i found the solution.
I have installed all new versions of TheaForRhino + Thea Render Studio were i made more tests with the same files… Surprisingly both Thea Renders became more stable and even more fast to respond.

I wonder if that issues was probably because of Windows 10 and its new DirectX 12 (knowing that i am using a GTX 780M KEPLER chip) ???

About export layers now i realise that i need to get new habits of work on this new Thea versions.

  • for example; Regroup everything inside Thea Render Studio has it the export scene option wont properly rename the groups like i name it inside Rhino layers.

I keep unhappy about this matter, because if my mind wont lie to my, the old THEAROS RTEXPORTER v.1.0.320 for Rhino, have that menu: GEOMETRY PROCESSING PARAMETER option enable. And from there it was able to export models with the same layers name/order has it was inside Rhino. (please check youtube video above: min 0:59)

TheaForRhino v.

  • not to stable.
  • Export Model and Export Scene take to long time processing.
  • Darkroom wont refresh after made changes to any objects.
  • Interactive Render inside viewport crash Rhino after 1 minute rotate/pan/zoom.

The Render Studio v.

  • Import Obj wont open correctly; all blank image.
  • When start interactive render overlay toolbars start flickering and wont stop until i close Thea Render and open again.
  • not to stable compare, for example, with Thea Render Studio v. (for me this previous version was the most stable on Windows 7 x64bits)

TheaForRhino v.

  • more stable.
  • more fast.
  • Export models and export scene became more fast to response.
  • Darkroom still not refresh changed objects (colors, etc…).
  • Interactive Render inside viewport became more stable. And it will not crash unless i push very hard on my hardware specs.

Thea Studio v.

  • more stable.
  • more fast.
  • fix flickering toolbars.
  • open files more fast.
  • Obj file import fixed.
  • apparently all became more workable.

Thanks for you help.

António André

Hi Antonio,

good to know everything is OK.
I know the exporter had this option but this will not be available in the new one.
Rhino materials will be updated in next version. You can work with Thea materials though which are updated during interactive rendering. There is a huge material library installed with Thea Studio and we also have a nice online material repository ( where you can find many read-to-use materials.


Hi again.

Well, has i say, we Thea Renders have to get new habits about the exporter layers properties. But i miss that option so much. It save some precious time on work… Its ok then. :smile:

About that new repository, in fact, is a big must to have. And i have been there to check the materials.

I have to say thanks again for all your spend time helping me here.

Again… Thank you very much.

António André

hello THEA RENDER Plugin for Rhino users.

Any one could help here?


I use Thea for all my renderings ( and from what I can tell this is a Rhino issue, not a Thea issue. When using Thea, use the AO setting, not the MC or AMC settings, and use production mode, not interactive mode.

I was unable to reproduce your errors, but I attached a file that looks clean. I extruded four planar surfaces (circles), then trimmed them and stacked them. I couldn’t detect any of the anomalies like you show. Might want to try a different approach.


cylinders.3dm (575.1 KB)

hello and thanks for helping.

I think you did not make properly zoom to that piece.
Try to choose:
CLAY 50%.
Camera film hight 35 | Focal lenght 50.
Ambient Occlusion enable
distance 10.0
Intensity 40.0

Disable sun and skylight or any other exterior light.
And yes, choose PRESTO AO because it is better for interactive preview. Presto MC and AMC are for final rendering, but they need more samples and more time to get clean like pro rendering.
I have been using Thea for long time. Not yet a big PRO like M.I.R.C, or Ronen Bekerman or Peter Guthrie, but i get nice result in Thea Studio for my works.

I try to test the same object inside Sketchup and Thea Render result the same small gaps at solid edges. It might be a need of GPU driver updade?!.. But i want to keep this options for the last. Like i said, it is the first time i saw small gaps like that in my models/work made in rhino and rendering in Thea.

I will test your file to see… Came back soon to report. Lets see what happen.

well, i made a copy from my suspicious object into your file and that gaps went gone. It is possible that small gaps is because the handrail is far from origin? I then explode your file and “create solid” from them and the gaps seem to gone. Any explanations?? Like i said, it is the first time this happens. No other model files i have, result in this issue. Strange situation.!!!

best regards.

Hello Again.

What`s happening with this???
Here we are again. I found that objects when far from origin coordinates (0,0,0) Thea Render Plugin for Rhino is missing correct textures. The result is small gaps on cylindrical surfaces or small objects.
First i thought that this was a Rhino issue, but not. It is a Thea issue. Or both?!?!?

How to solve this???

As you found out - move the geometry closer to the world origin.

Alternatively you could change your units from e.g. mm to cm or dm. Just make sure that the size of the smallest feature in the file doesn’t end up too many places behind the decimal period.

does somebody experienced the complete freeze of windows and i think is a cpu issue(amd 1090T and Nvidia gt 740), using thea render standalone and windows 10?
it’ s just a problem of win10(all editions) under 7\8 its all ok

suggestions are appreciate!

I experienced several freezes with Win 10 when running R5. I have an Nvidia GTX 970 and it seems to run flawlessly. I finally narrowed the freezes down to an app for Windows (ClassicShell) and one Rhino plugin (Clayoo, which was later resolved). The only way I could get a handle on it was to turn off the plugins one by one and see which plugin was the culprit. Very time consuming process.

Me too (W10 & R5). But I have no ClassicShell (at least it won’t show up in the search box) and no Clayoo.

Using a rudimentary GTX920, but it’s faster than Quadro 4000… Crashes equally often with both cards.


// Rolf

the funny thing is that if you downgrade to 8.1 or 7 the problem disappears …i think it’s just a WIn10 issue. and CPU!
what kind of cpu is on board?
mine AMD 1080T Black edition