Textures viewport issue

I am using last Rhino 5 SR6 64-bit. I am not sure what is wrong with displaying textures in viewport. I am not sure if it is because of RhinoThearos render plugin or Rhino itself but see the pictures below. If I open the file, the textures are displayed with wrong mapping. But the problem is only in viewport it doesnt affect rendering. If i want to fix it, i have to rotate UVW for a while e.g.by 90 degree and back to 0 to see the correct mapping. Dont you please know where should be the problem?

Fig 1

Fig 2

Fig 3

Can you please send me (pascal@mcneel.com) , or post, the file exactly as you have it? Please set DocumentProperties> Rendering to ‘Save support files in 3dm file’.



Hi Pascal. Sorry, I was not here (this forum) for a long time. Did you find out what is wrong with displaying the textures in viewport? It is still happening in our practice that textures are displayed wrongly in viewport. It mostly happens after scene export to the TheaRenderer. Then Rhino shows smudged textures in viewport. It can be corrected for a while by manipulating with the mapping widget or to check and uncheck Custom Mesh switch in object settings. But it is not permanent solution.

Hi Petr - no, I was hoping you would send the file…


OK, i am sending the file.
File sent.

Or available here:
texture viewport issue.3dm (397.1 KB)

I don’t have Thea render here to see/edit this material. Have you contact the Thea developers with this issue yet? If the texture looks right when rendered in Thea but doesn’t look right in the viewport, this might be something they need to fix in the plugin. It could also be a specific texture setting within the Thea material but I’m not sure without the plugin.

Hi BrianJ,

Thank you for your entry. I don’t know how Rhino handles owns materials and materials from different renderers.
But if the Thea plugin is off and you open the file, I believe that Rhino is responsible for what is displayed in the viewport, or am I wrong? That’s why I though you should check if there might be something on your side.
When you render the scene, the texture looks right in Thea. And the mapping widget is rhino widget.

Thea is working on some completely new plugin, so it probably doesn’t have any sence now to contact them.
In Thea forum they informed, that development of this plugin will be moved to another programmer and will be reworked completely. So if this problem is really plugin problem, so we will have to wait until new release come.

Without Thea installed I don’t see a texture in the Rendered display mode. Normally a rendering plugin has it’s own material definition and this should get converted (as well as possible) into a basic Rhino material if the plugin is not present. It seems as though Thea doesn’t work this way. I would suggest telling the developers now so they make sure to address this in the new version. @Andy may have already worked with them on integrating the plugin into Rhino 5 but if the render and the rendered display mode don’t match, it sounds like the UVs aren’t being used correctly with OpenGL.