Turning on a clipping plane makes dimension text&arrows invisible

I had to make some measurements of parts that are covered by other parts. I turned on a clipping plane and made my first dimension, but all I could see were the lines, no text and no arrows. I’ve recreated the problem with two simple parts as you can see in this image:

I tried all the display methods, but the dimension is always unusable. So then i turned off the clipping plane and voilà, my dimension is nice and readable!

Fun fact: when trying to print the viewport the dimension is visible, but I cannot select the points to make a window, nothing gets selected.

c3.3dm (192.8 KB)

The issue is kind of similar to Text not showing , but I do not have an option “Windows” in the display pipeline (only option is OpenGL)

Hello -

Please run the SystemInfo command in Rhino and copy/paste the results here.


Hi Pascal,

Here’s the output of SystemInfo:

Rhino 7 SR5 2021-4-10 (Rhino 7, 7.5.21100.03001, Git hash:master @ 2cd158094b595f6400479d7cbe511454b6149527)
License type: Commercial, build 2021-04-10
License details: LAN Zoo Network Node

Windows 10.0.18363 SR0.0 or greater (Physical RAM: 10Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display: VirtualBox Graphics Adapter (WDDM) (Oracle Corporation) Memory: 0MB, Driver date: 10-15-2020 (M-D-Y).
> External USB display device with 2 adapter port(s)
- Windows Main Display attached to adapter port #0
Primary OpenGL: GDI Generic: Microsoft Corporation. OpenGL Ver: 1.1.0
> No graphics device is being used for OpenGL

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 10-15-2020
Driver Version:
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: n/a

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hello - try updating to the most recent service release - you are a couple behind -

Does that help?

Wow, turns out my Rhino is unable to communicate with its update service. I’ve got the McNeelUpdate service running, but Rhino displays the error message “The McNeel Update Service is unavailable” and “Check now” is greyed out. Even after making the update from your link.

And unfortunately after installing the newest version the behaviour is still the same - as long as the clipping plane is on, the dimension text&arrows are invisible.

Oh - sorry, it’s this:

VirtualBox Graphics Adapter (WDDM) (Oracle Corporation) Memory: 0MB, Driver date: 10-15-2020 (M-D-Y).

I read right past that the first time through.


Ok, so as long as I stay on my virtual machine, this glitch is going to be there and everything should work fine when the file is opened on a proper Windows machine?

Hello- that is what I’d expect, yes - your file looks correct here.


Ok, thanks for your help!