Surface edges & curves disappearing

Hi Jon - thanks for the file - I do not see what you are showing in the images here. A couple of questions come to mind -

Is the display mode a default one, with no custom settings (i.e. no blue items in Options > View > Display modes > Shaded) ?

Does this happen in other display modes? Wireframe?

Is TestZBiasFactor at the default?

Shot in the dark, but does it make any difference at all if you ShrinkTrimmedSrf on all the objects? I do not expect it to, all points are on the visible side of the plane, but, shot in the dark…

Is your video card driver up to date?

thanks,

-Pascal

Hi Pascal,

Annoyingly I’ve opened up the same file I sent you to check it and it does not appear to be failing like it was! (which is good, but bad!)

It’s kinda frustrating that it has stopped, becuase it does it in both wireframe and shaded modes, which are both default views in my files. When it happens in wireframe mode lots of lines disappear so I can’t see most of the model until I move the model (which I dont want to be doing if I’m rendering).

I keep my video drivers up to date as much as possible and TestZBisaFactor is at default.

I guess I will have to keep looking out for it again. :’(

Hi Jon - OK, thanks- I guess it will remain a mystery for now.

-Pascal

I’ve been getting this for months in rendered mode. I’ll try updating the drivers.

Edit. Updated graphics card Drivers (Nvidia FX4100M) and I can’t get edges to disappear, try as hard as I can. They seemed to disappear when the computer was pushed hard - several programs open, video/music running; and annoyingly often if I started Snipping Tool which I do a lot. Shading seems subtely different in a good way too. I’m not usually an avid upgrader of video card drivers as I’ve had trouble with Rhino and drivers in the past - if it works why change it? - but this seems to be a great improvement so far. Thanks for the obvious suggestion :smile:

John

Not gone away. In this case just lines not edges have disappeared.

A slight pan restored the lines. It was a slight pan that made them disappear too.

Interesting that previous posters have based there models on non-Rhino file formats. This was based on a dxf from an architect.

John

I have come across this too and I have found the same issue. I have attached a couple pics to show what is happening with my models. This will happen with any model I use not just a specific one. This does not always show up but it only happens once in a while. Usually it happens when my NVIDIA graphics card needs updating or I have imported a model that I converted from another 3D program.

The issue I found is using clipping planes. If I use “front” or “top” I dont have any problems. The problem comes when you use the clipping plane in the “perspective” view so it clips my model while in the “perspective” view. When I use the clipping plane in the “perspective” view then I get what is shown in the top image. Then all my clipping planes are affected by this. So if you experience this then you have to delete ALL clipping planes then the model displays correctly like in the bottom attached image. I am running Rhino 5 on a windows computer. I hope this helps.

1 Like

Noticed that the surface edges in shaded & rendered mode are not displaying correctly in Rhino WIP (6.0), but work fine when I save back to version 5 and open in there…
Makes me think it may be something to do with the display adaptor/settings.
I’m running a Nvidia GeForce GTX 580 graphics card.

Thanks
Sach

I probably wouldn’t be a bad idea to update the drivers.
Could you also perhaps show an image of what is not working correctly?

Wim
Drivers are up-to-date!
Wire-frame image shows are surface edges. Shaded view many disappear!

I figured it out! Tangent Edges in the display settings needs to be selected!

I’m getting this here also, just recently, after a computer upgrade, with a very large file while the clipping plane is active.

Hi @Ncik

Did you check the ‘Tangent Edges’ box in ‘Display’ settings?

Please point me in the right direction for that setting.

Display setting is Ghosted.

That setting is available in the RH6 WIP.
I’d say this thread is getting confusing with several different things going on in different version.

I’m not sure what “this” is referring to - especially not with the extra information about clipping planes…

This is a Rhino 5 discussion.

“This” is the very first comment…

and “this”…

…hence the reference to clipping planes.