Weird Surface Edges Display Problem

Hi!

I’m trying to export some images from Rhino and I have noticed a weird thing happening…

In Display Settings I unticked Surface Edges but they still show in the Perspective view. (I checked for Top, Right, Front view… and they don’t show there)

I noticed they only disappear when I remove the Ground Plane…

Does anyone know why this is happening and/or how I can make the Edges go away and keep the ground plane?

Thanks folks!
Greetings from the Isolation in Vienna day 21937

here are some Images…(please ignore the colours, they made me do it…)

Hello - try Unweld > 0 degrees, ModifyNormals=Yes on the igloo shape - does that do what you want?

-Pascal

hi! thanks for the quick reply!

Unweld does’t seem to work because the geometry is a Polysurface…

Yep, OK - sorry, I misconstrued what I was looking at - can you please run SystemInfo in Rhino and post the results, and can you send this file to tech@mcneel.com,. with a link back to this topic? I’ll take a look.

-Pascal

1 Like

This is the result after SystemInfo
I’ve also sent the mail!

Thanks
:grinning:

Weird Surface Edges Display Problem_Miruna Vecerdi.txt (2.3 KB)

Hi Miruna - thanks - I did not realize we are talking about the Rhino WIP. Here, in V6 and the V7 WIP, your ini file imports with surface edges ticked:

and it looks correct if I un-check that setting:

If you re-import the ini file and overwrite the mode you have, does it work?

-Pascal

exporting with the unckecked edges and reimporting seems to work works… but then it doesn’t

so I just made a box and everything was fine
but then i zoomed in and these little devils reappeared…

and after zooming in

its becoming pretty hilarious!
btw, thanks for sticking for me on this one hehe

:sweat_smile:

Hi Miruna - I see the Zoom thing here as well, thanks for pointing it out . I’ll put that on the list - I don’t know if there is a useful workaround but if I find one I will let you know.

@miruna.vecerdi - So far it seems to be linked to the setting under Objects>Surfaces for ‘Naked edge usage’ If I change that to ‘Use surface edge setting’ it incorrectly toggles on surface edges, but here at least, if I then turn those off, the zoom level no longer affects the edges - I am still testing…

-Pascal

1 Like

HI!

That was it i think!
I changed it to ‘Use surface edge setting’ exported and re-imported and now regardless of how much i zoom in or out or how rotate the edges are gone.

Thanks a lot!
Best wishes and stay healthy !

-Miru
:space_invader: