Rhino 7 disappearing lines when panning + zooming

Hi there,
Getting this weird bug where curves are disappearing when I pan or zoom, mostly when I zoom in. Here’s a short video clip. Hoping there’s a solution as it’s making drawing this incredibly inefficient as I have to zoom in and out with every command.
Thanks in advance.

2019 Macbook Pro
2.4GHz 8‑core Intel Core i9
AMD Radeon 5600m 8 GB
64 GB RAM
2 TB SSD
Rhino 7

Hello - what does Properties say about the camera and target locations in this view (with nothing selected)

-Pascal

Hi Pascal, here’s the screen shot. Lmk what you think. Thank you.

Hello - that seems reasonable to me. Can you send us a file that shows this? The smaller the better, for troubleshooting, as long as it shows the problem. Please SaveSmall and send to tech@mcneel.com, with a link back to this topic in your comments.

-Pascal

Great. I just emailed you the file. There’s a few issues I outlined in the email. Can across another bug last night where the material maps suddenly changed to another map in Render View but was accurate when I Rendered the view. Then when I Saved Small, the floor and ceiling maps changed yet again. Let me know if you receive or don’t receive the file so I can resend. Many thanks for your time Pascal.

Here’s what I included in the email. Putting this here too in case others are / have experienced the same problem.

Hi Pascal,
Just following up to see if you were able to poke at this.
Thanks!

Hi all,
For those who see this in the future: I have the same problem on my 2020 16" MacBook Pro (2.3Ghz Intel 8-Core i9, 32GB RAM, AMD Radeon Pro 5500M 8 GB and Intel UHD Graphics 630 1536 MB, running Big Sur 11.6.5) and found a solution within settings. Under OpenGL, I discovered that turning off GPU Tessellation solves the flickering problem, and that with GPU Tessellation still turned on, even when the view is Locked, clicking and dragging (which does nothing because the view is locked) still makes my linework flicker. Hope this helps anyone struggling with this, and anyone at McNeel in diagnosing the problem.

Hi @r.raynor
So I’ve since upgraded to the M1 Max Silicone chip and have been experiencing incredible lag when in Wireframe, Shaded, and Rendered View to the point where I get the spinning ball every time I pan, zoom, perform a command, basically anything I did. Had been using my 2019 MBP until performance improved on M1.

I just read your post, went into my settings and noticed it was turned off by default so I turned it on and the spinning ball went away. Things are moving much smoother in wireframe and Shaded view. Rendered view doesn’t produce spinning ball and still slower compared to 2019 MPB but at least usable now! Thank you
Thanks!!

Oh fascinating – glad my post helped! So it seems that what worked for you was the opposite of what worked for me; you turned yours ON, and I turned mine OFF to solve the problem. Hope this helps @pascal or any others working on this problem.