Solid edge thickness


Im becoming crazy, i have to print some documents and there are some solids, like pipes or sphere, i would like to control the thickness from all this solid, i mean.

With layer properties i can control the line width from simple lines but if i put a pipe in this layer , the boundary lines from this pipe are not affected of this line width layer…

somebady knows how can i this fix?

Thanks a lot¡

Hi Fernando,
I’m assuming you are talking about controlling the print width of the lines via the properties settings? Anything that will display a curve should indeed be affected by the print width settings. Sample print image attached of a pipe on different layers with different print width settings.

If you’re instead talking about controlling actual wall thickness of the solid from the properties, then that is not really possible right now.

Perhaps attach a sample file if you are not getting expected behavior.

Thanks Carvecream¡

I think you are using wireframe display, however i want to control the real visible edges from this pipes in a Technical display mode, i can make it in Autocad in a simple way, i create tow layers and then printing i set the line width for each layer.

I send a picture maybe is better to explain…

I want to have this print but with Rhino, is possible? I dont find the way


You should be able to do that, yes. I remember running into issues with that a while ago but don’t remember what they were. In your technical display mode, did you turn up the line widths for Edges and Sihouettes under
[mode name] > Objects > Lines?

If that doesn’t’ work, you’ll have to be more specific as to which settings you are using where and if possible send a model for others to look at.

Thanks Wim¡

I modified in properties>view>technical>objets and here i can set a general width for all the edges, silhouettes and curves but i want to control it by layer becose i dont want all with the same width… i know rhino is not autocad but i guess there is some way to control it accurater.

If i want to print three pipes with differents width lines, for example 0,1 mm, 1mm and 2mm width… how can i do?

If i draw lines, this lines are affected from layer properties and consequently print width but with solids are not working…

Does this help? Not sure if this helps when printing though.

Thanks Peter¡

But this setting is general, all the edge are 2 pixel thickness, i want to control by layer…

Sadly trough the layers i dont think this is possible. I don’t know if Rhino has any option to have custom line widths for objects.

The only cheat, I could think up quickly would be putting curves with the correct thicknesses over the objects, but this only works from 1 view, and only if you have just a couple of objects, else it is just too time consuming.

You can make copies of your display mode and modify thickness for each. Then assign a specific mode to a specific object. If you don’t have too many different modes that should be doable.

Thanks everyone¡

I think with Rhino is not avalible this kind of management…

Peter, this cheat works better than you think. Can work from any view. DupFaceBorder, put those curves on new layer with proper line width settings. Print. voila.

thanks Carvecream¡

I have another solution, make2d and then i have simple lines that are affected from layer properties, same solition like you but another way… :frowning:

If you extract the curve you want to gave thicker and put them in a layer they would print as you need.
It’s a @BrianJ trick.

After a good night of sleep, I also figured out that of course if you leave the mesh in too, it will of course cover the ‘backsides’ of the lines.

For now I hope you’ll be able to work for now with these solutions, I would advice the DupFaceBorder way since make2d removes the option to change things easily.

Hey Skysurfer and Peter.

There is a problem with dupfaceborder, in one pipe there is two circles as facesborder, but still missing the real boundary that its depended from the view…

The only other way I would know is the one I proposed, Putting curves at the missing parts manually I’m afraid, perhaps someone else has any other ideas.

but if view changes than this lines are not more valid…

Correct, it’s a very limited solution as I was afraid of earlier in this topic. I had hoped the surface borders would help, but these do not suffice for your cause.

How many different styles are we talking about?