Serious problem with files sent by e-mail / Office 365 Outlook

No, that’ll be Rhino 11 …


:smiley: I’m a bit more optimistic.

Sorry had to go out for awhile… I sent the file before I left though.

I already checked - opened just fine for me :confused: I don’t have Outlook though. So maybe try that rollback @jeremy5 suggested

Yeah, was afraid of that too - recently they changed the whole thing - and not all that much to my liking. But no idea how to roll back to the previous version if possible.

Looks like I actually have the 4th of May version. There is a newer version out (12 May) looks like my Win 10 system wants to restart to install some updates anyway, will see if that helps at all first.

Edit: Nope, now on the latest build of Outlook, didn’t help at all…

Mitch can you reproduce the issue if you open Outlook from the Web?

It may be a bug that corrupts the file when combining the bytes if downloaded from the Win App Outlook.

Perhaps the browser does a better job combining the chunks of byte streams (or whatever they are called)

Yes, it is possible. I’m away from my computer at the moment but googling it will tell you how (from memory, it is simple), if you still need to.

So, that’s it - I downgraded to the April 14th version and things are working again. It’s not all that simple, you have to do it via a command prompt and a special config file. Now I gotta do this on all my other machines.

I can’t be the only 365 user here - as people get their updates I wonder if are we going to have a raft of these problems? I hope it ends up being just me, but as it is not just limited here to just one machine/OS, maybe not? For now, I have turned off Office updates.

Oh, and by the way - maybe the most important point - even if a file is corrupted somehow - it shouldn’t crash Rhino !! Worst case Rhino should just say - can’t read file.

1 Like

I use Office 365 but I don’t use Outlook much. I mean I mostly use the WebApp

Hi Mitch,

Glad you have it sorted for now. It would be a good idea to compare the good v. bad file internals to see what changed.

The issue may not be Outlook itself, could be an Outlook plugin or antivirus, both of which have had their problems before.

Dunno, all I had to do was downgrade and it is working… No antivirus other than Windows Defender.

Interesting to note that even attachments that came in before downgrading now open fine - makes me wonder if the problem happens only when (that version of) Outlook saves the attachments to disk.

I can understand the desire for it not to crash, and maybe that is possible, but in general it can be argued that a crash is what you want, especially when crash reporting is available.

Imagine that there is a part in the file where rhino is reading to find out how many frobitzes will be created, and you hex edit the file to make the number 4 billion … probably it will crash trying to allocate space for them, but is it valid to say “whenever I read a number from the file, I’m gonna check that it’s in a sensible range”? Besides there being too many places in the code for that to be feasible, and the bugs you would introduce in trying to do so, and besides the performance penalty you may pay for it if you did, this is going to come back and bite you in the future, when 4 billion is no longer an unreasonable number of frobitzes.

And even if you do, then I corrupt the file so the number is just below the 200,000 reasonable frobitzes number you picked … but it’s still the wrong number for what actually follows in the file, so we’ve just pushed the problem a few lines further in the code.

Point is, with data corruption you are generally best off to recognize you have entered the twilight zone, and don’t get too clever about trying to fix things up.

But let’s ignore that and say you are able to detect a given type of corruption, what can you do? All you know is that you have an invalid file, so you can put up an error dialog. But we can already consider the crash reporter to be a type of error dialog, and a superior one, since it gives the opportunity for devs to directly inspect what happened, instead of trying to get that info out of a user, if/when they report it.

1 Like

:thinking: I have a real problem following this.

shorter: you can’t reliably do good logic with bad data

@Helvetosaur I was having some unrelated windows issues that started in the past week. For me, uninstalling this windows update solved it. After reading the description of this update I thought about this thread. I have no idea if there’s a correlation but if you haven’t solved this , perhaps this might be something to try.

:edit: i see down grading solved your issue.

Hmm, yeah, I see this…

Maybe something related there…

That’s exactly the line that made me think of you.

Are any of the people experiencing the outlook problem also having issues with Chrome failing to download anything (the download runs competely but then the virus scan fails, on everything, including the latest WIP)? I appear to be having both problems over the last 2 or so weeks and was just expecting it to resolve itself until recently. Downloading with Edge is working fine.


Hey Mitch (@Helvetosaur),

It’s unfortunate that you’ve already “fixed” your system, since none of us can repeat this here…but I do understand the need to get things back in running order as soon as possible.

So, the only thing I can do at this point is ask postmortem type of questions…and hope you can remember the situation(s)…although, I’m still not sure how much that’s going to help in isolating what was happening…

  1. Drag-N-Drop can be a mysterious thing in Windows… So I’m curious if you ever tried just “Save Attachments” rather than using DnD ?
  2. Once the file was on your desktop, was the file icon correct? (i.e. Was it the thumbnail image of the actual file contents? Or was it just a plain icon?)
  3. I’m wondering if the latest Outlook is hanging onto the file internally somehow for some reason(s)…So did you ever try closing Outlook completely before trying to open the .3dm file? In fact, I’d be curious if after dragging the file onto the desktop, if rebooting the computer before opening the file makes any difference…
  4. I’m not sure you tried this (but it sounds like you may have)… This one is sort of along the same lines as the previous one…After dragging the file onto your desktop, right-click the desktop file and drag it again to “Make a copy” of the file… Then try opening the copied file. If Outlook is doing something internally with File I/O for the attachment, it shouldn’t have any impact on the copied file…so theoretically, the copied file should open. Your experiment to upload and then download the file and have it work sort of supports this theory. It also would explain why everyone else can open all of your “bad” files. I think Outlook is doing something stupid with the file internally…which is why I’d be very curious about all of the different scenarios that can exist for getting the attachment to your disk, and then all of the scenarios that exist for what you can do to that file before you try to open it (i.e. copy, move, rename, delete-then-undelete, etc…)… Basically anything that can/would break the “link” between the file and whatever Outlook may be doing with it.
  5. This one is a long-shot…but did you try re-installing Rhino after you updated to the latest Outlook? This may be a “side-by-side” type of issue/condition having to do with certain DLLs that get used/shared across the system…and sometimes a re-install of the affected application can clear that up. (Note: This may actually require a complete uninstall of Rhino and then Reinstall…not just a repair or update)

If you ever run into this problem again, please consider all of the above, and any other possibilities you can think of based on my WAG theories :slight_smile:


Yes, but it always worked before and has again since I downgraded.

Yes, correct icon with thumbnail.

Nope and nope. I still have one of the corrupted files here and it still does the same thing despite having rebooted the computer several times and having Outlook closed. Tried again just now, and Rhino crashed again.

Nope, I have made several copies of the file, no difference.

No, I have not. A service release candidate probably got installed, but I did not uninstall and reinstall. Note this happens with both V6 and the WIP.