Saving as PDF issues

same problem here:

model.3dm (2.8 MB)

reproduced in 5.3.1 and latest WIP version

Hi Marlin, you’re right it’s a different file, and I understand your need for consistency, but it seems to happen on every file now. As you can see from epiphany below, he’s experiencing the same problems too. Be great if you could fix this as it’s a real pain - whether actually printing or creating PDFs, for quality purposes you need the Vector setting.

experiencing this too when selecting vector option, in the print window it looks fine, but when I print out the document it has shifted and my text boxes are not in the printable area :frowning:

I have version 5.3.2 of Rhino for Mac and I just thought I’d let you know that I’m still experiencing this issue with Printing to PDF - what you see in the print preview window is what you get with the PDF if you stick to raster output. However, if you change to Vector output (my preference when trying to out put a drawing), the resultant PDF has the drawing offset so that it’s pushed up to the top left corner.

Hi Dom - I’m not seeing this here either, but in 5.4 now.


from the layout window, then opening the print dialogue box, I still get a small shift when choosing between raster and vector, my preferred option is vector too, it’s definitely problematic when you need to print documents out, not such a big issue when just saving as a PDF document

5.4? I’ve just checked for updates on my current version of Rhino and it’s saying I have the latest version (5.3.2) or is 5.4 a new purchase option?

Hi Dom,

5.4 is the WIP ( work in progress), and you can download and install it for free alongside the official one, 5.3…

Take a look at this link:

Thanks for that. I have downloaded and installed the latest RhinoWIP and again tried the PDF issue and received the same results. See attached.RhinoWIP_PDF.pdf (181.7 KB)
RhinoWIP_PDF(raster).pdf (397.6 KB)
One of the PDF has been created when the print options were set to Raster and the other is when this option is changed to Vector…you can see that the raster PDF has the drawing and it’s rectangular border centred, whereas despite all settings staying the same, when the vector option is selected, the drawing/rectangular border is offset. Any thoughts why?

Can you please tell me the exact manufacturer and model number of the printers you are using? We are unable to duplicate this with any of the printers we have here. I suspect this is a printer driver issue. Thanks.

lates WIP explodes closed paths to single segments - files cannot be postproduced in illustrator (fills etc.).

Actual stable version keeps in exported pdf all polylines closed.

I’ve noticed the exploded single line segments too. I have a Lexmark C925, but I think this theory has been offered before so I tried connecting another printer, a Samsung ML-2240 and this didn’t resolve issues. Seems odd that it’s fine in Raster output though if it’s to do with the printer driver. If no printer was connected, can you not “Print to PDF”?

Finally solved this. It is not a printer driver issue. I started methodically testing all the possible printing combinations and found that when using fixed scaling and vector output, setting non-zero print margins in the Print dialog would change the location of the output image. This will be fixed in the next WIP release. In the meantime, you can set the margins to zero in the Print dialog to get correctly placed images in your PDFs.

Still researching the exploded paths issue.

1 Like

Hi @epiphany-

Thanks for reporting this. Unfortunately, I’m having trouble reproducing this difference in behavior between 5.3.2 and 5E63w (the latest RhinoWIP as of today). Can you please provide the file you used (the 3dm), the export/printing steps, and the steps in Illustrator to demonstrate what you are seeing? I tried to reproduce what I think you are reporting, but I came up with the same result each time.

Here is what I did:

  1. Created TestPolylineExportToIllustrator.3dm (3.0 MB) in Rhino 5.3.2.
  2. Navigated to Print > Output: Vector > PDF > Save to PDF… and named the file TestPolylineExportToIllustrator_5_3_2.pdf.
  3. Opened the same file from step 1 in RhinoWIP 5E63w and repeated step 2, this time naming the file TestPolylineExportToIllustrator_5E63w.pdf.
  4. In Adobe Illustrator CC, I opened TestPolylineExportToIllustrator_5_3_2.pdf. I selected the Groups, right-clicked and selected Release the Compound Paths. I think selected the curves in bottom-most path (the rounded one) and right-clicked to Join them.
  5. I selected both polylines and filled each.
  6. I repeated steps 4 and 5 with TestPolylineExportToIllustrator_5E63w.pdf.

I got the same result for each file. What are we doing differently?


Hi dan,
please try this 3dm file:
example.3dm (4.4 MB)
steps to reproduce:
Rhino: Layout - Print - Vector output - Save as PDF
stable version output: output01.pdf (609.0 KB)
WIP version output: output02.pdf (608.6 KB)

In Illustrator (CS6):
Release Clipping mask - select eg any chair - Release Compound Path


  • stable version output keeps closed polylines closed
  • WIP version output produces polylines broken into single segments (unable to fill).

Thanks for sending along those files.

When I start with your example.3dm, I am not able to reproduce the issue in 5E63w when using the Print > Save to PDF. This is a screenshot from the output produced by 5E63w that I created

When I use your output02.pdf, I am able to reproduce the issue, but only on certain curves, like the arcs…

…but not with many of the other closed polylines…

It is bothersome still that I cannot reproduce the issue from the 3dm file you provided, but I think I see what you are seeing with the output2.pdf that you provided.

@marlin any ideas?

@dan The original issue is that 5E63w and 5.3.2 produce different results. It is not clear to me that you have confirmed that issue.

I am not able to produce different results between 5.3.2 and 5E63w with the example.3dm file that @epiphany provided above following the steps he provided.

I am able to see that output01.pdf and output02.pdf provided by epiphany behave differently in Adobe Illustrator.

I think, It could be related to blocks/trimmed circles?
stable version pdf output in Illustrator:


Create new file
Create circle/polyline with arcs, trimm that circle and create block.
Copy block, edit block, offset circle, Apply
Test PDF outputs in Illustrator