Saving as PDF issues

The step you have provided do not produce a closed shape.

If I presume that you checked the Cap (Flat) option when Offseting the Arc, I get results that fill in Illustrator like this, regardless of whether or not I use 5.3.2 (stable) or 5E63w (WIP)…

I do not see a difference between 5.3.2 and 5E63w, but it certainly doesn’t look correct to me.

It doesn’t matter if the shape was closed or not. Trimmed circle is interpreted as single (closed)curve in stable version compared to multiple segments in WIP.

Could you test it with Epson drivers, please?

Sure. I am getting consistent results between Rhinoceros 5.3.2 (5D197) and RhinoWIP 5E75w using Epson drivers.

At this point, I’m lost; I don’t see what you see…and I don’t actually know what you expect to see. I am able to create closed curves from Rhino, Save to PDF, and fill them in Illustrator without issues…in both 5.3.2 and the current RhinoWIP (5E75w).

Perhaps you can post a simplified 3dm, please? If you can also post detailed steps for how you created this model, that would also be appreciated.

expected results: closed polyline is opened in illustrator as closed curve, not exploded single segments.

Looks like there is new WIP relased now, I’ll test it tomorow.

On my machine, a closed curve created in RhinoWIP (5E75w) that saved is to a vector PDF and opened in Adobe Illustrator CC opens as a closed (compound) path that is easily edited and filled.

I look forward to hearing what you experience in RhinoWIP 5E75w.

Yes, great - thank you, that works now!

Seems to be fixed in latest WIP. Thanks @dan

Not sure if this is the same issue other people are discussing but I am getting a ghosting effect where certain lines ghost through the solids.

This is what I see in model space (this is displaying correctly)

This is what I see in “Layout” display (and when I print) …

If I zoom in to the layout …

and zoom in some more, it goes away …

These are my print settings …

Any ideas how to make this display/print properly?

When I hide the other objects in the file. It displays properly…


I have tried SelectBadObjects and it says that there are no bad objects in the model.

I have Audited and it says: No errors.

Does reducing the value for testZBiasFactor help here?

A post was split to a new topic: Cannot print to PDF