PDF Print Quality

macandwindows

#1

Does anyone know how to increase the print quality when outputting PDF’s from Rhino for Mac?

It appears to be printing at the screen resolution which is making the lines very clunky and pixelated.

This is a zoomed in shot of the lines…

Compared to a zoomed in screen grab of the model …

These are the print settings that I tried…

Acrobat%20Settings


#2

Just a follow up, I tried the workaround of printing the A3 layout at A1 (thereby forcing Rhino to increase the print resolution) by scaling the print to fit, but Rhino just refuses to scale it up (despite the settings indicating that it’s being scaled). See attached…

When I manually try to instruct it to scale up it wont do it either…


#3

Under Printer output, you should select Vector output.

Hth,
Uli.


#4

Same thing. Print settings …

Output…


(Fabiano Friedrich) #5

Have you tried moving the model to a new file?
Because it works fine on my end:


#6

I just tried moving all the objects into another file. Same output :frowning:

You want to have a bash with my file? See attached.

Counter.3dm (19.5 MB)


#7

not sure if this better, the perspective in rendered display mode still looks a little jagged when zoomed right in, file attached Counter Layout .pdf (2.6 MB)


#8

Still not great is it? I think its the same as my output.


(Fabiano Friedrich) #9

It looks like when you print in SHADED or RENDERED the lines gets pixelated.
Previously I printed as wireframe.

FUrthermore. I got some very strange results with your file @Seychellian
1 - When I opened your file I got this weird flickering in the viewport: https://discourse-cdn-sjc1.com/mcneel/uploads/default/original/3X/d/5/d56c257d5e88e517918c15a65f0af62ffeacf23a.mov

2- After I closed the file, a lot of my view modes had changed and Rhino started to work a little slower. I had to re-import my preferences to get it back working again.


#10

There seems to be something missing from your printing interface. This is how mine looks:


Yours does not give a choice between “Viewport”, “Extents” and “Window”, and as you can see the latter gives a similar result to your version, i.e. the scale is set as “Scaled to Fit”, yet the picture does not extent to the full page size.
It appears that the “Window” choice asks for a window to be set around your objects, meaning that the printing resolution will be applied to the entire window setting. This could explain the bad resolution of your pdf, when for some reason a large window has been set around your objects.

Max.

Edit: I see that your 1:1 scale picture shows the objects filling the entire sheet, which sort of dispels my theory. But the missing input fields still remain mysterious…


#11

yes i noticed that ‘flickering’ too, there was also a random piece of geometry way out in space,


#12

Hi @Seychellian, I think I solved the issue, is this the quality you are looking for?
Counter_jespizua02.pdf (2.7 MB)

When opening with Preview, wait a little bit, at the beginning it’ll appear a little blurry, at least on my computer.


#13

I have no idea why I am missing that setting from my print dialogue. This is my OSX and Rhino version info…


#14

Hi again @Seychellian, here you have your file “fixed” :wink:

There were a few problems with your file. Your drawing was very far away from the origin, and if you use _ZoomExtend you could check that there were curves very far from your model. There were also 2 bad objects and many duplicated ones.

I moved your model to W0,0,0 and deleted all curves that shouldn’t be there. There were also curves in Layout very far from the page, did you copy-paste from one file to another?

The problem is that when you move the model, your detail views are no longer synchronized, so you have tomanually update all details views one by one. I did a few of then but you will have to finish them and check everything because I eyeballed the ones I did.
Counter_jespizua.3dm (17.7 MB)


#15

And here is the pdf. As I told you, there are detail views that are not in sync…
Counter_jespizua.pdf (11.8 MB)
Edit: In my home computer I have to wait a few seconds until Preview will show a sharp image…


#16

Hi jespizua,

Thanks for the files. Your PDF print is indeed more crisp when I open it, however I am unable to reproduce that quality when I print from your 3dm file. Could you do a screengrab of your print settings for me to cross check?

These are my settings and my output (on your 3dm file) …

and this is the output…

Counter jespizua.pdf (424.9 KB)


#17

Here are my print settings


As you can see, I’m Saving As PDF from the drop down menu.


#18

Yes me too :persevere:


#19

Checking your screen grabs I see you are using 5.3. I’m using 5.4 (commercial, no wip)


#20

Not sure, this is a company computer so I assume that it’s a commercial license also. Is it a free upgrade to 5.4? I thought all versions of Rhino for Mac were still WIP.