Rhino 6, printing to PDF, vector crvs terribly distorted


I have finally updated to rhino 6 for Mac, and have come across an issue which I trust someone can help me resolve.

When printing to PDF, all my crvs become terribly distorted. I never had any issue with rhino 5 doing this, so I assume this should not be too hard to resolve?

here attached a screen grab of how some circles and leaders come out,



Oh, and one more thing. seems to be crashing alot, and I am getting very weird things happening, like with my screen going red…

Can you run SystemInfo in Rhino and post the results here?

Here we go…

Rhino 6 SR18 2019-9-23 (Public Build, 6.18.19266.13352, Git hash:master @ 3d84f88dec99b2f4e8b7497e739ed2adc2ba8ef6)
License type: Educational, build 2019-09-23
License details: Stand-Alone

Apple Intel 64-bit macOS Version 10.14.6 (Build 18G95) (Physical RAM: 32Gb)
Mac Model Identifier: MacBookPro15,3
Machine name: Andrew’s MacBook Pro
Language: en-GB (MacOS default)

AMD Radeon Pro Vega 20 OpenGL Engine (OpenGL ver:4.1 ATI-2.11.20)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: Radeon Pro Vega 20
Displays: Color LCD (258dpi 2x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
Radeon Pro Vega 20 (4 GB)
Color LCD (1680 x 1050)

USB devices
Apple Inc.: iBridge DFR brightness
Apple Inc.: iBridge Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: iBridge ALS
Apple Inc.: iBridge FaceTime HD Camera (Built-in)
Apple Inc.: iBridge

Bluetooth devices
Broadcom: Broadcom Bluetooth Wireless Mouse SDP Server, Broadcom Bluetooth Wireless Mouse, Broadcom Bluetooth Wireless Mouse PnP Server

Third party kernel extensions
com.getdropbox.dropbox.kext (1.10.3) F29DD0CB-48D6-311A-9B69-E39CF775493C

Third party plugins
/Users/andrewhaythornthwaite/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/KeyShot8RhinoPlugin.rhp/libkeyshot_rhino_plugin.dylib

Rhino plugins
/Applications/Rhinoceros.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.18.19266.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.18.19266.13352
/Applications/Rhinoceros.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 6.18.19266.1002
/Users/andrewhaythornthwaite/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/KeyShot8RhinoPlugin.rhp “KeyShot8RhinoPlugin”
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.18.19266.13352
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.18.19266.13352
/Applications/Rhinoceros.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.18.19266.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.18.19266.13352
/Applications/Rhinoceros.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.18.19266.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.18.19266.1002
/Applications/Rhinoceros.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.18.19266.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.18.19266.13352

Well, not a Mac expert, but everything looks OK and up to date… I wonder if the Keyshot plug-in could be causing some trouble…?

Hi, the key shot plugin has never given me any issues before with the rhino 5…

However, it seems strange that the print to PDF in vector is so incredibly bad… that must be a setting right?

I can confirm I’ve had both distorted vector printing issues and the red PDF issue on my 2019 mbp with i9 and vega 20. I’ve never installed any plugins. Let me know if my system info would be helpful and I’ll send it later today.

HI, did you ever manage to resolve these issues? in particular the printing to PDF, and being able to get clean crvs?

or has anyone else managed to resolve or can help here?.. It seems like a bad oversight if this is unable to be resolved.

Hi Andrew,

I haven’t found a solution to printing clean curves. I don’t have any printer drivers on my computer though, so I’m not sure if that affects how curves are printed. It’s agree that it’s a pretty big issue. After printing a full size architectural set last week i was disappointed with how distorted my line work looked when printed full scale.

Every Tuesday I’ve been updating to the latest beta and lately haven’t had any issues with the red screen. If it happens again I’ll follow up on this thread to see if I can get to the bottom of it.

The entire layout/printing seems still very immature.
We’ve consistently had problems getting the right scale.

For the curve-distortions: Can you try to change your tolerance settings (e.g. from 0.01 to 1) and see if this helps?

We’ve also been “more successful” using the workaround “export selected” as PDF.
Not a nice solution, as scaling doesn’t seem to work.

I tried changing the layout and model space tolerance from .001 to .1 but it didn’t have any effect. See screenshots below…

Hi, thanks. I have also tried this however as you say it seems as though it is not possible to control the scale output. I have also noticed that when exporting to pdf, it looses allocated line weights and turns texts to plain, i.e if they were bold, etc…

Is there away to get anyone from @mcneel involved on this topic. I would assume this is a pretty big issue that should be able to be fixed, especially as it worked in Rhino5 and now not in Rhino6

Maybe the only way is to ask them?

@mcneel, we ask you to please help!

Thanks for checking…

I have also got in touch with the mcneel.eu tech team directly by phone and email. I believe they are also kit having much luck… But if any positive results come of that I will post them

Completely agree, Andrew, and would also greatly appreciate if @mcneel can help sort this out. As is, this issue renders the current V6 release unusable for production.

Hi @a.p.haythornthwaite,

It’s really difficult to diagnose problems with screen shots. Is it possible that you are zoomed in really far on the detail of a PDF that is, in all actuality, about 10mm high? Can you please attach a 3DM file with as few objects as possible, the resulting PDF, and screen shots clearly indicating the area of the model and PDF that you don’t like?

HI Brian,

Thanks for your reply, most appreciated.

The reason for the initial screen grab was to illustrate the output. I would also say that it is not about what I don’t like, but more that in Ver5 the out put is much cleaner than in Ver 6… to me this seems strange.

please see attached rhino Ver 5 and Ver 6 files, which are in effect exactly the same, with corresponding PDF out puts.

you will notice the differences in particular when you look at the circles.

Look forward to hearing from you,

please also note that I have had a response from @stevebaer on this topic too from a separate private message… so maybe we concentrate efforts with either your self or Steve on this. Please let me know.



QWERTYUIOP _ TEST 2 _ Rhino Ver5.3dm (5.6 MB) QWERTYUIOP _ TEST 2 _ Rhino Ver6.3dm (5.7 MB) QWERTYUIOP _ TEST 2 _ Rhino Ver5.pdf (70.0 KB) QWERTYUIOP _ TEST 2 _ Rhino Ver6.pdf (54.9 KB)

I’ll keep the conversation open here instead of in the private PM.

For reference, I recommended that Andrew try the File…Export…PDF option instead of printing to PDF as that uses different code to generate the PDF on Mac. We tried incorporating this new code into the print dialog, but ran into some technical snags that will require us to write an entirely new print dialog on Mac to support the new PDF exporter.

Unfortuantely we just discovered that there is a bug in this file exporter that does not allow the scale to be changed . @BrianJ please reference this discourse post as you are adding the PDF scale bug to youtrack.

I do see the chunky output that you are seeing in the V6 PDF print. I’ve added this to our bug tracker at

HI Steve,

Thanks, Also another couple bugs I have noticed with the export to PDF is that it removes allocated line weights to the default weight setting. It also changes any texts which are bold to plain.

OK, Thanks,

Is this something that will be resolved in the foreseeable future you think?

I recently upgraded to V6, however the printing issues means that I have had to revert to using V5. which is unfortunate, as would be nice to use the programme, along with utilising some of the new features in V6.