Right clicking completes the command instead of toggling the options

mouse
command

(3012294) #1

Hi Rhino Community

This applies for every command, basically when I type in a command like Extrude_Crv it brings up a list of options which you can normally quickly toggle by pressing the key that represents it like B for Both Sides or S for Solid and then right click. But all of a sudden when I right click instead of toggling the option for the command it completes the command with whatever toggled input I put in.

However when I press enter it still toggles the command options? So I am not sure what the answers is. Can someone please help me?

Normally I find the answer to what I am looking for out on the internet or solve it through brute force but this is the second weekend in a row where I haven’t been able to find or solve this problem. I have tried restoring my aliases to their defaults, changed my mouse and updating to see if the the right click is faulty but those three things don’t seem to be the problem. I also tried to restore my mouse preferences back to the default but there was no option there when I looked so it must be a windows only feature.

Thanks


Goodbye RhinoWIP for Rhino 5 for Mac
(3012294) #2

RightClick_Example.3dm (3.0 MB)
Also here is a file where the problem persists, however I think this is a settings issue so I doubt it will help.

Thanks


#3

What are you’re settings for “mouse” in Rhino? There is a setting (checkbox) for this behavior.


(3012294) #4

Hi Toby,

Thanks for the reply, I dont have access to my computer at the moment but I will take a screenshot of the settings and post it here as soon as I get home.


(3012294) #5

@Toby Here are the settings for my mouse.

Also wow, sorry for the late response, I really took my leisurely time


#6

As far as I can see this works only if you use the “floating window” version of the options dialog.
With command options in the sidebar I have the same behavior (completes command).


(3012294) #7

Thanks Toby,

This is very close but the floating box has some problems since it takes up to much real estate especially on a laptop and the window resets its position (In the center of the screen) instead of remembering the last place it was in (In the top right part of the screen). It also doesn’t allow you to right click to enter the initial command :/.


Again, close to a solution but it still slows me down. Would you have any other guesses to what’s going on? Thanks for staying with me.


(3012294) #8

@toby Also, has it always autocompleted for you when in the sidebar? Your previous comment sounded like you ran into this problem when you switched the Modeling Commands Sidebar options back and forth, or has it always completed the commands on right click in the sidebar?

Thanks


#9

It always completes the commands on right click when using the sidebar version and works always as enter for the chosen option in the floating version (the behavior you are looking for).

That the command search floating window doesn’t store the position is a bit annoying, as the option window does remember the last position.

[edit] a workaround for your problem in the command search window is to scroll one (or more) command(s) forward and then left click on the one you actually want.


(3012294) #10

That’s odd, I have right clicked to toggle command options in the sidebar for the past year and couple months. It just started completing the commands on right click with sidebar about 11 days ago on my Mac.

Also when I go to work and use Rhino there the toggle on right click with the command sidebar still works fine (even though it is the Windows version).

Please someone help? I feel like I am the only person who has ran into this problem but there has to be an answer somewhere on why this setting changed for me a couple days ago.

Also thanks for staying with me Toby, unfortunately we still haven’t found the answer. :frowning:


#11

Have you changed some options 11 days ago or installed an update? The behavior ist consistent on my Notebook and Desktop (both 10.11.6 and Rhino 5.4)


(3012294) #12

No :confused: , I did not do anything outside of the norm of using it to 3d model new objects, I will try uninstalling it and then reinstalling it soon and see what happens.


(3012294) #13

This failed. I have always right clicked to toggle command options in Rhino and I feel like I am taking crazy pills right now because all of a sudden it seems like that never existed?? I reinstalled the program along with deleting the preferences.

The only thing I can think of is that if I had an older version of Rhino 5 maybe it would work again?


#14

Mmhh, probablby this was a “WIP” thing which wasn’t implemented in the finals.


(3012294) #15

Ok, wow, so I am looking at this forum post, Goodbye RhinoWIP for Rhino 5 for Mac. It was posted 25d ago so this matches up from when the problem started!

So I guess there is no way to fix this :slight_smile:

Why the downgrade? This for one obviously needs to be a setting and Second having this as the default is less efficient and intuitive work flow. I have to lift my right hand off of the mouse and press the enter button to toggle or go back and forth on the screen. As someone that has to work in Rhino a lot I will be doing this a thousand times a day. I guess I will keep this post alive until it’s fixed?

Thanks for the help Toby!


(Dan Belcher) #17

Apologies for the delayed reply.

I have checked Rhino 5.3.2 and Rhino 5.2 and - to my knowledge - this is how it has worked for quite some time in the Command Options in Sidebar. I doubt this is a regression in 5.4, but hopefully someone here will correct me if I’m wrong.

I’ve logged this in RH-45073. Please take a look and make sure I’ve captured your request properly.

If I am understanding correctly, your muscle memory has been trained to right-click. Is pressing space after entering the command option working for you? Just looking for a workaround here.


(3012294) #19

I guess this is the case. Space does work and it is better then pressing enter or using the Dialog box!

Also thanks for making the request, it addresses the problem exactly. I guess this would be in Rhino 6 since the page says 6.0 under release target.

I do want to point out again that it does work in the Windows version at work, I was probably blurring the lines of my personal Mac version which caused my bad assumption.

Thanks Dan!