Rhino3D and Linux (it works!)


#1

Hello guys,
you know that Rhino3D runs perfectly under Linux?
I used a derivative of Wine that works great.
You can also test it using the trial version of Codeweavers CrossOver and Rhino3D both.
They have created a system that uses macros dedicated to each software that solves all the necessary dependencies automatically.
Each software is installed in a specific container where environment has everything you need to run Rhino without going into conflict with other software.
So I abandoned Windows (at home, in the office is unthinkable) and I can finally enjoy my beloved Linux Mint ^____^ and the fabulous and super-loved Rhino3D!


#2

Perfectly? Not unless Codeweavers updated their install script within the last 4 months.

Yes, it runs - you can do creative work and save it.
No, customizing the interface does not work - as of August 2016.


#3

From my experience the interface is customizable.
But …
In a first period I could turn on or off the layers by clicking on the light bulb, but it does not work now and I am forced to use the layers options via the right mouse button. This is the only problem I found.
In all cases the performances are slightly lower than in Windows that, for a non-intensive use as in the office is more than excellent.
Then Linux Mint is a very light and versatile system so I’m really pleased to see my favorite CAD run stably.


(Nathan 'jesterKing' Letwory) #4

I installed Rhino 5 on my Linux Mint 18.1 machine using CrossOver. For fun I decided to run @Holo 's HoloMark 2.

The plug-in seems to get the GPU incorrect, but the Options > Views > OpenGL panel fortunately shows that I am using the RX 480. I did install amdgpu-pro driver to fully utilise its power.

The machine:

/Nathan


#5

Wow, cool!
I am not sure wonder why Holomark only picked up the integrated gpu and not the 480.
Also I see that technical display mode took an awful long time to complete, I have no idea why that happened.

Have you tried running windows 10 on the same machine?


(Nathan 'jesterKing' Letwory) #6

The linux install runs from a SSD drive in a PCI-E slot (around 20 seconds), because I got annoyed at the slow boot speed of Windows 10 on the very slow HDD drive (over five minutes). I have the drive still in the machine so I suppose I could try booting into it soon for comparison.

I don’t know what the technical data computation entails, but my guess is that it is something in the Wine layer that makes it take over 700 seconds. It’d be interesting to see what happens in Windows 10 indeed. For you I could boot into it one more time (but I’d rather never use it again on my own machine :wink: )


#7

What? Windows 10 is for me the best version of Windows so far… Sounds like you did a win7 -> win10 upgrade and not a full reinstall. Never trust those upgrades, they carry over all kinds of shitty programming from small vendors (they are clever and store stuff out of protocol). Uninstalling a program that was installed on windows 7 (after you have upgraded) can be a nightmare and really mess stuff up. So I would give it a second go as a clean install, not because I think you should use it, but because you are a programmer and I think you would enjoy the process.

But don’t do it for me, my hands are full, and if you find a bug then I have to spend time on it… :frowning:

:smiley:


(Nathan 'jesterKing' Letwory) #8

Don’t worry, it was a clean install :slight_smile:

It is just that the HDDs aren’t the fastest around, so it takes a long time for the system to boot from them. I’m right now running the HoloMark2 on the Win10 with RX 480 (had to unplug the monitors from the R9 though).

Results:

Holomark 2 v2,2,03

Total Score: 43246
Total Runtime: 332.99 sec

GPU scores: 34050
GPU_01 - 339.00 fps - Cube 4 tests
GPU_02 - 27.70 fps - UDT Shape
GPU_03 - 48.10 fps - Wireframe
GPU_04 - 30.50 fps - Shaded
GPU_05 - 21.70 fps - Rendered
GPU_06 - 22.20 fps - Block Rendered
GPU_07 - 11 units Nurbs @ 5 fps in Wireframe
GPU_08 - 7 units Nurbs @ 5 fps in Shaded
GPU_09 - 21 units Nurbs @ 5 fps in RenderSpeed
GPU_10 - 65.80 fps - RenderMesh Render
GPU_11 - 256.40 fps - RenderMesh RenderSpeed
GPU_12 - 85.50 fps - JoinedMesh Render
GPU_13 - 769.20 fps - JoinedMesh RenderSpeed
GPU_14 - 5 units mesh @ 15 fps in Shaded
GPU_15 - 6 units mesh @ 15 fps in Render
GPU_16 - 600 units mesh @ 15 fps in RenderSpeed
GPU_17 - 46.70 fps - mesh in Rendered Studio
GPU_18 - 7.20 fps - Nurbs in Rendered Studio
GPU_19 - 18.40 fps - Block Illustration
GPU_20 - 49.80 fps - 2D single
GPU_21 - 5.70 fps - 2D massive (20x)

CPU scores: 9196
CPU_01 - 13.60 sec - Booleans and Contours
CPU_02 - 2.21 sec - Twist and Taper (UDT)
CPU_03 - 6.62 sec - Meshing Mini
CPU_04 - 0.09 sec - Extract Render Mesh
CPU_05 - 0.11 sec - Join Render Mesh
CPU_06 - 22.88 sec - Reduce Mesh
CPU_07 - 3.56 sec - Calculating Technical display
CPU_08 - 5.30 sec - Making Silhouettes

Gigabyte Technology Co., Ltd.
To be filled by O.E.M.

VNC Mirror Driver - ERROR AdapterRAM
DriverVersion: 1.8.0.0
Radeon ™ RX 480 Graphics - 4095.0 MB
DriverVersion: 21.19.151.3
AMD Radeon R9 200 Series - 2048.0 MB
DriverVersion: 21.19.151.3

AMD A10-6800K APU with Radeon™ HD Graphics
NumberOfCores: 2 NumberOfLogicalProcessors: 4
MaxClockSpeed: 4.1 GHz

TotalPhysicalMemory: 16.0 GB

Microsoft Windows 10 Pro

  • None - 64-bit

Rhino 5 sr 12 64 bit

Technical display calculation… 3.56 seconds against a lifetime :slight_smile: I’m pretty sure it is down to Wine emulation layer, but without actually debugging that probably hard to say for sure.


#9

This is wonderful! I’ve given it a spin under the debian testing version (stretch, version 9 beta), and it works pretty well! There are some quirks with redrawing, and other things, but all in all it does seem to work.

I’ve read that wine is still a bit more quirky with 64bit programs, this may be why rhino 6 is not working yet?

All in all, thanks for mentioning this!


(Nathan 'jesterKing' Letwory) #10

I did try installing Rhino WIP in a x64 Win 10 bottle under CrossOver, but I am having trouble with the gdiplus.dll . Although I have GDI+ installed CrossOver/Wine fails to load/find it.


#11

I’ve also tried grasshopper, this initially seems to work, but after adding components it gives errors in drawing the components to the canvas, and ultimately ends up in a misery of breakpoints.


#12

I personally hope that the Rhino3d developers help the Wine project suggesting how to resolve the dependencies correctly. apparently the Linux versions are unlimited but in fact the most common office oriented systems are those based on Ubuntu and derivatives. A BIG Linux lacks is CAD related (as Rhino3D) and users could widen between Rhino enthusiasts and cascading down to the professionals. Perhaps neither Linux nor Windows are the future because of the huge crisis of desktop PC systems, maybe the future is Android or a super closed Windows app system but bigger is the audience more is spread a system and this can be also applied to the professional that over time has shown sensitivity towards free solutions such as Blender that was used into school by students. Students and enthusiasts are an important weapon for the deployment of software.


#13

Small bump: I’ve got grasshopper to operate under crossover by adding the gdi+ package to the rhino bottle. After installation of the gdi+ package grasshopper also works.


(Nathan 'jesterKing' Letwory) #14

Have you been able to set up a 64bit environment too with GDI+ ? I tried that to install Rhino WIP, but I run continuously into GDI+ problems with even just the installer :confused: Would be great to test Rhino WIP under CrossOver too.


#15

No, I’m having great difficulty getting just .net to install under the 64bit version of wine (both 2.0.x and 2.2x.). Rhino 5 64bit is also not installing here…