Rhino slow saving

Hello, I am new to rhino and have been modelling for the past week. It has started to take forever to save the file and I have no idea why. Also i noticed my PC starting to go nuts with the fans and its been using 100% of my CPU. Any ideas why??

Thanks
Joe

Hi Joe - can you please run the SystemInfo command in Rhino and post the results here?

-Pascal

Rhino 6 SR11 2018-12-14 (Rhino 6, 6.11.18348.17061, Git hash:master @ 600b621e607cf5226a968db60d7ac9230541b94d)
Licence type: Evaluation, build 2018-12-14
License details: Cloud Zoo. In use by: Joe Lloyd Thomas Ricketts ()
Expires on: 2019-03-29

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: JOE-PC

GeForce GTX 970/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 388.13)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-27-2017
Driver Version: 23.21.13.8813
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\import_SKP.rhp “SketchUp Import”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\import_ACAD.rhp “AutoCAD file import: import_ACAD”

Hi Joe - can you disable VRay in Options > PLug-ins, then restart Rhino and see if the problem persists?
(You might want to look for an update from the NVidia website for your video driver, though that is not, I’d think, connected to the problem you report - it’s just getting a little old-ish and Rhino generally seems to like 'em up to date)

-Pascal

Hi Pascal,

I have updated my GPU driver and disabled VRay but it is still taking a long time to save.

-Joe

How big is the file? Are you saving to a local disk or a network drive?

148mb on Network drive (OneDrive)

Hi Joe - and if you save the same file to the desktop? Also, what if you SaveSmall to the OneDrive?

-Pascal

1 Like

Hi,

I’m having the same problem. Any suggestions would be incredibly helpful.

Rhino 6 SR11 2018-12-14 (Rhino 6, 6.11.18348.17061, Git hash:master @ 600b621e607cf5226a968db60d7ac9230541b94d)
Licence type: Commercial, build 2018-12-14
License details: Cloud Zoo. In use by:

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: SFMDUMONT-D3

Quadro P4000/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 392.00)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-30-2018
Driver Version: 23.21.13.9200
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.11.18348.17061
C:\Program Files\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino.Plugin” 2.4.18304.1343
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.12.6.531\SectionTools.rhp “SectionTools”

I am still finding saving to our company server is extremely slow. It is successful, but very slow. Saving locally on the PC is very fast. I have had to work on projects locally and back up manually to our server where all jobs reside. Are there many users having this issue, and if so, is a fix being worked on? This issue is the only issue with v6 that is affecting my daily workflow - very happy with many new features in v6.

Any solution to the slow saving in R6? I’m having the same problem. File size is 832 MB and took 3 mins 31 secs. System Info:

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Educational, build 2019-02-27
License details: Cloud Zoo. In use by: hayden_mills_tt ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: HAYDEN-HP

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 12-10-2018 (M-D-Y).
Primary OpenGL: NVIDIA Quadro P3200 (NVidia) Memory: 6GB, Driver date: 6-14-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 391.76

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-14-2018
Driver Version: 23.21.13.9176
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - are you saving to a cloud-synced folder like DropBox or GoogleDrive?

-Pascal

Hi Pascal. Saving to HD.

Hello - what if you save to the desktop - is that the same?

-Pascal

1 min 29 secs . No changes made though as I just opened the file to save to the desktop. Still seems like a long time to watch an hourglass maybe?

Hi,

I also have exactly the same problem. I have to save my Rhino file locally on my PC and then copy/paste the file to the server. That’s really not super efficient but i couldn’t fix the problem otherwise. Any idea?

Best,

Frank

We use VRay 3.6 plugin - I thought maybe it was related (looking for textures). I haven’t found a work-around. Others having same issue:

Hello - do you see any difference if you disable VRay and restart Rhino?

-Pascal

Hello - yes, it seems long, and I can confirm a save of 1GB is also very long here - much longer than what you indicate, in fact. I’ll see what I can find out.

-Pascal

Thanks Pascal. Keep us posted.