Effect of meshes on save time Rhino V5 v V7

I have created a repeat pattern grille of an original item.using photogrammetry Agisoft Metashape.

I was finding each project save was 54 secs. Autosave every 20 mins stopped me for a minute !

Looking at meshes and effects, Rhino V5

The effect of meshes on saves.
3 meshes , rhino file size 382,442Kb 54 secs a save

Meshes were :-
section of grille, Ruler parallel chassis 19,956kb obj
section of grille Ruler at end 29,124Kb
grille no rulers 451,828 kb, 3403629 vertices, 5882795 polygons with normals

Delete meshes and photos ,… Rhino file size
1 grille (BlockInstance used). 15,224Kb. 3secs
15,291Kb 3 grilles (copies of first Block Instance grille), 3 secs

As I am going to be working with meshes a lot, with photogrammetry, is V7 going to be far better on this ?

PC will be same Processor, same memory and same Graphics card
i7 4790 3.6 GHz
32Gb DDR ram vengeance Pro Corsair
MSI Nvidia GTX970 4Gb ram.
just win 10 64bit pro installed to new SSD for C drive and data drives will also be SSD.

I have now saved the file as a new version deleting out all the meshes and photos to move on at speed.

I have many photos to form the rest of the item in Agisoft.

Hate to think the size but roughly 12 times that of the grille.



Yes, well when you look at the difference in file size between with meshes and without:

382Mb vs. 15Mb - that’s 25 times as big. So, all things being equal, if it takes 3 seconds for 15Mb to save, it could take as much as 75 seconds for 382 Mb. But 3 seconds to save a 15Mb file is very slow - that should be almost instantaneous.

This will mostly depend on how fast your hard disk is. A fast SSD will make a lot of difference in save time over a slower SSD or a rotary disk. Here a 650Mb file with one large mesh takes 3 seconds to save on a recent SSD.

all the SSD’s bought are Samsung 870 QVO, 7 of them.
No doubt they are slow. I thought SSD’s were all the same speed.
too late now, or perhaps not, havent undone them yet.

at £700 I would hope they are good. I dont have any more dosh to spend on such, need it to upgrade all the progs. 150 on PC, some may be free updates.


I don’t think your SSD is that slow, these are really good ones. have you tried it with V7? I suggest downloading a 90-Day trial and test it for your self.

Seven SSD’s? Wow, OK, I only have two… But it sounds like you haven’t installed them yet?

As you are still working in V5, you might also be suffering from V5’s automatic file compression on saving, which reduces file sizes on disk at the expense of a (considerably) longer time needed to save a file. In V6 and later you can turn this off via an advanced setting, which is one of the first things I do. The time savings is dramatic; disk space (local at least) is cheap these days.

So I retested with V5 here and it does indeed take longer - my 650Mb file takes around fifteen seconds to save in V5 as opposed to three in V7 (with auto-compression turned off). But it’s still a far cry from your 54 seconds to save a 382 Mb file, so something is strange there.

Tonight I open a prior file, it has one mesh. It takes 55 secs to save

File size when saved is 564Mb, there is not a lot to the project as yet. All extremely simple shapes, no fillets or fancy work at all. basic objects.
I do have row of cylinders (about 30) for cutting holes in a beam, cloned for the second beam, then the whole cloned for a second variant.

It has one mesh.
Open double precision polygon mesh: 162530 vertices, 299999 polygons
24,853,362 kb

I have a 462mb mesh in the problem above (start of thread) that saves at same time.
I am frightened to import and work on meshes !
Is this mesh struggle common to CAD or does Rhino struggle ?

I recall a poster somewhere saying Rhino working with meshes struggles. He uses a different CAD prog now.
I have to get this done then convert win7 pc to win10 pc usinf all new drives, and as such its holding me back, I feared meshes would be a problem, like wading through molasses . Like running down a corridor in a dream getting nowhere, end of corridor is my rhino 7 and win 10.


You could turn off compression during saving in v7. This is an advanced option (Tools > Options > Advanced). Type compression in the search bar, turn off the UseCompressionWhenSaving and try again timing your save time.

ps. on the flip side your files probably become bigger.

Well, all this posting about how bad meshes are supposed to be does not seem to be related to your slooowww saving problem. You have big(ish) files - that’s what meshes are, thousands of individual faces whose description takes up a certain amount of memory space - but that is normally not a real problem, with the file sizes you are describing, certainly not with a decent computer and a recent version of Rhino.

So maybe get back to us when you are finally on V7.

I have a file with a mesh, saves in 50 secs or so file size 581Mb
I delete mesh, save it, 50 secs.
close Rhino

Open rhino, open it takes a while, save it again. 50 secs still.

file size 557Mb

Its now just basic simple objects, and a few pics. yet its almost same size and takes 50 secs to save still.


i.e a normal file no mesh, and 557Mb, such is normally maybe 30Mb.

Impossible to work with.

How do I work with a non mesh file if it takes 50secs to save, yet another drawn with the same objects takes a second to save.

Its remembering it once had a mesh and wont let go of that fact, why almost the same file size ?

What is the solution as this should not be happening.


Hi Steve - please run Audit3dmFile on this file and post the results.

My guess of the moment is there is an embedded image, or block definitions.


I still think you have large bitmap textures stuck in the file. These don’t get deleted with the mesh. If you run Audit3dmFile on the file, you will probably see the large section is the materials table. If I recall correctly, in V5, there was a test command TestPurgeBitmapTable…

I run Audit3dmFile and it opens a file browser asking me to open something, but what ?

mention of materials, aha…thinks… I look in materials and the jpg for the obj is there, so i deleted both and save file, 60 secs and still 557Mb in fact just 14kb less !

I then delete the rows of cylinders which are my cutters for a row of holes, 5 rows of these.

and save file as 6b, and it takes 70 secs, and file size has GROWN, its now 785Mb.

So mesh gone, materials for it gone, repeated array solid objects for cutting row of holes gone, (cant use blockInstance cylinders as they are ghosts, they cant be used for booleans) and its gone 40% larger in file size.

HUGE at 3/4 Gb.
@Helvetosaur @pascal

I have some images I am working with using PictureFrame, do that hundreds of times last few years, they are never ever a problem, never make it slow a save takes a second or so.

If I run TestPurgeBitmapTable it will nuke everything , or is that for just jpg assoc with meshes ?

I have had to delete my meshes so as to try and work this file, I had just about finished drawing the item using the mesh, so nuke it to continue back in normal save speed, or so I hoped…not right to have to do so is that. It was only one mesh of an item 3ft long and a few inches tall. I just cant work with meshes in V5.



Hi Steve-

The 3dm file you want to audit.


I have opened the ‘offending’ file which is less its mesh, I run Audit3dmfile, I browse to the file I have open, rhino crashes.

I launch a new rhino, run the command, browse to the 3dm file in question, rhino crashes again.

Meanwhile I open the file less the meshes and also less the rows of cylinders, my hole cutters, and it takes ages , a black screen, its like wading through molasses, impossible to work with, its the one that after deleting mesh and deleting the rows of cylinders , saves as 785Mb when with them it was 557Mb.

A repeat pattern of anything involved in a boolean command, and Rhino just goes very slow, but one cannot boolean with BlockInstances, so one does need normal solid objects but Rhino wont let user work with such.

How do I continue as its extremely slow yet I have thrown a lot overboard !

Not much in the way of objects in it, not as if I was drawing a ship or aircraft. why is it HUGE as file size ?

This is Cruel !!!

I have selected all but the cutter cylinders, cylinder profiles, mesh, , export the items. basic geometry and some pictureFrame pics, takes forever,
eventually done. browse to the export and its EVEN BIGGER AGAIN, NOW 792MB,

Idea was to export simple stuff and carry on working with that.

not at this I can’t.

How do I get out of this ever increasing file size, and get a normal file again ?


Instead of having everybody guessing what might be the issue you could upload your file with Rhino - Upload to Support and have tech take a look at it to see what is going on.

I will do so, there are three files and associated meshes and photos,

  1. with mesh,
  2. mesh deleted,
  3. is 2 with cylinders deleted.

How do I take a rhino file and find all the associated pics and meshes for it, is there a way of getting the file to find them all , or do I have to look at all the paths and go find each one ?

I fall at first hurdle otherwise, it says source: from obj for the mesh in clicking on the mesh and choosing properties, but I need a name, ideally an address to it. or is it enough to send the .3dm file. I guess I will do that. Its embedded so no obj needed. photos though ere linked, am I right (PictureFrame).

I select photo and go properties and it says source: from obj… well thats not so, its a jpg from a camera, so rhino is wrong !!!


For now I wouldn’t worry yet about the image files.

Not sure what you mean with finding meshes for it - didn’t you already import them into Rhino?

Just upload the 3dm files you have, because to be honest I get very confused by what you write.

Its not going to be worth testing without images, IF images have a part to play, as mentioned in the notes with the upload, I have been working with MANY images in a file for years and never experienced this, exporting out objects and some images to leave behind any gremlins of this file and carry on working with a fresh file, sees file go HUGE, .
Difference with this file was adding a mesh, always makes it SLOOOOOOOW, then deleting mesh and the jpg from the obj didnt have much effect.
I have spent an hour or more finding all the images, thank god I put the image file name in the layer !

I had those images and the .3dm files in the same folder, different to my normal workflow, so they should all be seen.


upload taking 20 mins and still going, 1.6Gb zip seems very slow, resent and same again.

2nd time worked, in seconds . upload system a bit odd, maybe timed out whilst preparing files and notes


Looking at your file Export Bearers v5 less holes cutters and less mesh.3dm it has a couple of objects that account for 115MB each. The objects are pretty small in unit size, but have extraordinarily high polygon count:

3+ million quads is way more than needed.

Command: PolygonCount
There are 3,130,361 quadrilateral polygons and 34,844 triangular polygons in this selection
There would be 6,295,566 total triangular polygons in this selection after forced triangulation

custom render mesh settings like below help cut down quite a bit and still have a reasonable nut

The new settings give

Command: PolygonCount
There are 2,740 quadrilateral polygons and 500 triangular polygons in this selection
There would be 5,980 total triangular polygons in this selection after forced triangulation

The objects that are really huge and could do with better meshing settings:

    object[137]: 115794799 bytes, id = a38cec19-6fcf-4e14-8de1-42822b2f0788, name = ""
    object[142]: 115794918 bytes, id = efb13f9c-4acf-4ef7-a4db-81598a6c0e08, name = ""
    object[143]: 115795244 bytes, id = 68a7947b-c094-4f5c-b7e1-74efb2998269, name = ""
    object[148]: 115794601 bytes, id = 58a616a1-7e12-47a7-b271-fbca05486696, name = ""
    object[170]: 116686925 bytes, id = f82be9e8-9dbe-4fc2-9c7c-5f44870daa4b, name = ""
    object[177]: 117037805 bytes, id = f0c11737-5164-4c59-b7a4-492c3dc9eb2b, name = ""

Use SelId to get to each object, then play with mesh settings until reasonable.

You’ll notice that many of the huge objects are actually the same, so here block instances would make very good sense.

Note that objects 170 and 177 are pretty much the same, you probably didn’t intend 177 to stay, since it misses the inset for the nut, which 170 does have.

Using sane settings for the objects that are over 110 MB makes everything much smoother: saving, loading and using is much faster.

Also, you have many duplicates. SelDup and removing the duplicates saves another 21MB.

1 Like