Rhino 7 being incredibly slow at saving, even small files like 65mb

Experiencing extremely slow save times, from small files from 50mb to larger ones 350mb and such.

Seems to ONLY be a saving issue, everything else is perfectly snappy and fast. Just built a PC with a 3090 and a 5950x so it’s definitely not a hardware issue. Using octane but that shouldn’t be an issue.

Also seems to only be when there are meshes in the file. I am using some hi-res sunglasses for product display, but the glasses themselves are not that crazy large in size (i.e. have a stack of 10 of them on shelves, but even then the file size is only 65mb)

Anyone else have this issue?


Are you saving the files on a local HDD or SSD, or on a network or remote cloud storage location?

Thanks for the quick response!

Saving to a Samsung 970 evo plus local m2 nvme SSD, Rhino is installed on a 980 pro OS drive

That should be fine. Is the SSD getting full?
Do you have file compression turned on?

Do you have any plug-ins installed?

Please run the Rhino SystemInfo command and post the result.
It will give us a good overview of the resources Rhino sees.

1 Like

Nah, brand new system. 2TB on this ssd and extremely empty. 500gb OS ssd, also empty minus the usual stuff. All SSD speed tests are top shelf, just seems to hang on rhino saving! I’ve enabled admin privileges on R7.exe

No file compression enabled, only plugin is Octane for Rhino

It really only seems to be with meshes. NURBS are fine, ¯_(ツ)_/¯

Thanks again!

Here’s the sysinfo:

Rhino 7 SR2 2021-1-21 (Rhino 7, 7.2.21021.07001, Git hash:master @ 96ff97351fbdf5d2acdeaf781aea1577f2ff60f7)
License type: Evaluation, build 2021-01-21
License details: Cloud Zoo
Expires on: 2021-05-01

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3090 (NVidia) Memory: 24GB, Driver date: 1-22-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.40
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-22-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 24 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\OctaneRenderForRhino (f109bd23-4cf3-4c0b-9f83-06be474b0152)\2020.1.5.123\RHI Installer 6\Rhino 6.0\x64\OctaneRenderForRhino.rhp “OctaneRenderForRhino” 2020.1.5.123

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Maybe my memory is faulty here, but I seem to recall other reports of slow saving when the file contains meshes?

Perhaps SaveSmall to strip out the render meshes would be helpful.

I’d also try disabling Octane just to see.

I’ve been doing some performance profiling on file saving lately. If you have a file you can share with me, I’ll see if I can figure out why it is taking a long time to save (and maybe fix it in Rhino if we’re lucky.)

gotcha, still hangs for a bit. This really might be the meshes I’m using. File size is pretty small but geo is pretty dense, Tried saving small but didn’t help too much. It’s really not THAT slow, about 10 seconds…

Sure! I can send you a few different file sizes to analyze, I just mentioned above it may just be the meshes I am using. Doesn’t seem to be an issue with other meshes…

Should I just PM you a link?

A PM would work for me. Thanks

“Do you have file compression turned on?”

Yes! This was it. I thought you meant in windows.

Much faster saving now, at the expense of a larger filesize (meh, whatever. 'bout double fyi). Thank you and Steve for the help!

If anyone else in the Rhino Community makes it here based on my topic title, It was the specific meshes I was using, not a Rhino 7 thing. For anyone else wondering how to turn file compression off:

"If you open the options dialog in Rhino and go to “Advanced” options, look for the setting
Rhino.Options.Advanced.UseCompressionWhenSaving" and turn to false.


Just had this one hit me by surprise… Was just testing something, had an admittedly large mesh - about 13m polys - save file size was around 750Mb - forgot to turn compression off, took around 10 minutes to save the file. Tested again after having turned it off, took 3… There is a noticeable file size difference though, without compression the file is about 1.25Gb.

lol. ya, definitely ups the file size but it’s so much faster! went from 250mb to about 800mb but takes me just a few seconds to save now. I have no issue filling up my brand new ssd’s, they were feeling a bit empty hahah.

I have a work around when I am experiencing a slow down when saving / autosaving.
I would turn off the wifi / internet connection and that would solve this issue. It’s a temporary fix but always seems to work…

Strange fix but cool!

Turning off file compression worked as a permanent solution for me but I’ll give that a go next time, thanks!

1 Like

I am running into this issue now. I have a file that is nothing but Make-2D drawing lines, it is 127MB, and it has been saving for over 20 minutes. This is a brand new SSD.

That’s not normal, sounds like Rhino has actually crashed… what does task manager tell you?

It finished after 50 minutes, but something DEFINITELY went wrong. The file is 35 GIGABYTES.

It appears to be an issue with my source file, or possibly the complexity of the model. If I grab a different smaller model, it saves just fine, but this one just keeps saving and saving and I have NO IDEA what the hell is in that 35GB file. I tried generating just one of the 2D drawings from my source file and tried to “export selected”. It hung for 10 mins before I killed the process, and the export file was over 10GB.