Rhino Script Compiler V7 issue

I tried to follow this old video explaining how to run the Rhino Script Compiler now embeded in Rhino 7:

It seem’s that the script face some problem with the yak syntax, I did’nt figure out what was the problem with my yak files in temp directory.

I tried several times with different plugin names, command types…

A capture of my issue :

Any idea to solve this issue ? (Maybe @stevebaer)
Any ways to activate the DebugInformation ?
I did’t try to compile it myself yet, any tutorials to do that ?

1 Like

Please make sure to update to the latest service release of Rhino 7. This is a bug that was fixed.

I have the latest release :

Rhino 7 SR4 2021-3-19 (Rhino 7, 7.4.21078.01001, Git hash:master @ a432d22ab7f0f7b53d157d578278070c8bf6eff4)
License type: Commercial, version 2021-03-19
License details: LAN Zoo Network Node

Windows 10.0.18363 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1
Primary OpenGL: NVIDIA Quadro P620 (NVidia) Memory: 4GB, Driver date: 12-11-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 460.89
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-11-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I tried with Rhino WIP and Rhino 7.
I tried with a new project, 1 command for both Rhino Python Script and Grasshopper.

I’m sorry; this error message is different than what I have seen before. Can you send me your script compiler project? I would like to try and repeat the bug on my computer.

I tried creating new projects, they all face the same problem each time, as an example I can give you this project.
RhinoScriptCompilerProject.zip (1.6 KB)

It certainly due to my installation, or plugins maybe…

I tried with Rhino 5 Script Compiler compiling with Rhino 6 & Rhino 7 SDK (RhinoCommon.dll), and it is working.
Rhino5SCProject.zip (44.2 KB)

But I can compile command from grasshopper… And I need it.

I tried with another computer, I have the exact same problem. Maybe I didn’t configure well the options.
Does anybody have the same issue ?
Are they any other documentation to use this compiler ?

(the last release didn’t solve the issue)

Thank you

I am seeing a yak compilation error as well. @will can you give this a try and see if you get an error with the above project? I see a quick flash of a yak error when running a release build of Rhino (my debug build works just fine).

Gaspard, do you get an rhp in your bin directory or no files at all?

No luck reproducing it here. @gaspard.bourgeois can you try repairing the Rhino installation just to rule that out?

I completely uninstalled Rhino and deleted the folder Grasshopper and McNeel in %appdata% as well.

After reinstallation I’ve the exact same problem. And nothing in my bin folder.

I have this issue on two differents computers.

For SEO purpose, I paste the output here.

Rhinoceros Script Compiler
Visit discourse.mcneel.com for answers to your questions.

Compiling RHP Plugin

1. Generating source for RHP plugin...
   Creating project directory:
   Writing source code files:

2. Setting compiler parameters...
   Output path set
   Embedding resources
   .NET Framework referenced (system.dll)
   Microsoft Core Library referenced (mscorlib.dll)

   WarningLevel:         3
   GenerateInMemory:     False
   GenerateExecutable:   False
   DebugInformation:     False
   CompilerOptions:      /target:library /optimize

3. Compiling plugin assembly from source files...
     Compilation successfully completed at mardi 6 avril 2021, 12:29:47

Building yak distributionThe compiler generated the following errors:
 Message:Le format de la chaîne d'entrée est incorrect.
Press any key to continue

Did you a find a solution to this yak error ?

Can you explain how did you manage to run a debug build from the compiler ?

I’m able to generate the source file, but I don’t have any experience compiling C# files, is it free to do it with Visual Code ? Any advice ?

This seems like a text formatting bug when attempting to create a yak package,

When you ran the compiler and got an error, did you get an rhp file in your output directory? If you got an rhp, we can try walking through the process of manually creating a yak package

No I don’t have any RHP file. I am stuck to create a plugin.

J’ai exactement le même problème

Hello @stevebaer and @will,

I didn’t see any changes about it in your last updates, do you have any idea how we could help you to solve this issue ? Maybe we can manage a teamviewer or teams ?


Very good news here !
I still have the yak building issue. The output directory that I specify is used to generate the source files and not to build it. I indeed get the RHP file in the called “project directory” (created in my temp folder) and I can load it perfectly.
It solves a part of my problem.

If you want to have a look at my project directory created with the last version of Rhino 7, I attach it.

43ac10a9-53ae-443f-b5ba-f7111388a2b3.zip (3.4 MB)

I believe this is related to running on a non-English version of Windows and I am still trying to pin down the exact location where the bug exists. In the directory where the rhp is created, do you see any other files or subdirectories?

I don’t see any other file than the one in the zipped folder up there in my previous post.

Good news; I was able to repeat this issue by switching the script compiler to run under a French culture. If you need help creating a yak package of your rhp in the mean time you should be able to do this manually using the yak instructions at

I have logged the bug at