Rhino Script Compiler for Rhino5, second Beta

Hi Everyone,
Here’s a new version of the RhinoScript compiler for Rhino 5
http://www.rhino3d.com/download/rhino/5.0/rhinoscriptcompiler/

NOTE: This application requires .NET 4.5 to be installed on your computer.

This version improves support for packaging plug-ins as RHI files and other fixes related to python plug-ins. Give it a try and let us know what you would like to see improved.

Thanks,
-Steve

5 Likes

Great news Steve. Thanks. I’ll try it out soon.

Nice one Steve.
This should be an independent application, not “connected” with Rhino 5? Meaning I should run it, no matter what version of Rhino 5 I have (I am still using SR5).
Tried to run it, and got this message:

RhinoScriptCompiler.exe is not a valid Win32 application.

I am using 32 bit Windows XP SP3. Is that the problem?

Oh, I’m sorry I forgot to mention that this exe requires .NET 4.5 installed on your computer.

http://www.microsoft.com/en-us/download/details.aspx?id=30653

hello Steave
I get this error in the compilation
I have to install NETFramework 4.5?
win 7 64 bit
Ciao Riccardo

Hi Riccardo,
It is hard to tell from that error. Did you install .NET 4.5?

Is it possible to include encryption similar to Dale’s video: http://vimeo.com/41879788 - Perhaps one encryption for all the scripts in a plugin.

Also, can someone give the address of the web page that is shown in this video.

thx
Keith

Hi Steve,

I’ve first tried it without the .Net 4.5 just for testing and got the same error like Riccardo. After install of that update it works like expected. My Python Scripts now also work correct (without evoking EditPythonScript first).

Thanks for the update!
Jess

David already added encryption by default

Another future goal is to generate a full C# project so you can edit and adjust whatever you want.

1 Like

Thanks.
I have just realized .NET 4.5 does not support my Windows XP SP3. It requires Vista to newer ones.

Can you install .NET 4? The RHI building requires .NET 4.5 due to the zip file support in .NET 4.5, but I may be able to drop that feature for people running on XP.

As a side note, we are currently targeting Windows 7 as the minimum OS for Rhino 6.

Yes, I already have the .NET 4 installed.
Ah, did not know that about Rhino 6. Looks like an end might come to my current PC.

I’ll have to see how much effort is involved in making this run on XP. There is no way I’m going to be able to get to this for a few days at least.

No pressure Steve.
Take your time.

Hi Steve
Thanks , the compiler works like a charm
Ciao Vittorio

Hi Steve

Will we be getting the means to create a menu structure like the old Rhino 4 Monkey compiler ?

Roger

1 Like

Hello Steave
there was no net framework4.5
is installed everything works out
thanks

Does this support multi-python file to single package yet?

You should be able to have multiple python files in a single compiled project.

I don’t think we have the ability yet to have python scripts “import” from neighboring modules in the same package yet. Is that what you are trying to do?

I believe there was a first beta of the python script compiler that could handle the input from a single python file.

I would like to compile a python script that is split up into several python files and compile it to one project.