Rhino Script Compiler - Yak Version Error

Hi @stevebaer,

I ran into an issue when using the Rhino Script Compiler where making an updated version of my plug-in resulted in incorrect naming of the .yak file automatically generated at build. After I manually renamed the .yak file, the new version of the plug-in was able to be installed via the package manager.

I’m working off a private yak server as was outlined here:

I created an RHP using the Rhino Script Compiler and was able to see and install it via the package manager. This was version 0.1.0

I then did some changes the existing project and built a new version 0.1.1

This new version was not visible in the package manager. When I viewed the .yak file the RSC generated, I noticed the naming looked off compared to version 0.1.0

After renaming the .yak, the new version of the plug-in appeared in the package manager:

Did I do something wrong when editing the existing project or is there a bug in the naming of yak files?

Looks like it might the minimum Rhino version that is increasing by a power of ten whenever I run the Rhino Script Compiler

1 Like