Rhino 6: Zoom with mouse wheel not working

Hi…,

one of my Rhino 6 customers has problems with the mouse wheel zoom in Rhino 6. It seams not to work. The zoom factor is set to 0.9. The zoom works correctly in Rhino 5.

Any ideas?

Thanks

Michael
www.flexiCAD.com

Hi @pascal,

this is my second customer, where the mouse wheel zoom doesn’t work at all.

It is a Logitech-mouse with usb-connection, and here the Rhino 6 system information:
system_information.txt (1.4 KB)

Any ideas?

Thank you

Michael

Hi Michael… no ideas yet, I’ll have to ask the bigger brains…

-Pascal

Hi @pascal,

any news from the bigger boys. :wink: My customer can’t still scroll.

Thanks

Michael

Same problem on one of our cad station. Problem only in graphical viewport.
No answer from McNeel ?

@marc.lairet, @Michael_Meyer - all that comes to mind is a Windows setting which I will do my best to dig up - does it work to click in the viewport first, then scroll the mousewheel?

There is this:


But that should be fixed long ago as far as Rhino is concerned.

"apparently the behavior on Windows 10 can be turned off. On Windows 10, left click at bottom left corner, go to Settings->Devices->Mouse & touchpad, and turn off “Scroll inactive windows when I hover over them”.

-Pascal

We are on W7 but we Will try this stuff… It doesn’t work when we click in the viewport first and then scroll the mousewheel…
V5 and V6 have the same problem on this cad station but Solidworks and all other softwares works well.

OK…that does seem more like a Rhino thing- and, just to make sure, have you tried swapping mouses with a workstation where it all works as expected?

-Pascal

Sorry for delay…
Problem is not solved and yes we tried to swap différents mouse from Dell/Logitech…

Problem solved…
Due to net user session.
Why It only affect rhino ? I don’t know but It work with another user…

Hi @pascal,

my customer asked me yesterday if this problem is solved, he still can’t zoom with the mouse wheel in Rhino 6.

What do the bigger brains say? :wink:

Thanks

Michael

I’m having the same issue. I use an old really simple dell mouse - I’ve found it better for navigating Rhino. Just recently, Rhino won’t let me zoom in. I have no issues using this mouse normally with any other programs. Would love any guidance as this is super limiting for use of Rhino.

Thank you!
MS

Hi,
I have the same problem
I use Windows 7 pro.
The mouse works well in Rhino 5.
In Rhino 6 the wheel doesn’t work (but into Grasshopper it works !!).
I try a logitech and an HP mouse with the same result.
Thanks, Fabio

Hi @fabio, @mspring - can you run SystemInfo in Rhino and post the results here? Have you tried updating mouse drivers? I’m not saying you should need to, but it might be worth a try.

-Pascal

Rhino 6 SR9 2018-9-28 (Rhino 6, 6.9.18271.20591, Git hash:master @ 4cf7435f08f51c972347c8558d28355cfc0471ca)
Licence type: Licenza Lab Not For Resale, build 2018-09-28
License details: Cloud Zoo. In use by: fabio ()

Windows 7 SP1 (Physical RAM: 32Gb)
Machine name: PC-I7-3930K

GeForce GTX 970/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 359.21)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 12-16-2015
Driver Version: 10.18.13.5921
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

C:\Users\Fabio\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\LayoutManager (23664189-f095-4e9c-8f6d-1073c2c60efc)\0.2.6.0\LayoutManager.rhp “LayoutManager” 0.2.6.0
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2017.11.15.520\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2017.10.16.484\SectionTools.rhp “SectionTools”

You may want to update your driver, it is very old.

If that doesn’t help, try starting Rhino in its safe mode. Let us know how that works.

Hi Nathan,
I download and install SetPoit 6.69.114_64
new%20driver

but the zoom doesn’t work too.
And the system info give the same date:
driver Date: 12-16-2015
Driver Version: 10.18.13.5921

system_information 02.txt (2.0 KB)

Another strange behaviour is due to the right click on a panel menù:
In rhino 5 works well:

In rhino 6 I obtain a big empty grey sheet…

BTW, I’m using two monitor.

Thanks again,
Fabio

@fabio, I meant the driver for your GTX 970.

Also make sure all updates to Windows 7 have been installed.

Have you also tried the Rhino Safe Mode?

Sorry,
I try Rhino safe mode, but the wheel doesn’t work.

About Geforce:

GeForce%20message

I have this message from Nvidia.
I forced the update:

GeForce%20message%202

and the result is this:

No new driver.

It is possible, but why with Rhino 5 works, with 3ds Max 2018 works and with Rhino 6 not ?

I try on my Sony Vaio
and the zoom works, but the strange right click behaviour remain.
system info Vaio.txt (2.1 KB)

I hope it could help
Thanks , Fabio

You can download a driver directly from Nvidia web site. This is the one you want:

https://www.nvidia.co.uk/Download/driverResults.aspx/138350/en-uk

The GeForce Experience software is known to cause problems, so best to uninstall that (unless you really need it).