Viewport doesn't gain focus by zooming

Here (V5, V6, no V4 to test) moving the mouse cursor over another viewport without clicking does not activate it - but, as soon as I roll the mousewheel, it does activate it, so it zooms in the viewport the mouse cursor is currently in.

–Mitch

Nay! http://screencast.com/t/pW5m7niUqT Y’all do not see this?

What up with this discrepancy? V4 does the same thing here.

-Pascal

Nope - this is what I see… Note I did not click in any of the viewports, just rolled the mousewheel.

Mine works like Mitch’s, not Pascals.
Rh5R12, 32bit, normal wheel mouse.

Hmm- I have tried a couple of mices and they both do the same thing. Light touch I guess. Let me see what I can find out- thanks for the feedback, all…

Can you try Rhino in Safe Mode and see if that behavior changes? Thanks.

-Pascal

In Options > View; Pan section, is the option checked for "Auto adjust camera target after Pan and Zoom?

Yes.

In mine, it is set to ‘autoadjust camera after pan & zoom’

but unchecking that box makes no difference.

Mine works like Mitch’s too, including V4.
Mouse over does not change to that viewport unless a command is running.
Moving the mouse wheel instantly changes focus to the viewport the pointer is over without clicking.

The ONLY exception to this a a floating viewport.
The new floater can be current and I can wheel zoom another viewport without it changing focus.

Scott’s works the right way. I mean, like mine…

-Pascal

I just recently updated to Win10, is that a factor?

Seems to me if I DO something in a window (including zooming), that window should get focus?

Yeah, I honestly do not know what is the designed behavior - I could make a case for each. I’ll see what I can find out.

-Pascal

1 Like

Ok, back on my other computer and I’ll confirm this: the behavior is different on the SAME version of rhino on different versions of windows. On Win7, it works as I have always experienced it: zooming in a viewport puts the focus on that viewport. In Win10, it does not, which I find problematic. If I can kick in my own preference here, it would be as I always remembered it: zooming in a viewport gives that viewport focus. Thanks…

FYI: Installed Win10 on the other computer and the unliked behavior is now on that machine as well. Definitely a Win10 thing. And definitely drives me bonkers.

OK, thanks, I’ll see if we cannot get this working right for V6 at least.

http://mcneel.myjetbrains.com/youtrack/issue/RH-31571

-Pascal

1 Like

For anyone else who is going bonkers on this one and finds this thread, following the youtrack trail led me to the fix:

"apparently the behavior on Windows 10 can be turned off.

On Windows 10, left click at bottom left corner, go to Settings->Devices->Mouse & touchpad, and turn off “Scroll inactive windows when I hover over them”. Selection menu wheel scrolling should work like it used to."

Worked for me and restores at least some of my sanity, thanks guys.

1 Like

That’s true. The Windows 10 change effects Rhino V4, V5 and V6

THANK YOU THANK YOU THANK YOU MARK. This behavior has driven me crazy for a year. That solution works.