Scroll wheel has lost ability to Zoom

My Rhino 5 installation seems – suddenly – unable to Zoom in response to a roll of the scroll wheel on the mouse.

Apparently it is not a hardware issue. I tested the mouse on another program and it still scrolls. .

What happened? How can I restore this Zoom-on-scroll feature?

Thank you for your insights.


Options > View:
I suspect your Zoom Scale factor is set to 1.0
Try 0.9 or 0.95
A value larger than 1.0 (like 1.05 or 1.1) will reverse the zooming direction of the wheel.

Thank you for this idea, John. However, I checked and Zoom was already
set at 0.9.

That’s strange.
I’m not aware of any other setting in Rhino that can effect that in Rhino.

By chance are you in a perspective projection view and zoomed way in when this happens?
Does this happen in a parallel projection viewport?

Stranger and stranger. This morning, the Scroll Zoom works normally once
again. I tried it first on a file from some weeks ago (Scroll Zoom
worked immediately) then on a problematic file I saved yesterday.
Scroll Zoom worked again. Maybe opening the old file healed the code.

For several days I have been receiving promotional messages, inside
Rhino, for a particular pop-up. Might be the source of the problem.

If I lose scroll-Zoom again I will re-install Rhino 5.

Thank you for your help, John.


I’d also check the Windows Control Panel for your mouse settings. There, you can modify the buttons and wheel settings. My mouse lets me set the speed of the scroll wheel, so yours could have been modified accidentally / corrupted / etc.

And … maybe even update the mouse driver if needed. Some gamer mice (like mine) have driver updates occasionally.