Rhino 6 not starting up

Just recently my Rhino 6 stopped loading. It just gets hung up during startup.

  • Could possibly be due to Windows auto update. I have not tried making my system revert yet. Hoping not to have to do that.

  • It might have been b/c I tried to get Vray working again. So I uninstalled Vray to take that out of the equation. Still no luck.

  • Then…
    Loading RPC Plugin
    It looked like it was hanging up on “RPC” plugin. (Not something I personally installed, so I went into Safe mode - it started right up - and deselected it under plugins.

  • Back in regular mode it started hanging up on “creating viewports” - or some version of that phrase.

I have it working on my laptop (with Vray as well) but my desktop has crapped out.

Little help?



Rhino 6 SR21 2019-12-17 (Rhino 6, 6.21.19351.09141, Git hash:master @ 4d373f64ffb55e3a8d607d9618590728d86fb1e9)
License type: Commercial, build 2019-12-17
License details: Cloud Zoo. In use by: Alan Farkas ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-RO9R8FT

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2070 (NVidia) Memory: 8GB, Driver date: 10-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.12

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 10-24-2019
Driver Version:
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.21.19351.9141

Hi Alan - if you start in safe mode, disable Vray and then start normally, anything good happen?


Hi Pascal,

Vray is no longer installed in the system, and does not show up in the Plugins list anymore.

Is there any chance, Windows has updated and you’re in a reboot delay?

Windows had indeed updated. What’s a “reboot delay” and how do I know if I am/fix it?



Windows 10 by default downloads and installs updates. It then waits until your outside of “active hours” when the computer is left running to reboot.
In theory, it’s not a bad idea.
In practice, problems like this are far more common.

I have tweaked the settings in Check for Updates so I know when updates happen when restarts are needed, and I choose when to do the downloading, installing, and restarting.

These are my settings:

Another way is to look at your Windows shutdown options under the Start Button. Click the button and if a reboot is staged, instead of Sleep/Shutdown/Restart, it will say Sleep/Install updates and Shutdown/Install updates Restart.

No luck. Made sure Windows comp0letely updated. This is where I’m getting hung up.

Hi Alan -

This shows that your driver installation is messed up. A Windows update can cause that. Please try installing the drivers for your GPU again. If a normal installation doesn’t do it, you can try a clean uninstall-reinstall.

Thanks. Will try it.

And when you say clean uninstall-reinstall, you’re talking about the GPU driver? In case I need it, can you suggest a post that explains the best way to do that?



Hi Alan - I tend to point to this post:

… and stress to not to forget step 4 of the uninstalling part.

So, I did the system update.
I did the above suggestion for uninstall/reinstall/restart newest GPU (studio) Driver.
Still no good.

Now my system is saying theres ANOTHER UPDATE and the date is sort of weird, no?

Should I update to that “1968” thing, or should I try to “Rollback” my system? (I would have to use the built-in Windows abilities b/c I don’t have my system backed up right now)

UPDATE: Did the latest Windows Update (research said that the “1968” thing was ok) But not change starting up Rhino.

Should I reinstall Rhino? (FYI Rhino Safe Mode starts right up. Wouldn’t this mean that my problem is somewhere in my Rhino software or plugins?)

UPDATE AGAIN: Uninstalled and Re-Installed Rhino. Working now.

1 Like