Rhino 6 + GH - Text & Dimensions panel & Plug-in manager are missing

Dear developers,

We at our office have a serious problem in Rhino 6 where we can’t edit/create text and dimensions anymore after using our grasshopper script. In addition, the plug-in manager in properties has disappeared as well (see pictures below). Our script contains many C# scripts/plugins that communicate with Rhino 6 by either baking/deleting/editing text, geometry or blocks. I tried to reproduce the problem by singling out all the components and testing them thoroughly. The problem however occurred sporadically and happened with all laptops and computers using the script. I sadly can’t share this script. Which makes it also hard for anyone to narrow down the problem. :S I hope someone already solved the problem

I saw more people had problems with text editing. And saw that updating the NET framework could do the trick, which it sadly didn’t in my case. It’s however also impossible to fully uninstall NET framework on windows 10.

2 Likes

In addition, we work from a shared drive. The created scripts in visual studio are stored on this drive, but are also available offline. Not sure if this could be an issue…

Hoi Rolf - could you describe in details what happens when you try to create new text after you have used your Grasshopper script?

The Plug-in Manager is found in the Rhino Options page - from the picture, it appears that the Linear Dimension page is not showing in the Properties panel.
Could you run the Rhino SystemInfo command and post the result here?
-wim

Hey Wim,
Nothing happens when I type in the command ‘text’ after the problem occurred. The command ‘Dim’ still works though. Our script is also still able to bake text without showing any errors. The same behavior appears on all computers/laptops.

Here is system info ouput:
Rhino 6 SR16 2019-7-9 (Rhino 6, 6.16.19190.07001, Git hash:master @ a8b4ee102e9e0eb1d11825df063e13f96d518f93)
License type: Commercial, build 2019-07-09
License details: Cloud Zoo. In use by: rolf (SH - R&D)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: LAPTOP-ROLF

Hybrid graphics system.
Primary display: Intel® HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 10-29-2018 (M-D-Y).
Primary OpenGL: NVIDIA Quadro K1100M (NVidia) Memory: 2GB, Driver date: 3-17-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 419.67

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-17-2019
Driver Version: 25.21.14.1967
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.16.19190.7001

Thanks Rolf - nothing suspicious in that system information.

While you are having this problem, can you start a new Rhino instance and make new text there? If so, can you copy and paste it into the problematic session?

I’m just trying to gather information so that hopefully a developer possibly sees something amiss…

@JohnM - do you have any ideas about what could make the dimension panel go blank?
-wim

Yes, I copied text (that can still be edited) from a clean file to a file exhibiting the problem. The text has been copied correctly, I can however not edit it anymore after pasting it in the problematic file.
I’ve been trying to reproduce the problem a few times, but I believe the problem occurs randomly.

We have a few C# components that edit/add text. Do you think this could be the problem? I can discuss with my peers to see if we can share this.

Hi Rolf - yeah, if you can, send us the stuff that causes this, it, going to be hard to understand without it - to tech@mcneel.com, so as not to be public, but please include a link back to this thread.

-Pascal

It looks like the panels are not painting correctly, if you resize the dialog box do the panels appear?

Hey,
I discussed it with my colleague’s and we’re not able to share the script sadly. @JohnM rescaling either the text properties panel and plugin properties panel didn’t do anything sadly.

I isolated all the text C# components and tried to reproduce the problem without succes. So I don’t think this can be problem anymore. The last resort would be turning off every small script, every component one by one seeing if this will fix the problem, but we’re talking here about a very large script that we have been working on for 2 years now.

Possible problems I can think off are:

  • Grasshopper plugin crashing (would explain why we cant see the plugin manager): we’re using Human, Elefront, Clipper, excelreadwrite, Heteroptera, Lunchbox, Meshedit2000, metahopper and our own plugins created with visual studio which are mostly databases that allow complex geometry to be inserted, deleting of geometry, groups, text, baking of text, changing layers, creating of layouts.

  • We’re basically building a simplified version of revit, so if something changes in the design it immediately (read small delay) changes other elements that depend on it. So a lot of components work simultaneously and there also ‘baking’ simultaneously to rhino. Maybe there is a limit to this.

  • Maybe my .NET framework is still not correct. Not sure which version is stable and it seemed to have fixed multiple text problems for other people. See the following threads:

  • Text tool for Rhino 6 not working

  • Text command not working in V6

  • Resetting the Rhino settings also seemed to work once, but I can’t reproduce this anymore.

I just don’t know how I can systematically check where the problem lies, very annoying.
Hopefully you know some other test that I can do.
Everything is appreciated.

It’s been a while, but we think we have found the problem.
We created a shitload of keys + values in the document text function resulting in the overal text/dimension functionality to slow down. When selecting text it would literally take a few minutes to open the edit menu for text and dimensions.

We noticed adding document text values through Grasshopper with a the following command is quite slow.
Rhino.RhinoDoc.ActiveDoc.Strings.SetString(key,value);

Hoping this will improve in Rhino 7!