Rhino 6 freezes from start

Hey all,

unfortunately, I am currently faced with Rhino 6 freezing right from the start.
I already tried several advices with regard to updating the driver from my hybrid graphics system but no chance…

I would love to get some advice how to fix this and continue working with Rhino.
Thank you! :slight_smile:

My System Information:
Rhino 6 SR16 2019-7-9 (Rhino 6, 6.16.19190.07001, Git hash:master @ a8b4ee102e9e0eb1d11825df063e13f96d518f93)
License type: Educational, build 2019-07-09
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: MSI

Hybrid graphics system.
Primary display: DisplayLink USB Device (Unknown) Memory: 0MB, Driver date: 7-2-2019 (M-D-Y).
Primary OpenGL: NVIDIA GeForce RTX 2080 with Max-Q Design (NVidia) Memory: 8GB, Driver date: 5-26-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 430.91

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 5-28-2019 (M-D-Y).
DisplayLink USB Device (Unknown) Memory: 0MB, Driver date: 7-2-2019 (M-D-Y).

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 5-28-2019
Driver Version:
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.16.19190.7001

Hi Dominique - the problem is almost certainly with the DisplayLink USB - I’ll see what I can find out about that.

@Dominique_Lehmon - it may help for now to set your primary display as the laptop and not the DisplayLink.

If that does not get you running please follow the steps below to create, and send, a dump file that our developers can analyze:

There are times where Rhino may become unresponsive and appear frozen and there doesn’t seem to
be anything that can be done to bring it back. Rhino has possibly crashed, but has not fully gone down
and is just sitting there on your screen. In these cases, it is possible to manually create a “dump” file of
the running Rhino that can then be used by developers to hopefully see where Rhino is stuck and why it
appears to be frozen. The following steps outline the process for manually creating such a dump file.

  1. Once you realize that Rhino is in an unresponsive state, start the Task Manager by right-clicking
    on the Task Bar and select “Task Manager” in the popup menu that appears (see pic)…


  1. Looking at the Task Manager window, make sure the “Processes” tab is selected and locate the
    “Rhino 6” process., Right click on the “Rhino 6” process and select “Create dump file” in the
    popup menu that appears (see pic).


  1. Windows will start creating a “dump” file in your temporary folder on your system…


  1. Once Windows has finished creating the dump file, you will be shown the name and location of
    the file… You can select the name for copy and paste purposes…but the important part is that
    you locate the file on your system and then post it so that we can look at it (see pic).


Hello Pascal,

thank you for your help and instructions.
I created the .dmp file but was not able to upload it here. How can I transfer it over to you?

As for your advice to change the primary display:
You were right - it worked. But there is something strange. I am working with two 4k AOC Monitors and opening rhino on one of those two does not lead rhino to freeze. Only when I open Rhino on the wrong monitor it tends to freeze. As I prefer to keep rhino on one monitor and run grasshopper on the other one, this problem always brings trouble…


Hi Dominique - please Zip the dump file and post it here or send to tech@mcneel.com to my attention, and with a link to this thread on Discourse. If the file is very large, please zip and upload to


Hey Pascal, i just uploaded my .dmp file to the rhino.com page. Let me know if you need further information.


Hi Dominique - we got the dump file - thanks.

@Dominique_Lehmon - the developer reports that there is a file on your system, NahimicOSD.dll, which is likely the cause of your problems. This is a kind of On Screen Display service installed by an audio driver. This dll is buggy and has a bad record, out in the world, for causing problems such as you have encountered. There is a thread on Discourse about this - the relevant post is this one:

You’ll need to completely uninstall and remove this file.

Let us know how you get on…


Thank you for your effort Pascal!
I followed the instructions from this discussion and in worked!
Simply had to find “Nahimic Service” in the Task Manager (- Services) and disabled it. Afterwards Rhino started without any problem.
So I completely deleted the NahimicServices.exe and finally got rid of my problem :slight_smile:

Thank you !!

Great. Thanks for letting us know. (I’m just the messenger, that was @jeff 's work, figuring it out.)