Rhino 6 not working

(Suhas Vasudeva) #1

Hi,

I am currently using the Rhino 6 evaluation mode with 72 days still left on my trail and since the last few days, I have been unable to open Rhino.
Seems to work in safe mode and have checked to update all my drivers as well. Even after updating all the drivers, Rhino seems to freeze after the first screen.

The system info in safe mode:
Rhino 6 SR14 2019-4-28 (Rhino 6, 6.14.19118.15561, Git hash:master @ 8f0a84997c310a7ec1a42cf2704da8daa33e3e21)
License type: Evaluation, build 2019-04-28
License details: Stand-Alone
Expires on: 2019-07-26

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: MSI

Hybrid graphics system.
Primary display: Intel® UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 8-27-2018 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 1050 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 5-5-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 430.64

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 5-5-2019
Driver Version: 26.21.14.3064
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.14.19118.15561

Can you please help me figure out what might be the issue?

Thanks,
Suhas

#2

Hi Suhas,

Yes, I had the same problem recently. Rhino will start in safe mode but won’t load plugins
In my case I tracked it down to the latest nVidia driver, which seems to be the same one you are using (430.64).

I went back to 397.64 and all worked again.

HTH Steve

1 Like
(Suhas Vasudeva) #3

Thanks for that Steve,
Worked like a charm :slight_smile:

-Suhas

#4

@stevebaer @jeff Thought this worthy of your attention. Are you already aware?

(Jeff Lasor) #5

This sounds like the whole Intel-Hybrid driver collision problem…just a slightly different flavor.

IMO, whenever you have a laptop that comes bundled with OEM software and hybrid graphics…the first thing you should do is completely wipe the system of all video drivers (Laptop OEMs will probably cringe at that, but most of them don’t really know what they’re doing when it comes to driver installations and configurations, and all they really care about is whether or not the software they bundle on their laptops works)…

There are threads in this forum about how to do this so I’m not going to duplicate it again here…but, it’s more than just using the “Uninstall Program” feature in Windows, and certainly more involved than just updating a driver. Neither of those delete the current configuration, and once the configuration is bad, it remains bad across driver updates. You must completely delete all drivers off your system entirely, and then re-install them manually.

Lastly, hybrid graphics is a great concept on paper, but falls way short of its intended purpose…It has caused more pain and trouble than it’s worth on several levels (not just 3D graphics applications)…and whenever I have a laptop that has both Intel and NVidia GPUs, I completely disable the Intel GPU altogether, after having completely deleted and wiped the drivers off of the system. The Intel GPU is pointless and does not save you battery life. The biggest, most effective battery saver on ANY laptop is the LCD Brightness setting… the LCD is a major power-suck, and will drain your battery in just a couple hours just sitting at idle. By setting the brightness to 50%, you can usually almost double your battery life between charges…which is far more than some auto-switching GPU logic garbage is going to do for you… Note: This is purely my opinion based on experience…other opinions may vary…so do what you will.

Thanks,
-Jeff

1 Like
#6

Hi Jeff. In my case the issue was on a desktop with no Intel graphics card in the machine. This definitely warrants further investigation. Steve

(Jeff Lasor) #7

Hey @Steve_Howden, I’m not sure what you want me to investigate exactly?

I always keep my system(s) updated with the latest drivers, and I have not had any issues yet with 430.64. Rhino loads and starts up just fine with the latest drivers…but there are a lot of things that can vary between configurations, so I realize that just because something works for some doesn’t mean it works for others.

Loading plugins and GPU driver versions really have nothing to do with one another…so I’m guessing that it just seemed like that’s where things were going bad for you, but in reality, things are probably going bad somewhere down inside the graphics initialization sub-system.

So given that… if you really want me to try looking into something, then here’s what I’d like…

  1. See if you can repeat the problem… Go back and re-install 430.64 drivers (and make sure you do a clean install)… I would also force a reboot after the installation, even if the NVidia installer doesn’t think you need to… If the problem occurs again, then I’d say it’s repeatable…
  2. If this is repeatable, then I’ll need all information about your configuration and GPU model, including OS (and all updates)…as well as which version (SR) of Rhino you’re using.
  3. Once repeated, we need to dig into what’s really happening and try to isolate where Rhino is experiencing problems. If Rhino is locking up, then the easiest way would probably be to force a dump of the Rhino.exe process, and then send it to me to analyze (I can explain how do that later). But if it’s something else, then I need a clear description of the problem and what you’re seeing…all I know so far is that you apparently experienced some kind of issue during the plugin loading phase.

So when you have the time, I would try to repeat the problem…and then post back here with your findings…If Rhino is locking up, then follow the instructions in the attached PDF…but if it’s something other than a lockup, please provide the details.

Thanks,
-Jeff

Creating a dump file for Rhino.pdf (761.0 KB)

#8

Hi Jeff, will do as you ask later today when I have time. Just so you know, I had this problem earlier and ended up doing a complete bare metal reinstall of win7 pro 64bit (my, that was fun) and the problem was the same. I’ll get further info to you when I can.
Steve

#9

Hi Jeff,

Ok, you can relax.

Interesting. Yesterday Windows did a big update of the .NET framework (KB4499406).

Now the nVidia driver 430.64 works fine, whereas two days earlier Rhino locked up consistently with that driver.

I have no idea what all that is about, but since it works, I’m not going to question it :wink:

thanks for looking at this anyway, Steve

(Jeff Lasor) #10

Awesome!

Thanks for looking into this and getting back to me. :+1:

-Jeff