Requesting Sketchup Shadows in Rhino

TL;DR - Rhino is so much better then Sketchup but Sketchup’s basic display is so much nice for presenting a model, why?

I work on architecture, furniture and product design projects and have been using Rhino since 2008. I am often presenting to clients using the live model, not renders. We talk about stuff, I show lots of options and move around the models. Almost every non-designer I know fully understands an object if you show them a live 3D model that we can move around. It is incredibly powerful. Often showing them just a still image does not get the whole idea across and leaves a lot of room for misinterpretation.

I usually use a customized version of Rhino’s Shaded View to work in and present from, using ObjectDisplayMode to turn some objects Ghosted or Transparent (glass for instance). I leave shadows off because they work horribly and only confuse the viewer. I don’t quite understand it.

Many people have asked for a Display Mode that replicates the look of Sketchup but the only responses are suggestions for tweaks to the current display modes tha,t don’t get close to providing a solution, or to use an output renderer like VRay, which doesn’t help in real time presentations.

I want to be clear, that Rhino is my favorite program of all time. I use a lot of visual programs, a healthy portion of Adobe’s products, Revit, Vectorworks, and Autocad. They all have there place but I’d rather open up Rhino then all of them. Literally my only gripe that I have had for a long time is the realtime display disparity between Rhino and Sketchup.

Is there a reason this is not being addressed or can’t be done? Is it a pride thing of not copying Sketchup. That is the one that makes the most sense to me as the Rhino Dev team has done amazing things with Rhino, for which I am thankful!

P.S. Here is an example why I don’t turn on shadows, as they just confuse clients (and rendered mode is no better):

Bumping this just incase anyone has a sweet display setup they can recommend that gets me closer

I agree with your sentiment, it would be great if Rhino could implement a lightweight, fast vector sun shadow in the display port.

My workaround, which is not as good, has been to dig into the display options and use the below script to change how much memory Rhino (6) uses for rendering shadows. This works best on good hardware. Have a play with the slider settings under shadow, and make sure the scene lighting is set to ‘sun’ - that should improve things a little anyway.

This area got better in Rhino 7. The shadows are still not vector and I doubt this would be coming anytime soon, but in Rhino 7 the shadow quality / memory size allowed has been significantly increased to catch up with modern day hardware, therefore we can get much more precise and sharper shadowmaps. Additionally the speed has been improved for models with both sun and skylight shadows which makes is a very viable alternative or even far better display quality than Sketchup, if used right.

On your screenshots it looks like either you have low shadow quality setting in your display mode or your scene is very large (objects far apart) and you are looking into one piece of it. Rhino shadow display quality depends on the size of the entire scene, so there are a few things to look for…

If you can, share the file and/or display mode you have issues with so we can take a look and give you some advice how to improve it.

–jarek

Thanks Patt. I was thinking of making the move to R7 soon and Jarek responded below about R7 solving the problem you created the work around for. Gonna try that out now and then come back to you script to look at any other settigns that can improve the real time display.

Thank you Jarek. Let me try this in R7 and see where I can get it and then ask question from there, which will include the model and computer info.

To be clear that was the only model in that file and I did turn the shadow quality down because it gave a harder edge, but didn’t changed the crazy wired underlighting thing happening. I know light bounces, but not that hard!

Sounds good, the underlighting things looks odd; getting the file and display mode you use would definitely help. You can also play with the other shadow settings (below) and set them very low- they usually help with having good sharp edge shadow if the shadow quality slider is at max:
image

1 Like