Shadows display

The shadows are too pixelated or too smooth, I can’t have a clean display is very problematic as our CEO does not understand that the shadows are not displayed as well as in Sketchup so we need to transfer files on Sketchup every time we must submit sketches and it cost us a lot of time. Is there a way to get better shadows in Rhino without have to do a rendering.

1 Like

I think you’re asking about the skylight shadows in Rendered display… unfortunately these are not adjustable in any way. You can however use a few spot lights and then adjust their shadow intensity in object properties. Here’s an example of what I mean.

Thank you

But I speak about the shadows you can setup in the Rhino Options windows , that produce the projected shadows you can see on the images below.

Sometimes the shadows are opaque sometimes transparent, they are often not correctly attached to the objets that produce them , produce strange dark artefact on shadowy faces.


to get shadows in rhino which most closely resemble sketchup shadows, use these settings:

you might want to give it just the slightest amount of edge blurring (the minimal amount which will cause a visible change… not even a full step on the slider scale… just to lessen the jaggies that will appear at the shadow edges )

that said, it’s still possible you won’t get identical shadows as sketchup… they’re being created using different methods… i believe rhino is using openGL while sketchup is using something else… the both have advantages and disadvantages… with rhino, you can get soft shadows and control them better whereas with sketchup, you get one flavor-> hard/sharp edges only.

1 Like

I’d like to bump this thread. There seems to be an inconsistency between the opaque and transparent shadows. When and where is this defined in the display options

I know this was written a while ago, but using the sun command creates a sharp shadow comparable to the sketchup style shadow you’re looking for. Just in case someone googles this and can’t figure it out like I did.

1 Like