Help with custom display modes

I just finally upgraded from rhino 4 to 5 and I am loving it so far. One of the things I really like are the many display modes available and the ability to customize them. However, I am having difficulty achieving the look I am really after.

Now I know it is my probably taboo to mention Sketchup here so I am going to add a disclaimer first: overall I hate sketchup. Modeling in it makes me want to pull all my hair out. I started using rhino about 8 years ago and ever since I can’t even imagine trying to build a 3D model in it.

So with that said the one thing Sketchup has going for it are the many display styles available. Being able to take a screen capture of just the shadows with the geometry not showing is great when doing post processing in Photoshop.

So what I am trying to achieve is a display mode for displaying simple conceptual ideas where the geometry is a solid color (say white) and the lighting casts nice crisp shadows. I have gotten close by using the shaded display as a base but whenever I turn the lighting most of the imagery turns from a nice crisp white back to the normal grey you see with shaded display. And my ground plane with it’s nice texture file (from a png) turns all white.

So what am I doing wrong? I can’t find any sort of detailed tutorials on playing with display modes online. They all just go over the basics. Any ideas would be super appreciated and sorry for the long post. Thanks

Hi Jeff - something like this?

-Pascal

Um, yeah!! what sort of settings are you using. And also what sort of lights are you using? I can’t get the shadows that crisp and at times the display is not consistent even when I don’t change anything.

Also, any idea how to retain the plane with the texture on it? I made it using the picture frame command and it looks great and shows up well in my viewports but once I add lighting it just turns white.

That is seriously exactly what I am looking for

Hi Jeff -

Sorry, I don’t know why this image shows up as gigantic in the post, at least it does here. Click on it to see the whole thing.

I set it to use ‘Scene lighting’, that is, always use whatever lights you have set up,

<img src=“https://global.discourse-cdn.com/mcneel/uploads/default/original/3X/6/6/666b3460b0e6a1886976e3134ca898bac23b2a1f.png” width="561"height=“500”>

then, back in Rhino turned on the Sun and turned off ‘skylight’.

But you can place a directional light, use Custom lighting instead of ‘Scene’ above, then tell custom lighting to use the current scene lights and convert that to a permanent setting for the display mode:

I am not sure what you are referring to there…

-Pascal

I am still not getting any shadows. Tried just the sun, tried a directional light, not getting single shadow.

Here is a shot of the display mode with some objects in it

And here are the settings:

You can see in the top left a piece of the floor plane that I would like to have displayed as well, but there is always photoshop

Tell me if you see something that I am missing. Really appreciate all of this help.

I guess that looks like it ought to work - try importing mine into Options>View >DisplayModes.
Copy of Shaded_PG.ini (11.2 KB)

-Pascal

Thank you. Yours seems to work just fine. Weird, it doesn’t look any different than how mine was set up.
Much appreciated.

Can you share your “My Mode” settings? :stuck_out_tongue: